-   Slackware (
-   -   Slackware, Broadcom NIC Internet Trouble (

Chryzmo 09-09-2005 02:28 PM

Slackware, Broadcom NIC Internet Trouble
Hey all,

I know I have another post not too far down, but the first post is really long and now I think it is full of useless information. I setup Slackware 10.1 on my DELL Inspiron 6000 laptop. The Broadcom 400x NIC is detected without a problem and netconfig tells me that it went through the DHCP setup processes, but I still cannot get on the internet. I cannot ping anything but and my web browsers and chat clients do not connect.

I installed Ubuntu, which detected the card and was able to get online without a problem. I am not sure why this is though. Maybe slackware is having trouble getting an IP address through DHCP because I am at my college? I have the Windows ipconfig print out and the Ubuntu ifconfig print out, so maybe if I tried to manually tell Slackware the DHCP settings, that would work?

Another idea, could it be the kernel? Ubuntu runs on a 2.6 kernel whereas Slackware runs on the 2.4 kernel. Although I think that would only matter if Slackware couldn't detect the card at all, right?

I have never messed with networking type stuff except for setting up a small home network at my house. So, I may be completely wrong here, but it's all I've got at the moment.

If anyone could tell me how I'd go about manually setting up my network settings for DHCP or perhaps offer another suggestion I would greatly appreciate it.


Bonzodog 09-09-2005 03:07 PM

What does $ifconfig tell you? does it report eth0 up? or just lo?

Chryzmo 09-09-2005 03:08 PM

just plain 'ifconfig' reports only lo

if i do 'ifconfig -a' it shows eth0 and lo, but eth0 does not have an inet address.

Bonzodog 09-09-2005 03:17 PM

ok, so have you tried bringing up the interface using '$ifconfig eth0 up'?

Chryzmo 09-09-2005 04:18 PM

I brought up eth0, then it showed up when I did '$ ifconfig', however it still does not have an "inet address"


$  ifconfig eth0 up
$  ifconfig

eth0      Link encap:Ethernet  HWaddr 00:12:3F:D7:D4:F3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:2
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:1188 (1.1 Kb)

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

I think this means that the card itself is detected and working, my computer is just not being assigned an IP address.


Chryzmo 09-10-2005 12:21 PM

Anyone have any other ideas? Is anyone familiar with how Ubduntu's network wizard does it's configuration? Ubuntu allowed me to get online without a problem.

truckers_atlas 09-10-2005 06:18 PM

Which version of Slack are you using? I have a Dell dimension desktop and couldn't do anything with Slack 10.0, but 10.1 worked like a charm. As I recall it had to do with the higher kernel version, though both were 2.4.x . I know I couldn't do any internet stuff, but I don't think I did as much investigation as you have so I know if this will help at all...

All times are GMT -5. The time now is 05:17 PM.