-   Slackware (
-   -   slackware 9.1 - X not working (

mastershake 12-03-2003 03:17 AM

slackware 9.1 - X not working
I've been using Redhat 9.0 for two months. I just installed Slackware 9.1.
Everytime I try to start up XWindows the system locks up. I type "startx" and then see the same screen everytime: some vertical lines of various colors (no text).
X worked fine on Redhat. I'd appreciate any help (even stating the obvious).


Y0jiMb0 12-03-2003 03:21 AM

to me all points to the configuration file of the X server ("/etc/X11/XF86Config"); check if everything is right there.

ceedeedoos 12-03-2003 03:23 AM

sounds indeed like an X configuration problem ...

try running xf86config as root ... you'll be able to create a new config file and place it where it belongs ... if it works then, you know the problem was the generic config :)

mastershake 12-03-2003 03:58 AM

after configuring i got an error when trying to use millions of colors (24b)
i then tried the next lower setting (16b). I then got this message:

EE Virtual height (0) is too small for the hardware (min 1)

i got x to work at 256 colors......but....who really wants to live with that?

my graphics card is a sucky 4MB, but i've always been able to handle millions of colors. and for some reason, when i did get x working (with few colors), the resolution was something atrocious......didn't hand count the pixels but it was worse than 600x400.


mastershake 12-03-2003 04:19 AM

well.......i got it working.

i guess specifying that Intel is the manufacturer of my video card did, because really, thats the only thing i changed. goes to show ya

thanks for the help

All times are GMT -5. The time now is 10:48 AM.