-   Slackware (
-   -   Slackware 9.0 rebooting itself (

Mattias 04-21-2003 12:56 PM

Slackware 9.0 rebooting itself
Hi. I got a problem with Slackware 9.0. It keeps rebooting itself like 30 seconds after the loginprompt appears, just after a fresh install. The first time I installed it, everything worked except my mouse. So I reinstalled, now the mouse works (the 30 seconds I'm in) but as I said I got this problem with it rebooting.

Has anyone got any problem similar to this or does anyone know what I possibly could have done wrong during install? I got Windows XP on the same computer and since that works 100% I'm confused, I thought Linux were more stable :O

There's a repeating error during boot of Slackware which I think has to do with my soundcard which is an integrated VIA AC97 and it says something like insmod and i810 blabla I don't know 100%, something like that. But I don't think it's rebooting because of that since I got that error the first time, when it worked, too.

Thanks in advance,

fskmh 04-21-2003 01:14 PM

Hi Mattias

If you're certain that this reboot is not caused by fsck then try disabling hotplug support. Bearing in mind you only have 30 seconds, try something like this:

chmod 644 /etc/rc.d/rc.hotplug

If this allows you to stay logged on for longer then you need to figure out which kernel module is the culprit, and add it to /etc/hotplug/blacklist. Better still, recompile the kernel to suit your hardware better.

BTW, try fixing a hardware issue this quickly in XP ;-p.

Mattias 04-21-2003 01:21 PM

OK thanks. I'm going to try it.

Sorry but what is fsck, I'm not certain it is not caused by that :)

fskmh 04-21-2003 01:31 PM

When an inconsistency is detected on a hardware partition during mounting, the system gives you an option to do some manual system maintenance by pressing ctrl-d and giving the root passwd so that you are dropped into a root shell to manually fsck the partition. If you do nothing the system reboots and attempts to mount the partition again. This is one explanation for what you may be experiencing.

Mattias 04-21-2003 01:33 PM

I'm never given the option to press CTRL+D or atleast I can't see it. Is there a way I can check this? And what am I supposed to do with fsck then?

webtoe 04-21-2003 01:46 PM

You may also may be able to get to a more permanent command line by going into single user mode. Not sure if this will suffer the same problems but its worth a try if all else fails.


fskmh 04-21-2003 01:54 PM


If the system is not asking you to manually fsck a partition then you don't need to worry about this. It was just one possible explanation for the system's behaviour :-D.

Mattias 04-21-2003 02:24 PM

Alright, reinstalled again, tested ext2 instead of ext3... Now fsck appears every time after the system reboots itself. But it still doesn't work. I also tried 'chmod 644 /etc/rc.d/rc.hotplug'. No result.

Please help, anyone? I want to start using Linux again :/

Tinkster 04-21-2003 04:24 PM

What happens if you give it
single as a parameter on the lilo-prompt?

Does it also reboot then, or does the
problem only occur in multiuser-mode?

If it doesn't, browse through your /var/log
and see whether you can find any indication
as on why the box keeps rebooting ...

Hint: use ls -ltr /var/log to see which files have
been written to most recently :}


DaOne 04-21-2003 05:21 PM

What is the output of lsmod? If i810-tco is loaded, do rmmod i810-tco. bang away for a few minutes...if it doesn't reboot, then this module is your problem. If it is, you can remove "Watchdog timer" support from the kernel (nothing in the ( )...), then recompile.

Mattias 04-21-2003 05:40 PM

OK first i tried the single user tip and it never rebooted so I had time checking logs etc. Found some stuff with i810_audio and i810_rng in /var/log/syslog saying "Audio controller supports 6 channels", "Primary codec not ready" and "RNG not detected".
Told me nothing, so I got back here for more help, I saw DaOne's post and tried that first. Worked! Removing the i810-tco module made it to not reboot.
I'm going to recompile the kernel now, thanks for the help everyone.

Just one more question, if I wouldn't recompile the kernel, how would I stop i810-tco from loading every time? Can't find it in any /etc or /etc/rc.d files...

webtoe 04-21-2003 06:56 PM

Possibly have a look in /etc/modules.conf? i don't actually know why this module is getting loaded at all since i didn't think that watchdog cards were very common in anything but a server (and even then). so why it was on when you installed unless somehow slack detected a watchdog card (or mistakenly detected it). I grepped my start up scripts and there's nowt there either.


Tinkster 04-21-2003 07:13 PM

I wouldn't know why it's loaded, either...
In lsmod, does it state any modules that
are using it (and thus trigger it's loading


Excalibur 04-21-2003 07:54 PM

I would think you could delete the module itself from the /lib/modules/2.4.20/kernel/drivers/char tree. But if the default kernel build command "make modules_install" is run, it will reinstall it. It would have to be disabled in the kernel config before it was rebuilt. I reviewed the modules.dep file and nothing appears to have a dependacy on the i810-tco module. And the module itself does not have any dependacies.

If it is not being called through the hotplug feature and not from rc.modules. Then where would it be loading from? In Slack the /etc/modules.conf file is empty.

Mattias 04-21-2003 07:58 PM

As I said earlier I can't find where it's getting loaded. Can't find it in any /etc or /etc/rc.d file.

This is what 'lsmod' shows about i810-tco.

i810-tco 3088 0 (unused)

I tried recompiling the kernel, Watchdog timer was already removed and it made my usb-mouse not working. So I'd like to know how to do to stop i810-tco from starting every boot without having to recompile the kernel (even if I would like that too, but that's a future problem)

Note: It tries to load i810-tco, i810_audio, i810_rng and 8139cp (I have Realtek 8139 network card, but I modprobe 8139too in /etc/rc.d/rc.netdevice) like 20 times. That makes me even more confused. But I renamed the drivers and that keeps i810-tco from loading and that works for the time...

All times are GMT -5. The time now is 01:39 AM.