-   Slackware (
-   -   Slackware 9.0 modprobe issues (

GreatHornDragon 05-27-2003 12:10 AM

Slackware 9.0 modprobe issues

I am trying in vain to get my network card working under Slackware 9.0. I think I have discovered that the problem is not with the hardware but with the installation or distribution.

Basically, whenever rc.modules tries to modprobe a module, it is looking for /lib/modules/2.4.18/modules.dep.

The problem is, /lib/modules/2.4.18/modules.dep does not exist, but /lib/modules/2.4.20/modules.dep does.

It looks like somehow I have a heap of modules that will only work with 2.4.20, and my kernel version, for some reason, is 2.4.18.

I tried creating a symbolic link to this directory so it found what it wanted, but it tells me they won't work with my kernel version.

So my question is... do I need to update me kernel version for these modules to work? It seems a bit stupid to me to have a distribution with modules that don't work for it.

Any help appreciated. Thanks.


Tinkster 05-27-2003 01:12 AM

Would be interesting to know where
you got the old kernel from :)

However, I'd recomend to
a) reinstall the kernel-package of the CD
b) get the kernel source and roll your own.


GreatHornDragon 05-27-2003 01:31 AM

Well the CD came from a Slackware 9.0 ISO that I downloaded from the Slackware site, so I'm buggered if I know how or why it happened :) It was on a fresh hard drive too.

How might I reinstall the kernel package?

If that fails I will just compile a 2.4.20 kernel.

Thanks for the help.


Tinkster 05-27-2003 01:40 AM

mount /mnt/cdrom
installpkg /mnt/cdrom/slackware/a/kernel-ide-2.4.20-i486-5.tgz
installpkg /mnt/cdrom/slackware/a/kernel-modules-2.4.20-i486-7.tgz


big_belly 06-26-2003 01:40 AM

I am having a similar problem too. I have yet to find the answer but seem to have identified the source of the problem. The problem is probably the kernel. With the Slack 9 iso that I downloaded and installed I noticed that no modules were being loaded. For some reason 2 kernels were installed in /boot:


both are the same file size (the correct size for a 2.4.20 kernel) but with different md5 checks.

However kernel 2.4.18 is loaded!
uname -a says 2.4.18
the welcome message on the first tty says 2.4.18
insmod is looking for 2.4.18 modules and will not accept 2.4.20 modules - appropriately for a 2.4.18 kernel

Something important to note here is that these two kernel files have different md5 checks - but both load a 2.4.18 kernel!?!

However it is a slackware 9 install (my welcome to Slackware 9 email tells me so ;-) ). I have tried 3 different mirrors with the same results, and the md5 check out ok on each and are identical (as they should be). I'm lost as to what the problem is or more importantly what the solution is!

GreatHornDragon 06-26-2003 01:48 AM

I managed to fix mine by copying the kernels from the CD and changing LILO to reflect it.

I used bootdisks for mine as the CD wouldn't boot, not sure what your setup was. I think the problem occured when I chose to use the kernel from the bootdisk instead of one from the CDROM. If thats what you did as well, that is probably the source of the problem.

big_belly 06-26-2003 01:59 AM

I ran through the standard install on the cd. I therefore used the kernels from the CD also(?)

You manually took your kernel from the cd - yes?

GreatHornDragon 06-26-2003 06:34 AM

Yep, refer to Tinkster's post above.

jadugarr 07-22-2003 02:59 PM

I also had problems when loading slackware 9 from a bootdisk. The kernel loaded from the disk is 2.4.18, instead of the 2.4.20 that is installed ... this causes all kinds of problems. If anyone else has this problem and has to use a bootdisk, I would boot from a slack cd, and make a new bootdisk using the kernal that is installed on your system.

All times are GMT -5. The time now is 01:10 PM.