-   Slackware (
-   -   Slackware 9.0 kernel compilation arggghh (

vurtuali 06-15-2003 08:51 AM

Slackware 9.0 kernel compilation arggghh
Hello people,

This is yet another post about kernel (2.4.20) compilation under Slackware 9.0. I have been scratching my head :scratch: about this for days now and have read LARGE amounts of docs, forums and helpfiles with no result. I have seen several similar posts in this forum, but still no solution!! I am a reasonably new newbie so your patience is appreciated.

Here goes...

I have recently installed Slackware 9.0 on my box and need to compile a new kernel to support my Cmedia sound chip. I have gone through the usual process, editing lilo.conf and moving the original kernel, make menuconfig, make bzImage, make install, make modules etc........ When booting with this new kernel, I get the message: decompressing kernel.......... Then the screen goes blank, I suspect that it continues to boot as it's still hitting the hard drive and the keyboard is not locked.

I am positive that it is not down to the compilation options as I have never had this problem with linux2.4.20 compilation on other distributions (Mandrake, Debian). Is there anywhere the config details for bare.i are posted so I can compare and contrast???

What's going on? Any pointers will earn you a substantial reward in the afterlife (afterlife not guaranteed)


C++freak 06-15-2003 09:39 AM

when you run make menuconfig
Select "Code maturity level options" and set "Prompt for development and/or incomplete code/drivers".
Then select "Console drivers" set "Support for frame buffer devices" to built-in (even if it says EXPERIMENTAL)

Qzukk 06-15-2003 12:22 PM

Actually, I suspect that his problem may be that he did not turn on support for consoles at all.

In "make menuconfig" go to the bottom to the "Console drivers" section. Make sure that VGA Text Console is enabled, and if you wish to use the framebuffer, that the correct frame buffer driver is enabled as well. Then, go to the "Character Devices" section, and make sure that you have "Virtual Terminal" turned on, as well as "Support For Console on Virtual Terminal".

This should get you going again.

Now, the question is, "the screen goes blank" ... if you are currently using the framebuffer, and you selected the wrong driver or entered an invalid video mode, then it may be that the monitor is turning itself off. If you have all of the above options enabled, try building a kernel *without* framebuffer support and see if that works. (leave in VGA Text and the Virtual Terminal options)

vurtuali 06-16-2003 02:03 PM

:D Thanks for that. It was down to me not selecting support for frame buffer devices. Well I feel stupid.... a bit blindingly obvious when you know the answer. Anyhow thanks again, problem solved

All times are GMT -5. The time now is 11:40 AM.