-   Slackware (
-   -   Slackware 8 Window Managers (

xcobra 06-08-2002 06:44 AM

Slackware 8 Window Managers
I installed slackware 8 (full without promps). I'm new to this and have many questions. I've also downloaded all the docs but couldn't find my questions.

1. Hi another question: I want to run another windowsmanager; just for fun. So log in as root; typed xwmconfig and i scrolled down to xinitrc.wmmaker windowmaker pressed ok, then i typed startx againg and it boots kde strange... I installed the full editions so windowmaker should start right? Tell me if I done something wrong or should download wmaker?....

3. Well in the case I should download; it's easy to untar, gunzip from the shell and it's explained well in the tutorials. But whats the best directory to untar and unzip in ?... I use the user/home directory but I don't want to make a mess from my system...

acid_kewpie 06-08-2002 06:53 AM

please do NOT double post

spook 06-08-2002 09:19 AM

If i remember correctly in order to get windowmaker to work you have to do "wmaker.inst" for any user that wants to use it.
Hope this helps.

kdaru 06-08-2002 04:38 PM

To see if you have windowmaker on your system, type

whereis windowmaker

and see if it comes back with a path, e.g., /usr/X11R6/bin/windowmaker. If it just says "windowmaker:", then you have to download and install.

I find it easier to edit .xinitrc directly (with vi or whatever) to force it to start my windowmanager of choice. At the end of the file it should have a line like


Comment this out and write

exec windowmaker

Keep in mind also that there may be >1 .xinitrc scattered over your system: one in your home dir, one in /root, and one in /usr/X11. Changes to your home .xinitrc will not be seen if you startx as root and root has its own .xinitrc.

Re where to put new packages: I've been using /opt, but I don't know if that's right or not.


trickykid 06-08-2002 06:03 PM

Actually in Slack 8, there won't be any xinitrc files by default in any users home directory.

The default xinitrc scripts are located in /etc/X11/xinit
where you'll find many different Window Managers installed.

There you should find a xinitrc.wm, can't be for certain not at my Linux box at the time. The easiest way to setup your default Window Manager or Desktop in Slack is this way:

To setup globally for all users, say for instance you wanted everyone to use window maker by default:

1. cd /etc/X11/xinit
2. If your have a xinitrc link file, remove it like this:
rm xinitrc
3. ln -s xinitrc.wm xinitrc
4. Now you should have a new xinitrc linked to xinitrc.wm which makes your default desktop Window Manager for all users on the system.

Now if you want to make a default desktop for a particular user, the easiest way to do this is to create a link like above in the users home directory to point to the desktop they want to use.
Say user1 wants gnome as their desktop, you can do these steps from their home directory:

ln -s /etc/X11/xinit/xinitrc.gnome .xinitrc

And this should place a hidden link .xinitrc that makes Gnome their default desktop. You don't specifically have to put the period in front of the xinitrc, but it's usually good to, so its hidden and can be viewed with a ls -al command to list all files.

Hope this helps in anyway. And If you did a full install of Slack8, Window Maker is installed or should be at least. Not sure of the correct file like I mentioned before for windowmaker but you should know once you see the list of xinitrc scripts. As far as I know though, it should be xinitrc.wm though..

Also about installing files.. I tend to download to my home directory and install from there.

Sfin 06-08-2002 06:28 PM

The correct fileame is:


well that is what it is on my Slack.

Just giving you some help tricky ;)

acid_kewpie 06-08-2002 06:51 PM

?!?!?!?! How hard is it NOT to reply to double posts??? criminy!

trickykid 06-08-2002 08:34 PM


Originally posted by acid_kewpie
?!?!?!?! How hard is it NOT to reply to double posts??? criminy!
I closed the other one.. quit wasting bandwidth acid ! ;)

Thanks sfin, I wasn't for sure cause first its not installed on my box I ssh into from work, and second, my other box was turned off so I couldn't access it to see since it is installed on it.. :)

Dvorak2099 06-12-2002 07:36 AM

Well I think I know the answer to this
well i think it is simple enough to realize that you just can't highlight your window manager and press enter you must highlight it in xmwconfig then press space then enter to select it. Glad I could help.

All times are GMT -5. The time now is 09:43 PM.