-   Slackware (
-   -   Slackware 8.1: "installpkg" command not working? (

tigerflag 10-08-2002 11:05 PM

Slackware 8.1: "installpkg" command not working?
I'm new to Slackware, new to command-line, totally frustrated...
Just so you know, I've RTFMed, studied man pages (after fighting with BASH to figure out how to do ANYthing), searched all over the Internet before finally bothering you guys.
I have the 4-cd boxed set from Slackware, along with the Slackware Linux Essentials book. Did a full installation, except for Emacs. Trying to install some packages from the sourcecode/additional applications cd, in the "extra" directory.

I've tried "su" to root, and I've tried logged in as root. Same results both ways. Here's what happens:

I cd to "/mnt/cdrom" and then do "ls".
I manage to get to the "Extra" folder and do "ls" again.
I see a package, say, blackbox.
Go into the blackbox folder and see "blackbox-0.62.1-i386-1.tgz" along with a README.txt or something like that.
I do "installpkg blackbox-0.62.1-i386-1.tgz" (w/out the "") and get the following:

"cannot install blackbox-0.62.1-i386-1.tgz package does not end in .tgz ''

Same thing happenes when I try to install Java Runtime Environment from the same Extra folder. I figure I'm doing something wrong that will be obvious to someone, yet when I did "installpkg parted-blah-blah.tgz" it worked perfectly!!!

Using the shell is all hit-and-miss (mostly miss) with me, so if you have any suggestions, can you please tell me EXACTLY what to type?

Thanks for your time...

Siri Amrit

neo77777 10-08-2002 11:53 PM

Can be a bad archive,
file /path/to/blackbox/blackbox-yada.yada.tgz
What do you get?

tigerflag 10-09-2002 03:41 PM

Ok, I did all of the following both as user and after su to root. Tried the path you recommended as well as the long path with /mnt/cdrom. Got the same result each time:

input: file /path/to/blackbox-0.62.1/blackbox-0.62.1-i386.tgz
output: Can't stat '/path/to/blackbox-0.62.1/blackbox-0.62.1-i386.tgz' (No such file or directory).

input: file /path/to/java2-runtime-environment/j2re-1.4.0_01-i586.tgz
output: Can't stat '/path/to/java2-runtime-environment/j2re-1.4.0_01-i586.tgz' (No such file or directory).

input: file /path/to/mnt/cdrom/extra/java2-runtime-environment/j2re-1.4.0_01-i586.tgz
output: Can't stat '/path/to/mnt/cdrom/extra/java2-runtime-environment/j2re-1.4.0_01-i586.tgz' (No such file or directory).

input: file /path/to/parted-1.6.1/parted-1.6.1-i386.tgz
output: Can't stat '/path/to/parted-1.6.1/parted-1.6.1-i386.tgz' (No such file or directory).

input: file /path/to/mnt/cdrom/extra/parted-1.6.1/parted-1.6.1-i386.tgz
output: Can't stat '/path/to/mnt/cdrom/extra/parted-1.6.1/parted-1.6.1-i386.tgz' (No such file or directory).

Any ideas/suggestions are MOST appreciated!

neo77777 10-09-2002 07:02 PM

What I ment with /path/to prefix you have to substitute with a real path to the file. You said you tried "the long path", so in that long path get rid of /path/to prefix
file /mnt/cdrom/extra/blackbox-0.62.1/blackbox-0.62.1-i386.tgz

bynaar 10-09-2002 07:18 PM

I have experienced the same phenomen . . .

qickfix: run pkgtool as root instead , and chose to install from other directory option.

I worked out fine for me.

It would be nice to know why the installpkg tool 'don't wanna play' so to speak . .

tigerflag 10-12-2002 03:44 PM

Sorry for taking so long to get back to the forum with this. Life took a few wide turns the last few days...

When I typed in the correct file path for blackbox it returned the following full information:
gzip compressed data, deflated, original filename, 'blackbox-0.62.1-i386-1.tar' last modified: Mon May 6 00:07:39 2002 max compression, os: Unix

When I did the same for java2-runtime-environment it also returned full information on it. Exactly same as above, only specific to: 'j2re-1.4.0_01-i586-1.tar' for the original filename, and different dates for it.

Still, when I tried to do installpkg, it failed with 'can't stat...(No such file or directory). Maybe it's typos on my part, but I'm trying to be really careful.

On a better note, thanks to Bynaar's instructions, I was able to use pkgtool.

Still can't figure out how to install something like OpenOffice 1.0.x from a .tar file, but that can wait for another day...

All times are GMT -5. The time now is 08:40 AM.