-   Slackware (
-   -   slackware 8.1 floppy drive not working (

lto 07-18-2002 12:44 AM

slackware 8.1 floppy drive not working
After running slackware 8.1 on my home machine for a few day, I notice that I could not mount the floppy drive. I installed the slackware 8.1 via cdrom directly. dmesg show kernel detected 1.44M floppy drive; however, it also said no floppy0 controller found. When I try to mount the /dev/fd0, system returns error message mount: /dev/fd0 is not a valid block device. I used stock usb.i kernel. Any Idea how to fix this? Thanks!

Excalibur 07-18-2002 06:45 AM

Boot the Slack 8.1 CD and see if the floppy drive works using the bare.i kernel. If it does, then it is a kernel issue. If it does not, then probably hardware problem.

lto 07-18-2002 07:59 PM

I've tried booting from the live cd with bare.i; The system is still not able to mount the floppy. The weird thing is that I can start the system with a linux boot floppy made by a different machine. Once booted, the floppy drive is in-accessible! any idea? Thanks!

Excalibur 07-18-2002 10:11 PM

If you are not logged in as root then it could be a permission issue. Attempt it as the root user. I would think the command "su root" would do.

But in the regard of what you have stated my next thought then would be the file system on the floppy disk. What is the format of the diskette, FAT or ext2? Or depending on the method you use to mount.

If FAT (DOS), then use this to mount

mount -t vfat /dev/fd0 /mnt/floppy

If ext2, then use this to mount

mount -t ext2 /dev/fd0 /mnt/floppy

You could also attempt to format it ext2.

mke2fs /dev/fd0

I can't imagine any kernel being built not including floppy support and bare.i includes it. But the /dev/fd0 might be missing or incorrect. It should be listed in the /dev directory as (use "ls -l /dev/fd0" lowercase L's)

brw-rw---- 1 root floppy 2, 0 May 14 1996 /dev/fd0

If incorrect then delete it, recreate. If missing then create it. The date is not important. To create it use

mknod /dev/fd0 b 2 0

Let's see how far this gets. After a mount attempt, you can use the "dmesg" command on another console screen to see any errors that might be reported by the kernel that might be related.

lto 07-19-2002 10:24 PM

well, I spent 2 hours re-install the slackware with bare.i kernel; The floppy drive is working now. However, gpm does not work with my usb mouse anymore :( . Fortunately, the usb mouse work under X by using /dev/psaux and Protocol "ImPS/2". I guess its time to customize my slackware kernel. Thanks!

lto 07-19-2002 10:28 PM

Oh, where the heck is gpm invoked while booting up? I know it resides in /etc/rc.d/rc.gpm. Thanks!

Excalibur 07-19-2002 11:32 PM

The init level 3 file, rc.M, is where the rc.gpm file is called. If you want to terminate the execution though. Just do

chmod 000 /etc/rc.d/rc.gpm

It will disable the script and it will not be able to execute from any program. The rc.M script checks to see if it is executable before attempting to call it.

Oh, congrats on resolving your fd0 problem. I still don't understand it.

lto 07-20-2002 12:00 AM

Thanks! It seems like the code in usb module some how creates a conflict with the floppy controller. Btw, I have a HP pavilion 7970 with winXP, FreeBSD 4.6, and slackware 8.1. I was trying to use the floppy to transfer the slackware's boot sector so I could use it with the NT boot manager. That's when I found out the drive was not working at all. All are working fine now. Oh, I just heard that debian 3.0 released today. I think I might give it a try. Thanks again!

All times are GMT -5. The time now is 11:57 AM.