LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-09-2024, 06:08 PM   #1
rocknrobin
Member
 
Registered: Apr 2020
Location: Texas
Distribution: 14.2
Posts: 55

Rep: Reputation: Disabled
Slackware 15.0 distro ntpd will not start consistently after reboot


Hello again. I recently did updates on my Slackware 15.0+ distro and noticed that the ntp daemon was not starting after reboot. I could manually start it after reboot and waiting a few minutes with :
/etc/rc.d/rc.ntpd start


I checked the log entries. Before the last ntp update for 64-current the log would reflect this upon reboot:

Code:
 3 Jun 04:40:04 ntpd[4154]: initial drift restored to 13.538300
 3 Jun 04:40:04 ntpd[4154]: Listen and drop on 0 v6wildcard [::]:123
 3 Jun 04:40:04 ntpd[4154]: Listen and drop on 1 v4wildcard 0.0.0.0:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 2 lo 127.0.0.1:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 3 eth0 10.160.134.65:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 4 eth1 10.160.160.15:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 5 lo [::1]:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 6 eth0 [fe80::9a90:96ff:fec5:3b5e%2]:123
 3 Jun 04:40:04 ntpd[4154]: Listen normally on 7 eth1 [fe80::a26:aeff:fe3c:2217%3]:123
 3 Jun 04:40:04 ntpd[4154]: Listening on routing socket on fd #24 for interface updates
 3 Jun 04:40:04 ntpd[4154]: kernel reports TIME_ERROR: 0x2041: Clock Unsynchronized
 3 Jun 04:40:04 ntpd[4154]: kernel reports TIME_ERROR: 0x2041: Clock Unsynchronized
Note...Even though the last two entries show clock unsynchronized the network timing protocol was working. I could evoke the command

ntpq -p

and see the peers and the one it was synched to.

After the update however this is what the log reflected after reboot.

Code:
 8 Jun 16:31:18 ntpd[1206]: initial drift restored to 14.560181
 8 Jun 16:31:18 ntpd[1206]: Listen and drop on 0 v6wildcard [::]:123
 8 Jun 16:31:18 ntpd[1206]: Listen and drop on 1 v4wildcard 0.0.0.0:123
 8 Jun 16:31:18 ntpd[1206]: Listen normally on 2 lo 127.0.0.1:123
 8 Jun 16:31:18 ntpd[1206]: Listen normally on 3 eth1 10.160.160.15:123
 8 Jun 16:31:18 ntpd[1206]: Listen normally on 4 lo [::1]:123
 8 Jun 16:31:18 ntpd[1206]: bind(21) AF_INET6 [fe80::a26:aeff:fe3c:2217%3]:123 flags 0x811 failed: Cannot assign requested address
 8 Jun 16:31:18 ntpd[1206]: unable to create socket on eth1 (5) for [fe80::a26:aeff:fe3c:2217%3]:123
Then when I tried to invoke any ntpq command I got connection refused.

If I wait a few minutes I can start the ntpd with /etc/rc.d/rc.ntpd start and it will start running:

Code:
 8 Jun 16:38:35 ntpd[1838]: initial drift restored to 14.560181
 8 Jun 16:38:35 ntpd[1838]: Listen and drop on 0 v6wildcard [::]:123
 8 Jun 16:38:35 ntpd[1838]: Listen and drop on 1 v4wildcard 0.0.0.0:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 2 lo 127.0.0.1:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 3 eth0 10.160.134.65:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 4 eth1 10.160.160.15:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 5 lo [::1]:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 6 eth0 [fe80::9a90:96ff:fec5:3b5e%2]:123
 8 Jun 16:38:35 ntpd[1838]: Listen normally on 7 eth1 [fe80::a26:aeff:fe3c:2217%3]:123
 8 Jun 16:38:35 ntpd[1838]: Listening on routing socket on fd #24 for interface updates
 8 Jun 16:38:35 ntpd[1838]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
 8 Jun 16:38:35 ntpd[1838]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
I then added /etc/rc.d/rc.ntpd start to my rc.local file and it would only start after reboot inconsistently. The only way I could get the ntpd to start reliably was as I mentioned, wait a few minutes and start the ntp daemon manually. Here are the log entries with the ntp daemon start command added to rc.local when it works.

Code:
 8 Jun 16:20:34 ntpd[1400]: initial drift restored to 43.568237
 8 Jun 16:20:34 ntpd[1400]: Listen and drop on 0 v6wildcard [::]:123
 8 Jun 16:20:34 ntpd[1400]: Listen and drop on 1 v4wildcard 0.0.0.0:123
 8 Jun 16:20:34 ntpd[1400]: Listen normally on 2 lo 127.0.0.1:123
 8 Jun 16:20:34 ntpd[1400]: Listen normally on 3 eth1 10.160.160.10:123
 8 Jun 16:20:34 ntpd[1400]: Listen normally on 4 lo [::1]:123
 8 Jun 16:20:34 ntpd[1400]: bind(21) AF_INET6 [fe80::fae4:3bff:fe5a:b0a1%3]:123 flags 0x811 failed: Cannot assign requested address
 8 Jun 16:20:34 ntpd[1400]: unable to create socket on eth1 (5) for [fe80::fae4:3bff:fe5a:b0a1%3]:123
 8 Jun 16:20:36 ntpd[1796]: initial drift restored to 43.568237
 8 Jun 16:20:36 ntpd[1796]: Listen and drop on 0 v6wildcard [::]:123
 8 Jun 16:20:36 ntpd[1796]: Listen and drop on 1 v4wildcard 0.0.0.0:123
 8 Jun 16:20:36 ntpd[1796]: Listen normally on 2 lo 127.0.0.1:123
 8 Jun 16:20:36 ntpd[1796]: Listen normally on 3 eth1 10.160.160.10:123
 8 Jun 16:20:36 ntpd[1796]: Listen normally on 4 lo [::1]:123
 8 Jun 16:20:36 ntpd[1796]: Listen normally on 5 eth1 [fe80::fae4:3bff:fe5a:b0a1%3]:123
 8 Jun 16:20:36 ntpd[1796]: Listening on routing socket on fd #22 for interface updates
 8 Jun 16:20:36 ntpd[1796]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
 8 Jun 16:20:36 ntpd[1796]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
 8 Jun 16:20:40 ntpd[1796]: Listen normally on 6 eth0 10.160.134.60:123
 8 Jun 16:20:40 ntpd[1796]: Listen normally on 7 eth0 [fe80::da5e:d3ff:fe82:4915%2]:123
 8 Jun 16:20:40 ntpd[1796]: 51.81.209.232 local addr 10.160.160.10 -> 10.160.134.60
 8 Jun 16:20:40 ntpd[1796]: 23.157.160.168 local addr 10.160.160.10 -> 10.160.134.60
 8 Jun 16:20:40 ntpd[1796]: 5.78.62.36 local addr 10.160.160.10 -> 10.160.134.60
 8 Jun 16:20:40 ntpd[1796]: 71.19.144.140 local addr 10.160.160.10 -> 10.160.134.60
 8 Jun 16:20:40 ntpd[1796]: new interface(s) found: waking up resolver
As can be seen the initial start of ntpd fails with the socket error and then after starting in rc.local it successfully starts with the entries for peers.


Additional info...I have another Slackware 15.0 image running that only has the ETH0 interface and ntp starts up fine every time with that one. On the one with two Ethernet interfaces ETH1 is behind a point to point VPN which for all practical purposes does not have any Internet access on the far end so it can't receive timing updates on that interface.

Is there a configuration I am missing or is there a way to configure which interface is used for the timing updates? Thanks in advance.

Last edited by rocknrobin; 06-09-2024 at 06:21 PM.
 
Old 06-09-2024, 06:13 PM   #2
lostintime
Member
 
Registered: Dec 2021
Posts: 214

Rep: Reputation: Disabled
Remove /etc/rc.d/rc.ntpd from rc.local. Then chmod +x /etc/rc.d/rc.ntpd. The script will be launched from rc.M.

Last edited by lostintime; 06-09-2024 at 06:14 PM.
 
Old 06-09-2024, 06:28 PM   #3
mrsam
LQ Newbie
 
Registered: Jan 2024
Distribution: Fedora, Ubuntu, Slackware
Posts: 14

Rep: Reputation: 11
This was discussed already:

https://www.linuxquestions.org/quest...it-4175737558/

TLDR: either add the requisite pixie dust to /etc/ntp.conf to ignore your ipv6 link local address (you don't need it), or fiddle with NTPD_OPTS in /etc/default/ntpd, turning off all IPv6 options, if you don't need them.
 
Old 06-09-2024, 11:39 PM   #4
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 4,489
Blog Entries: 7

Rep: Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580
Quote:
Originally Posted by rocknrobin View Post
Is there a configuration I am missing or is there a way to configure which interface is used for the timing updates? Thanks in advance.
If you're not using IPv6 (and it looks like you may not be), then you should add the "-4" flag to the NTPD_OPTS line in /etc/default/ntp.

Once you do this, you should get consistent results on startup using the default /etc/rc.d/rc.ntpd script.
 
Old 06-10-2024, 09:17 PM   #5
rocknrobin
Member
 
Registered: Apr 2020
Location: Texas
Distribution: 14.2
Posts: 55

Original Poster
Rep: Reputation: Disabled
Replies...
lostintime...rc.ntpd is executable or I wouldn't have even been able to start the daemon manually.

Code:
root@robrutrm:~# ls -l /etc/rc.d/rc.ntpd
-rwxr-xr-x 1 root root 907 Jun  2 16:34 /etc/rc.d/rc.ntpd*
mrsam and rkelsen...Here is my /etc/default/ntp

Code:
 Default options for the ntpd daemon:
#
# -g: allow initial time correction to be Big (once only)
# -p /run/ntpd.pid: write ntpd PID to this location
# -u ntp:ntp: run ntpd as user ntp, group ntp
#
# Depending on your network, you might want to add -4 (ipv4 only)
# or -6 (ipv6 only).
#
# For other available options, see "man ntpd".

NTPD_OPTS="-g -p -4 /run/ntpd.pid -u ntp:ntp"
I added the -4 option in NTPD_OPTS and here is still what I get in the log when I reboot:

Code:
10 Jun 20:30:54 ntpd[1231]: ntpd exiting on signal 15 (Terminated)
10 Jun 20:31:35 ntpd[1205]: initial drift restored to 14.843277
10 Jun 20:31:35 ntpd[1205]: Listen and drop on 0 v6wildcard [::]:123
10 Jun 20:31:35 ntpd[1205]: Listen and drop on 1 v4wildcard 0.0.0.0:123
10 Jun 20:31:35 ntpd[1205]: Listen normally on 2 lo 127.0.0.1:123
10 Jun 20:31:35 ntpd[1205]: Listen normally on 3 eth1 10.160.160.15:123
10 Jun 20:31:35 ntpd[1205]: Listen normally on 4 lo [::1]:123
10 Jun 20:31:35 ntpd[1205]: bind(21) AF_INET6 [fe80::a26:aeff:fe3c:2217%3]:123 flags 0x811 failed: Cannot assign requested address
10 Jun 20:31:35 ntpd[1205]: unable to create socket on eth1 (5) for [fe80::a26:aeff:fe3c:2217%3]:123
I then manually started the ntp daemon, /etc/rc.d/rc.ntpd and this is what the log showed:

Code:
10 Jun 20:36:06 ntpd[1860]: initial drift restored to 14.843277
10 Jun 20:36:06 ntpd[1860]: Listen and drop on 0 v6wildcard [::]:123
10 Jun 20:36:06 ntpd[1860]: Listen and drop on 1 v4wildcard 0.0.0.0:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 2 lo 127.0.0.1:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 3 eth0 10.160.134.65:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 4 eth1 10.160.160.15:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 5 lo [::1]:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 6 eth0 [fe80::9a90:96ff:fec5:3b5e%2]:123
10 Jun 20:36:06 ntpd[1860]: Listen normally on 7 eth1 [fe80::a26:aeff:fe3c:2217%3]:123
10 Jun 20:36:06 ntpd[1860]: Listening on routing socket on fd #24 for interface updates
10 Jun 20:36:06 ntpd[1860]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
10 Jun 20:36:06 ntpd[1860]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
mrsam...when I add the fixes suggested in the link you provided from 06/01/2024 that did not really fix the issue either. I added

interface ignore ipv6 to /etc/ntp.conf (to ignore all ipv6 addresses) and then it seemed to ignore all addresses except the loopback and wildcard. Here is the log with the interface ignore ipv6 added to ntp.conf.

Code:
10 Jun 21:03:48 ntpd[1916]: ntpd exiting on signal 1 (Hangup)
10 Jun 21:03:54 ntpd[1934]: initial drift restored to 14.843277
10 Jun 21:03:54 ntpd[1934]: Listen and drop on 0 v6wildcard [::]:123
10 Jun 21:03:54 ntpd[1934]: Listen and drop on 1 v4wildcard 0.0.0.0:123
10 Jun 21:03:54 ntpd[1934]: Listen normally on 2 lo 127.0.0.1:123
10 Jun 21:03:54 ntpd[1934]: Listen normally on 3 lo [::1]:123
10 Jun 21:03:54 ntpd[1934]: Listening on routing socket on fd #20 for interface updates
10 Jun 21:03:54 ntpd[1934]: kernel reports TIME_ERROR: 0x2041: Clock Unsynchronized
10 Jun 21:03:54 ntpd[1934]: kernel reports TIME_ERROR: 0x2041: Clock Unsynchronized
Since no outside connected addresses are configured ntp is unable to interrogate any of the timing updates locations.

Last edited by rocknrobin; 06-10-2024 at 09:19 PM.
 
Old 06-10-2024, 09:49 PM   #6
chris.willing
Member
 
Registered: Jun 2014
Location: Sydney, Australia
Distribution: Slackware,LFS
Posts: 922

Rep: Reputation: 623Reputation: 623Reputation: 623Reputation: 623Reputation: 623Reputation: 623
Perhaps ntpd is starting before the network on the appropriate interface is fully established; then by the time you start ntpd manually, networking is established so ntpd starts successfully.

If you're using NetworkManager, you can delay startup of network applications until a desired network interface is up by using a script in the /etc/NetworkManager/dispatcher.d directory. Here is a script I use on a wifi connected laptop to start a mosquitto daemon only when the wlan0 interface is up - change the obvious to start ntpd:

Code:
# Start mosquttio daemon

IF=$1
STATUS=$2


if [ "$IF" = "wlan0" ]; then
  case "$2" in
    up)
      logger "Network Manager mosquitto triggered on $IF"
      if [ -x /etc/rc.d/rc.mosquitto ]; then
        /etc/rc.d/rc.mosquitto start
      fi
      ;;
     *)
      logger "Network Manager $STATUS triggered on $IF"
     ;;
  esac
fi
If you've been fiddling with starting ntpd elsewhere, ensure those other startups (like in rc.local) are not now interfering i.e. remove them. Since ntpd is normally started from /etc/rc.d/rc.M, you should comment out the section in there where it tries to start ntpd.

Scripts in /etc/NetworkManager/dispatcher.d are plain shell scripts and need to be executable (from memory). Full details are available from 'man NetworkManager-dispatcher' but I recommend keeping any script there as simple as possible.


chris

Last edited by chris.willing; 06-10-2024 at 09:51 PM.
 
Old 06-10-2024, 10:07 PM   #7
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 4,489
Blog Entries: 7

Rep: Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580
Quote:
Originally Posted by rocknrobin View Post
mrsam and rkelsen...Here is my /etc/default/ntp

Code:
NTPD_OPTS="-g -p -4 /run/ntpd.pid -u ntp:ntp"
Your "-4" is in the wrong spot... The PID path needs to follow "-p". You're giving invalid input to the -p option.

Try moving the "-4" to be like this:
Code:
NTPD_OPTS="-g -4 -p /run/ntpd.pid -u ntp:ntp"
 
1 members found this post helpful.
Old Yesterday, 11:47 AM   #8
rocknrobin
Member
 
Registered: Apr 2020
Location: Texas
Distribution: 14.2
Posts: 55

Original Poster
Rep: Reputation: Disabled
Thanks rkelsen...I updated /etc/default/ntp as suggested:

Code:
# Default options for the ntpd daemon:
#
# -g: allow initial time correction to be Big (once only)
# -p /run/ntpd.pid: write ntpd PID to this location
# -u ntp:ntp: run ntpd as user ntp, group ntp
#
# Depending on your network, you might want to add -4 (ipv4 only)
# or -6 (ipv6 only).
#
# For other available options, see "man ntpd".

NTPD_OPTS="-g -4 -p /run/ntpd.pid -u ntp:ntp"
And now this is what /var/log/ntp shows on reboot.

Code:
11 Jun 08:58:32 ntpd[3658]: ntpd exiting on signal 15 (Terminated)
11 Jun 08:59:26 ntpd[1208]: initial drift restored to 14.843277
11 Jun 08:59:26 ntpd[1208]: Listen and drop on 0 v4wildcard 0.0.0.0:123
11 Jun 08:59:26 ntpd[1208]: Listen normally on 1 lo 127.0.0.1:123
11 Jun 08:59:26 ntpd[1208]: Listen normally on 2 eth1 10.160.160.15:123
11 Jun 08:59:26 ntpd[1208]: Listening on routing socket on fd #19 for interface updates
11 Jun 08:59:26 ntpd[1208]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
11 Jun 08:59:26 ntpd[1208]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
11 Jun 08:59:31 ntpd[1208]: Listen normally on 3 eth0 10.160.134.65:123
11 Jun 08:59:31 ntpd[1208]: 209.38.132.42 local addr 10.160.160.15 -> 10.160.134.65
11 Jun 08:59:31 ntpd[1208]: 51.81.226.229 local addr 10.160.160.15 -> 10.160.134.65
11 Jun 08:59:31 ntpd[1208]: 69.89.207.199 local addr 10.160.160.15 -> 10.160.134.65
11 Jun 08:59:31 ntpd[1208]: 162.159.200.123 local addr 10.160.160.15 -> 10.160.134.65
11 Jun 08:59:31 ntpd[1208]: new interface(s) found: waking up resolver

Last edited by rocknrobin; Yesterday at 05:17 PM.
 
Old Yesterday, 12:22 PM   #9
rocknrobin
Member
 
Registered: Apr 2020
Location: Texas
Distribution: 14.2
Posts: 55

Original Poster
Rep: Reputation: Disabled
Another quick question for you guys if possible.

I see in https://docs.slackware.com/howtos:network_services:ntp it advises:

NTP prefers to use SYSLOG for logging. There is an alternate logging feature in NTP itself that can be used instead. Looking again at the preinstalled Slackware /etc/ntp.conf, the alternate logging feature has already been turned on:

logfile /var/log/ntp


It is simpler to delete the logfile line and use Slackware's preinstalled SYSLOG package. Using SYSLOG, NTP logs warnings and errors to /var/log/syslog, and routine status messages to /var/log/messages.

If you still want to use the alternate logging feature, be sure to create the empty file and make it writable by the NTP daemon:

# touch /var/log/ntp.log
# chown ntp:ntp /var/log/ntp.log

I would prefer to use this alternate logging feature so I don't have to look at the other logs and filter out the ntp info. Therefore I set up for an ntp log as below.

I did not do this touch and chown before on the ntp log. From the previous configuration above, logfile /var/log/ntp, I had assumed that ntp was the actual log file in /var/log. I created an empty file by just going into nano -c ntp, putting in a line ntp log, then saving it and chowning ntp:ntp for the file ntp. Now the log entries for the ntp daemon are going into the file ntp instead of ntp.log. If I do the touch on the /var/log/ntp.log and then chown ntp:ntp /var/log/ntp.log will the log entries start going into ntp.log or continue going to the file ntp? Thanks.
 
Old Yesterday, 01:46 PM   #10
Petri Kaukasoina
Senior Member
 
Registered: Mar 2007
Posts: 1,960

Rep: Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571Reputation: 1571
Quote:
Originally Posted by rocknrobin View Post
logfile /var/log/ntp
...
# touch /var/log/ntp.log
There is a typo in the howto page: the filename changed. If you want your log in file /var/log/ntp.log, use 'logfile /var/log/ntp.log' in ntp.conf.
 
Old Yesterday, 05:00 PM   #11
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 4,489
Blog Entries: 7

Rep: Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580
It'll write everything to /var/log/ntp with the default setting, which seems to be what you want? Or have I misunderstood?
 
Old Yesterday, 05:16 PM   #12
rocknrobin
Member
 
Registered: Apr 2020
Location: Texas
Distribution: 14.2
Posts: 55

Original Poster
Rep: Reputation: Disabled
rkelsen...I was just confused as to why the default setting was:

logfile /var/log/ntp

but yet the touch and chown commands referenced ntp.log. I would actually rather use the ntp.log since the other log files have the .log extension.

I changed the logfile setting to

logfile /var/log/ntp.log

as per Petri's suggestion and after reboot the log entries for ntp are going to ntp.log. Hopefully the typo will be fixed in the next update for ntpd so I/we won't have to keep changing it down the road. Thanks for everybody's help.
 
Old Yesterday, 05:26 PM   #13
metaed
Member
 
Registered: Apr 2022
Location: US
Distribution: Slackware64 15.0
Posts: 378

Rep: Reputation: 174Reputation: 174
Quote:
Originally Posted by Petri Kaukasoina View Post
There is a typo in the howto page
Good catch, thank you. Fixed on the howto page.
 
Old Yesterday, 06:23 PM   #14
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 4,489
Blog Entries: 7

Rep: Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580Reputation: 2580
Quote:
Originally Posted by rocknrobin View Post
I changed the logfile setting to

logfile /var/log/ntp.log
You need to beware that Slackware's default setup includes the file /etc/logrotate.d/ntp, which specifies that the file /var/log/ntp will be rotated when logrotate is run (by cron) at 4:40am daily.

If you don't change the reference in that file, then your ntp log will be skipped and will continue to grow.

The howto seems to have incorrect information about this too.
 
Old Today, 03:30 PM   #15
metaed
Member
 
Registered: Apr 2022
Location: US
Distribution: Slackware64 15.0
Posts: 378

Rep: Reputation: 174Reputation: 174
Quote:
Originally Posted by rkelsen View Post
The howto seems to have incorrect information about this
I'm unaware of any incorrect information about log rotation. Error reports or suggestions for the NTP howto would be most welcome.
 
  


Reply

Tags
ntp, ntpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] OpenOffice on OS/X now consistently dies about thirty seconds after you start it ... sundialsvcs Other *NIX 6 08-26-2022 12:11 PM
After password change consistently get Authentication failure crichard12nj Linux - Security 1 12-14-2015 02:14 AM
How I finally got wireless/wpa_supplement to work consistently in Slackware 12.1 moddoc Slackware 0 08-23-2008 01:37 AM
Restart consistently installing SUSE 10.1 apparently after kernal pakage install. TehFlyingDutchman Linux - Software 0 06-27-2006 08:07 AM
DPMS is not working consistently on Fedora Core 2 george.howitt Linux - Hardware 1 09-26-2004 11:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration