-   Slackware (
-   -   Slackware 14 on a thinkpad W530 ... what works and what doesn't (

bimboleum 10-22-2012 01:25 AM

Slackware 14 on a thinkpad W530 ... what works and what doesn't
Background .. I have been using Slackware since 1995 when it was the only distribution that would install on my old B&W IBM laptop! I use it on all my machines.

I have just put Slackware 14 on my Thinkpad W530. Previously I had Slackware 13.37 but, of course, it was too old properly to support the new hardware on the W530.

So, what's the skinny.

The W530 came with 32G ram, and a 500G hard-drive. I put a 32G msata SSD drive in the internal slot and this is the drive which comprises my root filesystem ... well actually 2 15G partitions, one for 13.137 and one for 14.00.

So ... installation is flawless.

I have lilo set up to use UUID's for the specifying the root drive and partition so that it doesn't matter what or how many hard-drives I have installed. To do this you need an initrd with udev support so the /dev/disk/ subtree is properly set up prior to mounting the root filesystem.

I installed Eric's multilib packages.

I have the graphics set to Integrated Graphics so now I get the nice wide console. I dont want (or need) the nvidia GPU.

The X driver works! The screen brightness keys work!!
xfce works.
skype works.

I have firefox nightly installed which works

I use claws-mail. When compiling claws-mail, I found is missing from /usr/lib64.

My soundcard works (Intel hda).

3.2.29 supports the bluetooth chipset. The bluetooth kernel modules install OK. bluetoothd runs OK. The bluetoothmanager in xfce works OK. I can associate my bluetooth headset OK BUT NO DEVICES appear. I have a .asoundrc in my home directory which worked (devices appeared and were usable by skype) when I was running 13.37 on my old thinkpad t60 so something is broken but I don't know what to turn on to get some debugging output.

The phonon backends are broken somewhere.

I have minitube 1.9 for accessing youtube. This works under 13.37 and uses the phonon-xine backend.

I recompiled it for Slackware 14. With the vanilla settings, it tries to use the phonon gstreamer backend. It downloads the videos and thumbnails, and displays the thumbnails, but doesn't play the video even though the log output declares it is playing the video.

If I tweek the settings (/usr/share/kde4/services/phononbackends/*desktop)
to make phonon-xine the preferred backend, the videos play BUT the thumbnails are NOT displayed .. even though the log says they are downloaded.

I see this behaviour with both the newly compiled binary and that compiled under 13.37 so I think the problem lies within Slackware 14 rather than within minitube.

I run Windows 7 (shock, horror, gasp ... needed because work insists that Outlook is the only thing for handling mail) under vbox .. works like a charm but I had to call Microsoft to activate over their automated phone line ... would not work over the web .... OEM licence maybe ... anyway no problem with the automated phone thingy.

So all-in-all, not bad.

I need to solve the bluetooth problem so any help/suggestions would be appreciated. My .asoundrc file looks like:-

pcm.jawbone {
type bluetooth

ctl.jawbone {
type bluetooth

I can't find the button to use the code window so I apologise for the above.


pete hilton

All times are GMT -5. The time now is 06:53 PM.