-   Slackware (
-   -   slackware 14 gCompris issue (

captain_sensible 10-14-2012 11:51 AM

slackware 14 gCompris issue
I installed slackware 14 (32 bit) and then installed gCompris and gnet for my daughter. gCompris works except there is an issue with the chess game.

The chess game part worked only ,so sent an email to the developer; who was kind enough to reply. He's basically saying the gnuchess that comes with the main install of slackware 14 isn't quite what gCompris is looking for.

He mentions GIT and gave me a link. All i know about GIT is that linus Torvalds wrote it but that all. Bruno says "just get GIT and run sh configure --enable-build-gnuchess.

Can anyone elucidate what he wants me to do, since I just don't understand it

copy of email as follows:
Le dimanche 14 octobre 2012 à 18:54 +0700, andrew brookes a écrit :
> Hi
> I have gCompris installed on slackware 14, with its dependency (gnet)
> , I looked in packages and gnuchess is also installed.
> My daughter can move the white chess piece, but when its the computers
> turn nothing happens. I tried hitting return after the white piece
> move.. nothing
> The only gui buttons on view are home and help
> Any ideas?


Probably the gnuchess version you have is not compatible with the one
GCompris expects.

I just made a fix to let you compile GCompris with its internal gnuchess
version that is know to work:

Just get the git and run:
sh configure --enable-build-gnuchess

Let me know if this works for you.


Didier Spaier 10-14-2012 12:19 PM

Bruno wants you to grab from the "git repository" the version he just modified for you, then build a package for it, install it and see if that works for you.

I'm trying and if successful will tell you how to to do that. Stay tuned.

EDIT Please be patient, heavy download ahead.

willysr 10-14-2012 08:22 PM

I tried building using the 12.05 source and the patch, but it failed. I guess it has to be the git version

Didier Spaier 10-15-2012 05:09 AM

I guess so as well. I did clone the git repository with following command:

git clone --depth=1
But then trying to run I saw that I missed the gnome-compilers-flags.m4 macro.

Sorry but I can't go further as I'm not ready to set up a full gnome compilation environment...

I just sent a link to this thread to Paul Liconti, the maintainer of the GCompris SlackBuild @ in the hope he can help you better.

Meanwhile you could request Bruno to send you a source tarball with his patch applied and try to build the package with that. You would have to run the SlackBuild this way then:

VERSION=<version of the new source tarball> ./gcompris.SlackBuild

captain_sensible 10-15-2012 10:47 AM


I much appreciate the comments and help. Understanding GIT will have to be added to the end my "light" bed time reading list, and its a long list!

Bruno seemed to suggest gnuchess might be the problem ; but it appears he has done a patch to fix gCompris to work with my existing gnuchess which is gnuchess-5.08-i486-2. Is that what he is saying ?.

had a look at man git ,so if I knew how to use GIT I would use the link he gave me?

Didier , i don't know how much time a developer has to spend on this kind of thing, but have sent a email requesting as you suggested.


Didier Spaier 10-15-2012 11:03 AM


Originally Posted by captain_sensible (Post 4806250)
Bruno seemed to suggest gnuchess might be the problem ; but it appears he has done a patch to fix gCompris to work with my existing gnuchess which is gnuchess-5.08-i486-2. Is that what he is saying ?.

What I understand from his message is that the version of GCompris he prepared will allow you to build a version of gnuchess compatible with it, provided you add the configure option he mentioned in gcompris.SlackBuild.

gapan 10-19-2012 10:44 AM

The packages from salix have a builtin gnuchess and work properly.

captain_sensible 10-20-2012 08:05 AM

I started reading up on GIT and considered that the following sequence might get me nearer to a properly working gCompris.

$ Mkdir gitProject
$ cd gitProject

git init

git add .
git commit

git config --global "andrew "
git config --global ""

git clone git://

cd gcompris
sh && make
sh configure --enable-build-gnuchess


I got as far as " git clone git://" which started , but unfortunately due to my slow connection speed where I am at the moment , I got a " timed out by peer"

If I did to to the point of " sh configure --enable-build-gnuchess" , (I don't know because I haven't done it yet) is this going to give me a source package to use with

"VERSION=<version of the new source tarball> ./gcompris.SlackBuild"

or is it going to compile gCompris and gnuchess into my system ?

Anyway thanks very much Gapan, the easier option at the moment is to get the package from Salix.I can download at an internet cafe and then install later.

much as I like the learning curve challenge from builds , I must check out which other
"ready to install" packages salix has.

All times are GMT -5. The time now is 04:39 AM.