-   Slackware (
-   -   Slackware 14 and the infamous BCM4313 (

wolfslacker 10-11-2012 12:08 AM

Slackware 14 and the infamous BCM4313
Hello fellow slackers, I need your assistance. I've installed Slackware 14 (32-bit) and the broadcom driver provided by but I cannot get my dell laptop vostro 3300 to active my wireless port eth1. I had no problem with this when I was using Slackware 13.37. On my first attempt, I blacklisted the b43legacy items as indicated by Slackbuild and compiled and installed the broadcom-sta driver. After reboot, my "iwconfig" showed no eth1 device. I then compiled the fwcutter, firmware and legacy items and undid my blacklist and reinstalled broadcom-sta and still got no eth1. I did a little bit of research and according to my BCM4313 is not supported by fwcutter. I unstalled fwcutter, firmware and legacy, re-implemented the blacklist and re-compliled broadcom and re-installed and still got no eth1. I played around with loading different kernels (generic, huge) but still wasn't able to get eth1 to come up. This laptop is dual-booting Xubuntu 12.04 and wireless is working flawless on that distro so I don't think it would be hardware related. I waited so long for Slackware 14 to be released and now I can't get over the wifi hump, any help would be appreciated. The following is my laptop status.

root@naaltsoos:~# lsmod
Module Size Used by
snd_seq_dummy 1119 0
snd_seq_oss 24956 0
snd_seq_midi_event 4568 1 snd_seq_oss
snd_seq 41599 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 4276 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 33254 0
snd_mixer_oss 12984 1 snd_pcm_oss
ipv6 238549 18
cpufreq_ondemand 5272 4
speedstep_lib 2567 0
acpi_cpufreq 4977 1
mperf 923 1 acpi_cpufreq
freq_table 2103 2 acpi_cpufreq,cpufreq_ondemand
lp 7119 0
ppdev 4710 0
parport_pc 16755 0
parport 26159 3 parport_pc,ppdev,lp
fuse 58282 3
btusb 10108 0
bluetooth 132835 1 btusb
usbhid 31118 0
hid 65824 1 usbhid
joydev 7668 0
uvcvideo 55700 0
videodev 66999 1 uvcvideo
ums_realtek 6148 0
uas 6464 0
dell_wmi 1209 0
sparse_keymap 2492 1 dell_wmi
snd_hda_codec_idt 47698 1
dell_laptop 9392 0
brcmsmac 508474 0
dcdbas 4308 1 dell_laptop
i915 372988 8
cordic 805 1 brcmsmac
crc8 796 1 brcmsmac
brcmutil 2847 1 brcmsmac
drm_kms_helper 22825 1 i915
mac80211 202703 1 brcmsmac
snd_hda_intel 19503 4
drm 151850 4 drm_kms_helper,i915
snd_hda_codec 70505 2 snd_hda_intel,snd_hda_codec_idt
psmouse 54408 0
i2c_algo_bit 4543 1 i915
snd_hwdep 4802 1 snd_hda_codec
serio_raw 3349 0
evdev 7314 11
snd_pcm 59013 4 snd_hda_codec,snd_hda_intel,snd_pcm_oss
cfg80211 145277 2 mac80211,brcmsmac
i2c_i801 6952 0
snd_page_alloc 5925 2 snd_pcm,snd_hda_intel
intel_agp 8712 1 i915
i2c_core 16454 6 i2c_i801,i2c_algo_bit,drm,drm_kms_helper,i915,videodev
snd_timer 14798 3 snd_pcm,snd_seq
intel_ips 10370 0
rfkill 12432 4 cfg80211,dell_laptop,bluetooth
intel_gtt 11571 3 intel_agp,i915
r8169 42347 0
snd 43657 17 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_idt,snd_mixer_oss,snd_pcm_oss, snd_seq_device,snd_seq,snd_seq_oss
mei 27885 0
soundcore 4570 1 snd
agpgart 22087 3 intel_gtt,intel_agp,drm
mii 3335 1 r8169
wmi 7255 1 dell_wmi
thermal 6587 0
battery 9119 0
video 9938 1 i915
processor 23020 1 acpi_cpufreq
thermal_sys 12122 3 processor,video,thermal
ac 2563 0
button 3665 1 i915
hwmon 1033 1 thermal_sys
loop 14650 0
root@naaltsoos:~# uname -a
Linux naaltsoos 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686 Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz GenuineIntel GNU/Linux
root@naaltsoos:~# lspci -nnk|grep -A3 Net
12:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
Subsystem: Dell Inspiron M5010 / XPS 8300 [1028:0010]
Kernel driver in use: brcmsmac
13:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)

lkraemer 10-11-2012 05:42 PM

Here are some good reference URL's for your Broadcom [14e4:4727]

If you just want the Firmware, you can download it from this URL:
Download, and Extract. You will be copying these files according to the above URL's instructions.

Kernel driver in use: brcmsmac and your lsmod shows it is installed.

Check /etc/modprobe.d/blacklist.conf just to verify what drivers are blacklisted.

The following ROOT commands:


will tell you what the Wifi Interface is detected as.

Once all that information is correct, this URL will help you get it going:


ReaperX7 10-11-2012 09:18 PM

The BCM4313 is NOT supported by the B43 driver, it's supported by the brcm80211 driver.

You will need the firmware from here:

Copy brcm/bcm43xx-0.fw and brcm/bcm43xx_hdr-0.fw to /lib/firmware/brcm (or wherever firmware is normally installed on your system).

and you may have to reconfigure your kernel as such:


Location: -> Device Drivers

    -> Network device support

        -> Wireless LAN

            -> <M> Broadcom IEEE802.11n PCIe SoftMAC WLAN driver

            -> <M> Broadcom IEEE802.11n embedded FullMAC WLAN driver

                ->[*] SDIO bus interface support for FullMAC driver

                ->[*] USB bus interface support for FullMAC driver


Location: -> Device Drivers

    -> Broadcom specific AMBA

        -> <M> BCMA support

            ->[*] Support for BCMA on PCI-host bus

and then rebuild the kernel and modules. Your driver modules will be either:

brcmsmac - For PCIe/MiniPCI cards


brcmfmac - For motherboard embedded controllers.

wolfslacker 10-11-2012 09:22 PM

Thanks lkraemer, from what I gather, brcm80211 will support the BCM4313 device so I would need to replace the original brcmsmac that came with Slackware 14 install. Prior to installing brcm80211, I would need to update my firmware files (brcm/bcm43xx-0.fw and brcm/bcm43xx_hdr-0.fw) which I did. Now the confusing part, for downloading the brcm80211 driver, I was directed to and from there I downloaded the "compat-wireless-3.2.5-1.tar.bz2" file which seemed to match my slackware kernel. I followed the unpacking, building and installing direction from the url but the install hit an error(1). I also got numerous "invalid option -- 'l'" messages during the build. So in the end, I'm still unable to activate my eth1 wireless device.

I'm surprise I'm having a difficult time with this and I can hardly find anyone else who is plague with this same problem. It leads me to believe that maybe I overlooked something simple.

ReaperX7 10-11-2012 09:33 PM

Your wireless card should be wlan0, not eth1.

Marcelo_Belfalas 10-11-2012 09:59 PM


After Patrick started compiling the kernel with the CONFIG_BRCMSMAC option my BCM4313 works out of box.

From lspci:

12:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

Just check your rules for udev because your card may be listed as "eth1", not "wlan0".

To change that, you can add:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<mac-address>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

to /etc/udev/rules.d/70-persistent-net.rules

ReaperX7 10-11-2012 11:31 PM

The udev problem should be fixed by now.

wolfslacker 10-12-2012 12:11 AM

Thanks all, I guess I was over-complicating things. I re-installed Slackware 14 and treated wlan0 as eth1. To be more specific, I did the following.
1) # iwconfig wlan0 up
2) I ran the wpa_passphrase to get my pre-share key.
3) I then entered my ssid and psk into /etc/wpa_supplicant.conf
4) I next ran # wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
5) dhcpcd wlan0
and I was happily greeted with a broadcast lease. The pro to using wlan0 is that I didn't have to install a broadcom driver, which probably made things more complicated. The con is that in the past, I use to use the command "# iwlist eth1 scan" to scan for available broadcasts. The same command doesn't work with wlan0. Is there an equivilent command to get wlan0 to scan the airwaves?

wolfslacker 11-19-2012 09:20 PM

Slow boot in re-enabling gpu turbo...
There is something else I should mention in case anyone else is having a similar issue during boot. I would get a "i915 driver attached, reenabling gpu turbo" message followed by a 10 second pause and then a message saying "worker [1547] timeout, kill it". After a little bit of research, I found a remedy to this problem.

1) Insert the following in /etc/modprobe.d/blacklist.conf
blacklist b43
blacklist brcmsmac
2) Insert the following in /etc/rc.d/rc.local
modprobe b43
modprobe brcmsmac

All times are GMT -5. The time now is 08:04 AM.