LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-07-2017, 01:25 PM   #1
glupa4e
Member
 
Registered: Jan 2011
Posts: 248

Rep: Reputation: 2
Unhappy Slackware 14.2 multilib - MkvToolNixGUI cannot find or load the Qt platform plugin "xcb"


Hello,

I have installed mkvtoolnix withi gui support. When i try to start it, i get:
Code:
bash-4.3$ mkvtoolnix-gui 
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
I already checked
Code:
ldd /usr/lib64/qt5/plugins/platforms/libqxcb.so | grep libQt5
        libQt5XcbQpa.so.5 => /usr/lib64/qt5/plugins/platforms/../../../libQt5XcbQpa.so.5 (0x00007fc2f8701000)
        libQt5Gui.so.5 => /usr/lib64/qt5/plugins/platforms/../../../libQt5Gui.so.5 (0x00007fc2f3c38000)
        libQt5DBus.so.5 => /usr/lib64/qt5/plugins/platforms/../../../libQt5DBus.so.5 (0x00007fc2f39af000)
        libQt5Core.so.5 => /usr/lib64/qt5/plugins/platforms/../../../libQt5Core.so.5 (0x00007fc2f32f1000)
 
Old 05-07-2017, 02:15 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,544

Rep: Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920Reputation: 5920
If you installed my qt5 package, then check out its dependencies first. My guess is that you forgot to at least install the libxkbcommon package.
 
Old 05-08-2017, 01:53 PM   #3
glupa4e
Member
 
Registered: Jan 2011
Posts: 248

Original Poster
Rep: Reputation: 2
Eric,

as far as i can remember i installed Qt5 from SlackBuilds. I checked out its dependencies once again. It turned out, that i had forgotten to install libinput. When i installed the missing package, i was able to also start MkvToolNix-GUI without reinstalling Qt itself.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] What is Qt platform plugin "xcb"? mfoley Slackware 3 12-07-2016 11:56 AM
Linux10.10 Where to down load "Demux " plugin for "Amorak" music bluesman1951 Linux - Newbie 10 10-28-2011 01:08 AM
Error installing "evas" from Enlightenment DR17 on Slackware 13.2 64Bit Multilib ZXDunny Linux - Software 0 06-07-2010 11:58 AM
[SOVLED] Problem with Slackware 13 x86_64 ATI driver on 2.6.32.3 using "multilib" ollebanan Slackware 5 01-24-2010 01:02 PM
Flash won't load in Konqueror - "Unable to load Netscape plugin" rollo Linux - Software 2 09-10-2005 12:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration