LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-04-2017, 12:58 PM   #1
glupa4e
Member
 
Registered: Jan 2011
Posts: 241

Rep: Reputation: 2
Slackware 14.2 multilib - Icecast won't start - Could not start logging


Hi,

i have installed the latest version of Icecast that is available here.
I have edited the configuration file. That configuration used to work. I tried to make some changes to the config file and now Icecast refuses to start. Some details to my config. I have enabled chroot in icecast xml, so the server should run as "user".
Configuration for the paths is
Code:
       <basedir>/usr/share/icecast</basedir>

        <!-- Note that if <chroot> is turned on below, these paths must both
             be relative to the new root, not the original root -->
        <logdir>/var/log/icecast</logdir>
        <webroot>/usr/share/icecast/web</webroot>
        <adminroot>/usr/share/icecast/admin</adminroot
I have explicitely given the write permission to the "user" under which the program should run after starting. The upper directory looks like that
Code:
root@localhost:/var/log# ls -la | grep icecast
drwxr-xrwx  2 root root     4096 Jan  4 15:56 icecast/
The log files have the following rights
Code:
root@localhost:/var/log/icecast# ls -larth
total 408K
drwxr-xrwx  2 root root  4.0K Jan  4 15:56 ./
-rw-r--r--  1 user users 265K Feb  4 12:12 error.log
-rw-r--r--  1 user users 129K Feb  4 12:12 access.log
drwxr-xr-x 17 root root  4.0K Feb  4 19:34 ../
I repeat that configuration used to work. I do not know what have i changed in the config file, but it does not say it can not parse the configuration. When i start Icecast, i get
Code:
root@localhost:/usr/share/icecast/web# icecast -c /etc/icecast.xml
[2017-02-04  12:39:39] WARN CONFIG/_parse_root Warning, <hostname> not configured, using default value "localhost". This will cause problems, e.g. with YP directory listings.
Changed root successfully to "/usr/share/icecast".
Changed groupid to 100.
Changed supplementary groups based on user: user.
Changed userid to 1000.
[2017-02-04  11:39:39] WARN fserve/fserve_recheck_mime_types Cannot open mime types file /etc/mime.types
FATAL: could not open error logging (/var/log/icecast/error.log): No such file or directory
FATAL: could not open access logging (/var/log/icecast/access.log): No such file or directory
FATAL: Could not start logging
Although i have set the log level to debug, i do no see any messages in the files, because it somehow cannot find them.
Any idea how to get out of that situation?
 
Old 02-05-2017, 09:44 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,219

Rep: Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228Reputation: 5228
Perhaps you need to share your full configuration? As long as you only provide part of the background, no one is going to waste his or her time answering you with relevant suggestions.
 
Old 02-05-2017, 11:04 AM   #3
davjohn
Member
 
Registered: Jan 2017
Posts: 33

Rep: Reputation: Disabled
If I undertand this correctly you set chroot to /usr/share/icecast but /usr/share/icecast/var/log/ doesn't exist.
All paths are relative to chroot folder. It even says in comment:
Code:
<!-- Note that if <chroot> is turned on below, these paths must both
             be relative to the new root, not the original root -->
So you probably just need to create /usr/share/icecast/var/log/ and possibly other folders.
 
1 members found this post helpful.
Old 02-05-2017, 02:33 PM   #4
glupa4e
Member
 
Registered: Jan 2011
Posts: 241

Original Poster
Rep: Reputation: 2
Hi,

well i have missed the part with the relative paths. Now i changed the configuration to
Code:
       <basedir>/usr/share/icecast</basedir>

        <!-- Note that if <chroot> is turned on below, these paths must both
             be relative to the new root, not the original root -->
        <logdir>../../../var/log/icecast</logdir>
        <webroot>/web</webroot>
        <adminroot>/admin</adminroot>
and the servrer logs to the desired folder /var/log/icecast
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14.2 multilib - Icecast fails to build glupa4e Slackware 6 01-04-2017 06:55 AM
[SOLVED] Slackware 14.2 multilib - Adobe Reader does not start due to missing library libxshmfence.so.1 glupa4e Slackware 1 08-21-2016 09:02 AM
[SOLVED] virt-manager build's on slackware 14.1 multilib but won't start bmarley83 Slackware 10 10-22-2015 09:52 PM
x won't start in Slackware 13.1 2handband Slackware 3 12-23-2010 02:03 PM
Window manager (fluxbox) won't start when logging in pbaumgar Slackware 6 05-06-2004 01:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration