LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-08-2017, 07:55 AM   #1
giogio
Member
 
Registered: Sep 2005
Posts: 34

Rep: Reputation: 15
slackware 14.2 :GRUB from iso DVD does not boot (UEFI)


Trying to boot from dvd on an HP notebook model hp 15 ba064nl.
Disabled secure boot. Starting the boot, it shows just the Grub label, then it stays there for a very long time, without making anything.
At start up, just selected the DVD for boot and then the Grub starts, without any possibility to insert any command.
Just tried with other distros without problems.
Is there any way to see slackware 14.2 booting?
Thank you all
 
Old 02-08-2017, 08:19 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,747

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
What is your installation media? In a few cases grub fails from an USB stick, at least if the ISO has been post-processed with isohybrid (as is the case for Slackware ISOs). That's one of the reasons in Slint we used elilo instead of grub for installation in EFI mode, ans xorriso instead of post-processing the ISO image.
 
1 members found this post helpful.
Old 02-08-2017, 08:30 AM   #3
giogio
Member
 
Registered: Sep 2005
Posts: 34

Original Poster
Rep: Reputation: 15
Hi Didier,
I am using a DVD, but maybe it should be a good thing to think about Slint. So I will try this night or tomorrow.
 
Old 02-09-2017, 04:27 PM   #4
giogio
Member
 
Registered: Sep 2005
Posts: 34

Original Poster
Rep: Reputation: 15
Hi,
just did that. The disc booted a perfect way.
After a second installation (the first one failed booting from hard disk, I do not know why) it is all working ok.
Now I have Slint/Slackware on this pc.
Thanx
 
Old 02-09-2017, 04:54 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,747

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Glad it worked. Feedback using it is welcome, for instance in this forum.
 
Old 09-07-2017, 10:42 AM   #6
MartinB
LQ Newbie
 
Registered: Sep 2017
Posts: 2

Rep: Reputation: Disabled
Unhappy DVD slackware install 14.2 does not boot

Hi guys.
I experiment the same problem.
I have burned slackware install 14.2 on a DVD and it does not boot at all.
My box seems not to see the DVD as a bootable media ; after a while, It's booting on HD.

I don't understand what Giogio has done to succeed ? Does he problem on installation phase or, after installing, at the first HD boot ?

Thanks.
Martin
 
Old 09-11-2017, 05:03 PM   #7
giogio
Member
 
Registered: Sep 2005
Posts: 34

Original Poster
Rep: Reputation: 15
Hi,
I did nothing but simply downloading Slint and installing Slint (i.e. Slackware as modified by Slint). I don't know why Slint is working while the iso from Slackware not. I understand this is not a good answer, but as it works I use it. Formally there is no difference, at least from the way one install Slackware: the iso from Slint boots on my machine, the one from Slackware not.
 
Old 09-12-2017, 02:45 AM   #8
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,747

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Hi Martin,

welcome on this forum

The reason Giovanni succeeded installing Slint is probably because it uses xorriso instead of isohybrid or ELILO instead of GRUB, as indicated in post #2.

But, all we know about your context is that you used a DVD as installation media, and there can be other reasons that prevent booting, like Secure Boot (neither Slackware nor Slint can boot if Secure Boot is enabled) or another firmware feature or setting.

More information on your system could help us help you, like: what are of your machine hardware and firmware and the firmware features and settings: is it hybrid (Legacy + UEFI), did you disable Secure Boot, among others.

Oh, and when you encounter an issue it's better to open a new thread for it than posting in another one, as that could be a completely different problem. Also this thread is marked as [SOLVED], so this could confuse readers.

Last edited by Didier Spaier; 09-12-2017 at 02:58 AM.
 
1 members found this post helpful.
Old 09-14-2017, 09:18 AM   #9
MartinB
LQ Newbie
 
Registered: Sep 2017
Posts: 2

Rep: Reputation: Disabled
Wink [SOLVED] slackware 14.2 :GRUB from iso DVD does not boot (UEFI)

Hi Giogio, hi Didier.
Thanks for the answer.
I am sorry to have post my question in a solved thread; it was because it adresses the same concern. But it is effectivly confuse.
I do not open an another thread to thank you.
I have found a DVD de slaware 14.0 that boot on my machine. I will use it.

My Mother board is an ASUS M4A88T-M/USB3 - Chipset AMD 880G / SB710.
I did not activate secure boot or any particular BIOS features ; several other CD/DVD boot correctly.
I think it is a legacy boot.

I take a look at slint and I understand that is a specific distrib based on slackware.
I am very uneasy with it.

In fact, I am fan of the slitaz distrib. But it seems that the communauty is not very populous.
I am interested to slackware by its technical aspect and its active communaut.
It seems to me that the slint distrib appears to be to much young.
 
Old 09-14-2017, 09:42 AM   #10
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,747

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
@MartinB:

I now assume that either the ISO was not properly downloaded (did you check its integrity with md5sum?) or not properly written on the DVD.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need a Slackware uefi grub howto a4z Slackware 18 08-13-2016 05:54 AM
BIOS, UEFI & CSM Boot, GRUB and/or LILO and Windows/Linux Dual Boot rm_-rf_windows Linux - General 4 11-10-2014 09:30 AM
Cannot boot arch iso in uefi mode jbpenguin Arch 1 09-04-2014 08:11 PM
[SOLVED] Can I compile slackware-install-dvd.iso out of slackware-source-code-dvd.iso mshlinux Slackware 11 05-25-2013 02:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration