Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 04-24-2014, 08:33 AM   #1
LQ Newbie
Registered: Nov 2009
Posts: 8

Rep: Reputation: 0
Slackware 14.1 x64 -- Issues with GDB 7.x

When launching gdb on an application I am greeted with the following error:

&"warning: GDB: Failed to set controlling terminal: Inappropriate ioctl for device\n"
Could not load shared library symbols for
Do you need "set solib-search-path" or "set sysroot"?

Some googling of this provided a whole myriad of garbage, from patches to finger pointing, and other sorts of hand waiving.

Frequently people say that this is a harmless warning and can be ignored. I am thinking that is not the case.

I am debugging a 32bit application. SlackVer is x64.

GDB gets the shared kernel object : which resides at 0x00007fffc7dde000

my application gets: which resides at 0xffffe000

At any rate, gdb is not working right at all. I can set break points, step through, step over etc. That's all fine an dandy, however it fails to give me values if I add an expression evaluation. I can set a break point before a variable is set, at it, then immediately after. GDB stops at all the points but does not have a value for me.

This makes debugging next to impossible with gdb.

If anyone had this issue and has since resolved it your input would be greatly appreciated.

[Edit]: For what its worth I am debugging a multi thread program which is interfacing with other applications.

Last edited by hitormiss; 04-24-2014 at 08:41 AM.
Old 05-13-2014, 03:28 AM   #2
LQ Guru
Registered: Dec 2011
Distribution: Slackware
Posts: 7,819
Blog Entries: 10

Rep: Reputation: Disabled
I'm no expert on this as I have only been running Slackware for 2 weeks but it sounds like GDB is not being invoked correctly or like you said it's not working at all.

In this link it's a bug. Sorry I don't know more.

Maybe a more experienced Slackware Member will know & chime in.


The default value for the set sysroot variable depends on your toolchain. If your GDB binary was compiled with the --sysroot argument, you won't need to run the set sysroot command - the sysroot will be automatically set to the location specified during compilation. Otherwise the default value will be "" and you might need to set it manually if you are debugging remote processes.
Old 05-13-2014, 03:34 AM   #3
LQ Guru
Registered: Dec 2011
Distribution: Slackware
Posts: 7,819
Blog Entries: 10

Rep: Reputation: Disabled
This is the only thread of many that I found online that makes an sense.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 14.1 x64 -- Qt 5.2.1 -- Failing to compile 32bit code. KDE applets issues. hitormiss Slackware 7 04-04-2014 10:09 AM
FFMPEG for APACHE 2.4.6 (x64), PHP 5.5 (x64), MYSQL 5.6 (x64) on WINDOWS 8 (x64) Punctual Programming 3 08-07-2013 05:20 PM
Slackware 13.37 x64 & Windows 7 x64 Dual Boot Issues toolman30044 Slackware 4 08-08-2011 02:39 PM
NDISwrapper works for Slackware 13.0 x86 but not Slackware 13.0 x64 - Belkin F5D8053 thewizkid Slackware 0 01-14-2010 06:18 AM
update issues x64 and mandrake 10.1 lostn1slinux Mandriva 2 12-10-2006 12:07 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:11 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration