LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-27-2015, 05:00 PM   #1
bamunds
Member
 
Registered: Sep 2013
Location: Mounds View MN
Distribution: Slackware64-14.2 XDM/WMaker
Posts: 639

Rep: Reputation: 190Reputation: 190
Slackware 14.1 Konqueror and Pipelight


I run slackware 14.1 x86_64 with multilib on an HP Laptop with 2 Gb of memory. I have installed pipelight-plugin according to AlienBob's instructions, including user-agent spoofing. Sites will work with Qupzilla 1.8.4 using pipelight plugin with Silverlight 5.1. But I cannot get Konqueror with pipelight/silverlight 5.1 to display properly. Konqueror pipelight will test okay for silverlight 5.1 on the fds-team.de/pipelight page, but when I try to use it on other pages it fails with a blank page. I've checked that Konqueror is seeing the plugin, and if I start Konqueror from a xterm I can see silverlight 5.1 is loading, but when I go to the silverlight page I want to view I get the error: "Nsviewer can't create plugin class". Remember I don't get that error with Qupzilla, also a web-kit browser. I've scanned the KDE and pipelight forums and don't see any specific answers related to KDE/Konqueror and pipelight.

I was at first thinking it was a KDE/Konqueror NPAPI issue, so I pursued the idea of nswrapper missing something, but then saw that silverlight was loading, but Konqueror is throwing a error message when the site is selected.

Then I thought pipelight was missing a library for Konqueror, but the few missing libraries are not critical for pipelight (libnetapi, libodbc (32 & 64bit), libpcap, libsane).

I'm hoping this esteemed group will have a clue for me to pursue for how to get Konqueror to use silverlight 5.1 properly. Anyone have a clue has to how to overcome this error? In the meantime my work-around is to use Qupzilla for the target sites, but I'd like a second browser that also works correctly (no I don't use Firefox because I don't like the direction it is going with more and more memory). Thanks in advance for your suggestions or maybe even an answer?

Last edited by bamunds; 01-27-2015 at 11:10 PM.
 
Old 01-27-2015, 08:12 PM   #2
chemfire
Member
 
Registered: Sep 2012
Posts: 231

Rep: Reputation: Disabled
Try the silverlight 5.0 plugin. I get the same error with Seamonkey using 5.1. Have not been able to determine why, but 5.0 works.
 
Old 01-27-2015, 11:03 PM   #3
bamunds
Member
 
Registered: Sep 2013
Location: Mounds View MN
Distribution: Slackware64-14.2 XDM/WMaker
Posts: 639

Original Poster
Rep: Reputation: 190Reputation: 190
Thanks for the suggestion, I hadn't thought to try that with Konqueror. I have been there - done that with Seamonkey, like you. However, AlienBob recommended that many sistes won't work with only 5.0 so to stick with 5.1. Thus I'm looking for a mozilla plugin pipelight silverlight fix for Konqueror. Thanks again for at least an idea to see if it is Silverlight 5.1 only issue, it is one more clue to Konqueror fix.
 
Old 01-31-2015, 07:18 AM   #4
chemfire
Member
 
Registered: Sep 2012
Posts: 231

Rep: Reputation: Disabled
So interesting..I just upgraded to seamonkey 2.32 from 2.31 and now silverlight 5.1 works again via pipe-light. I am using pipe-light 2.8 and Wine 1.7.33(staging). So maybe NAPI changes someplace? Hope this info helps with your Konqueror issue.
 
Old 05-30-2016, 04:24 PM   #5
bamunds
Member
 
Registered: Sep 2013
Location: Mounds View MN
Distribution: Slackware64-14.2 XDM/WMaker
Posts: 639

Original Poster
Rep: Reputation: 190Reputation: 190
UPDATE: Have still not found a solution for KDE Konqueror and pipelight with Silverlight 5.1, including latest security builds of Silverlight and Flash as of this post date. Konqueror will show Success on the fds-team.de/pipelight test page if the Konqueror supplied "Change Browser Identification agent is changed to Firefox 31 (I added Firefox 38.8 aslo to the kiohttp file) but it will not respond on the Bubblemark test or the Adobe Flash test pages. Just to re-iterate this is with Konqueror set for WebKit not KHTML, and the user agent set to Firefox. Still looking for solutions with Konqueror. SeaMonkey and Pale Moon work perfectly well, again with the User Agent Switcher version 0.7.3. I've dropped Quipzilla since it is moving to WebEngine/Blink engine and not dropping WebKit. Pale Moon is my backup in case the SeaMonkey Council/Developers falls apart or stray in to troubling social correctness waters. Pale Moon forked Gecko to create a new engine Goanna, which has it's own development that tracks Gecko, but doesn't implement everything weird and trendy.

Last edited by bamunds; 05-30-2016 at 04:32 PM.
 
  


Reply

Tags
konqueror, multilib, pipelight plugin, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] pipelight with nvidia driver baldur_1 Linux - Software 5 07-07-2014 01:42 PM
[SOLVED] pipelight/wine re_nelson Linux From Scratch 1 05-06-2014 12:41 PM
[SOLVED] Need Advice on Pipelight Install enorbet Slackware 12 01-25-2014 05:48 PM
Has anyone tried getting the pipelight project working in Slackware? Daedra Slackware 2 09-20-2013 02:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration