-   Slackware (
-   -   slackware 14.1 - kernel panic - unable to mount root fs (

joshua60 12-25-2013 11:41 AM

slackware 14.1 - kernel panic - unable to mount root fs

I'm getting kernel panic on boot after successful installation of slackware 14.1. current, it tells:

no fs could mount to, tried: romfs
kernel panic not syncing VFS: unable to mount fs on unknown block
CPU:0 PID: 1 Comm: swapper Not tainted 3.10.17 #1
HW name:ASUS All Series/Z87-K, BIOS 0903 10/25/2013

thanks for your help!

business_kid 12-26-2013 03:47 AM


no fs could mount to, tried: romfs
It boots the kernel, then wants to mount the root filesystem. It's stuck there.
Your kernel can only read romfs, which means it can't do ext4. It can't find a romfs file system. At a guess, that kernel needs an initrd. If you just boot the huge kernel, it should run with no initrd.

joshua60 12-26-2013 10:26 AM

thanks for your hint, business_kid.

I looked at grub.cfg and noticed that: (I'm running a multiboot system!)

linux /boot/vmlinuz-generic-3.10.17 root=/dev/sda8 gives a kernel panic but ...

linux /boot/vmlinuz-huge-3.10.17 root=/dev/sda8 does'nt!

Didier Spaier 12-26-2013 10:40 AM


Originally Posted by joshua60 (Post 5087180)
linux /boot/vmlinuz-generic-3.10.17 root=/dev/sda8 gives a kernel panic but ...

linux /boot/vmlinuz-huge-3.10.17 root=/dev/sda8 does'nt!

That's simply because -generic Sackware kernels do not have support for ext4 file system built-in, and at time access to your root partition is attempted, no kernel module is loaded yet, unless it be contained in the initrd.

  • either stay with a huge kernel
  • or if you want to use a generic one, make an initrd including support for your root file system
See /boot/README.initrd for an how-to.

gengisdave 12-26-2013 10:42 AM

generic version has ext4 compiled as a modules, while in the huge version is builtin compiled. You may be missing kernel-modules package, but it's more obvious that kernel can't read an ext4 fs to load the ext4 module :) (initrd is strictly required)

GNU/Linux 12-26-2013 12:36 PM

As stated you need initrd. mkinitrd package includes a script (/usr/share/mkinitrd/ that will give you the required command to generate mkinitrd.

joshua60 12-27-2013 04:27 AM

I'll keep 'huge' for the time being, thanks so much!

TSquaredF 12-27-2013 11:55 AM

There is a trend of people using the 'huge' kernels for everyday work. But, this is not recommended. From "Changes & Hints.txt":

Use one of the provided generic kernels for daily use. Do not report bugs until/unless you have reproduced them using one of the stock generic kernels. You will need to create an initrd in order to boot the generic kernels - see /boot/README.initrd for instructions.
The huge kernels are primarily intended as "installer" and "emergency" kernels in case you forget to make an initrd.
As noted above, using "/usr/share/mkinitrd/" makes creating an initrd a trivial exercise.

ccx004 09-29-2014 06:22 AM

For Information
I am posting this just in case anyone stumbles across this thread from a search engine.

I don't think this is the complete answer. I have exactly this problem with Slackware 14.1 but I am using a huge kernel. Despite that it cannot mount the root partition. I did try the initrd solution just to be sure but that results in a whole lot of errors about duplicate symbols and exec format errors. Since the modules are built into the huge kernel these errors are not surprising but it does mean there is something else wrong that prevents the kernel from mounting an ext4 partition when it boots. Sadly I don't know what it is:-(

Didier Spaier 09-29-2014 06:45 AM

@ccx004: welcome to LQ and this forum.

Unfortunately the information you give is too sparse to be helpful, and we don't know if you issue is similar to that of the original poster, or completely different.

So please tell us what you did exactly:
  • did you try to install a 32-bit or 64-bit edition of Slackware 14.1?
  • if you tried a 32-bit edition, which kernel did you use: huge.s or hugesmp.s?
  • what media did you use use? was it a DVD that you bought, or an ISO file that you downloaded?
  • in the latter case, did you check the integrity of the ISO before using it (e.g. with the md5sum command)?
  • still in the latter case, did you make a DVD or USB installation? What command did you use to burn the DVD or write on the USB stick?
  • how did you partition the hard disk? Did you make other partitions than / and maybe /home?
    Or did you re-use a former installation, without re-partitioning /? In that case what system was installed there before, and what filesystem was present on /?
  • did you make a full installation?
  • did you install lilo in the last part (CONFIGURE) of the installation? With what specific settings?

    Please answer, so we can help you and maybe others in a similar situation.

ccx004 09-29-2014 06:57 AM

As I said: "I have exactly this problem with Slackware 14.1 but I am using a huge kernel" as others described. I used an ISO image which I have used many times. It is the 32 bit version. I only posted so people would know that this is not the only issue that causes this problem. I wasn't asking for help I was just letting anyone that comes across this thread that there can be other issues. Sadly I don't know what the solution is. In fact I deleted the server a few minutes ago as it was just an experiment that I was trying and it was easier to start again.

Best wishes....

Smokey_justme 09-29-2014 07:05 AM

Yes, but we already know that... The huge/generic issue fitted the OP and related problems... There are a number of other issues that can happen at boot time and have the same simptoms, including (but not limited to) mount problem due to disk errors or file-system errors, using default naming scheme for partitions (e.g. /dev/sda1) and making hardware changes that would break the name, etc..

Didier Spaier 09-29-2014 07:06 AM

@Colin ccx004: Sorry, but there is nothing in your previous post that support your claim that your problem is exactly the same.

So I fail to see how this post can help other people to solve their problems. Of course there can be other issues, so what?

ccx004 09-29-2014 07:39 AM

Oh well
Oh okay, sorry to have bothered you

Smokey_justme 09-29-2014 07:41 AM

Well.. Your intentions we're good :) So that counts :)

All times are GMT -5. The time now is 07:06 PM.