-   Slackware (
-   -   Slackware 14.1: cdda2wav permission issues... (

andrew.46 11-12-2013 02:58 AM

Slackware 14.1: cdda2wav permission issues...
I am trying to rip an audio cd with cdda2wav on a new 64bit iinstallation of 14.1 with the following commandline:


cdda2wav -vall cddb=0 -paranoia -B
cdda2wav finds the correct address for the drive, does a cddb query correctly, allows me to select an entry but then stalls with:


scanning for ISRCs: 6 ...
index scan: 6...
cdda2wav: Permission denied. Could not open audio sample file audio_01.wav.

Can anyone reproduce this problem or even better propose a solution?

GazL 11-12-2013 03:42 AM

I assume that the current working directory is writable? Seems odd that it's complaining about the output file.

cdda2wav works here as non-root as long as I add -D /dev/sr0 (but that will force use of the "cooked_ioctl" interface). I get a whole heap of "permission denied" without it when running non-root. if you want it to use the "generic_scsi" interface (which is the one recommended in the man-page) then you'll need to make sure the sg module is loaded and run cdda2wav as root.

This looks like a job for a /usr/local/bin/rip_cd script and a corresponding sudoers entry.

andrew.46 11-13-2013 03:02 PM

Using /dev/sr0 certainly worked, thanks for pointing that out. I use modprobe sg in rc.local and the error I mentioned occurs with the scsi address as a root user; there is no problem with permissions at the destination.

I see a discussion of this issue in German:

and my schoolboy German seems to indicate that the last post in this exchange is from Jörg Schilling himself with the promise of a fix in a new release cdrtools-3.01a18. But I cannot understand the whole thread which at least starts discussing the same error that I have found, are there any German speakers reading this thread? Changelog for the new release reports:


Fixed fine grained privilege handling for Linux. Thanks for Daniel Pielmeier from Gentoo for reporting and testing.
On the weekend I will compile the newest release and see if this definitively solves the issue...

GazL 11-13-2013 05:52 PM

The generic_scsi was working for me, but that might be because I was running a custom 3.11.y kernel. google translate doesn't do too bad a job at that thread if you want to give it a go:

andrew.46 11-13-2013 06:44 PM

Thanks for the translation link :). Actually took a bit of time before work and compiled the newer version which made no difference unfortunately. I will think a little more + I have with some trepidation consulted the cdrtools mailing list...

andrew.46 11-27-2013 06:58 AM

The latest version of cdda2wav / cdrtools has resolved all issues here:


andrew@skamandros~$ cdda2wav --version | head -n 1
cdda2wav 3.01a19 (x86_64-unknown-linux-gnu) Copyright (C) 1993-2004 Heiko Eissfeldt (C) 2004-2013 Joerg Schilling

Still a little surprised that nobody else has experienced this issue...

All times are GMT -5. The time now is 01:56 AM.