-   Slackware (
-   -   Slackware 14.0 (x86_64): alsaconf nowhere to be seen. (

stf92 12-29-2012 02:45 PM

Slackware 14.0 (x86_64): alsaconf nowhere to be seen.
I've just installed Slackware 14.0 (x86_64). I installed all series, except for the series for international languages which the installer always unselects by default.

Now, when booting I get

amixer: Mixer default load error: Invalid argument
Storing default alsamixer settings: /usr/sbin/alsactl store
/usr/bin/alsactl: get_control:250: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument

And when invoking alsamixer I get

$ alsamixer
Cannot load mixer controls: Invalid argument

What can possibly be the cause? I tried to run alsaconf, but after doing 'updatedb', locate could not find it.

(a) Nor is alsaconf in the installation CD /extra / directory.

(b) Unfortunately /usr/doc/Linux-HOWTOs/Sound-HOWTO is obsolete (dated July 2001, it is still speaking of kernel 2.5 development).

(c) lspci gives
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

guanx 12-29-2012 03:56 PM

I remember I've read something to say that alsaconf is obsolete because it's broken in many places and is has only something to do with ISA sound cards.

Woodsman 12-29-2012 04:03 PM

Try alsactl init.

stf92 12-29-2012 04:27 PM

Thanks. alsactl init tambien se quejaba... but not any longer. I created /etc/modprobe.d/alsa.conf:

$ cat alsa.conf
alias snd-card-0 snd_hda_intel
alias sound-slot-0 snd_hda_intel
options snd_hda_intel model=auto

Then 'alsactl init'. Problem solved.

I found snd_hda_intel with lsmod. In fact, I could not have done it if I had not read this.

All times are GMT -5. The time now is 01:59 AM.