-   Slackware (
-   -   Slackware 14.0, UEFI and GPT -- installation in unfamiliar environment (

slaka 01-05-2013 06:44 AM

Slackware 14.0, UEFI and GPT -- installation in unfamiliar environment

So I have PC with UEFI and GPT (no secure boot enabled).
Installed it from USB stick, but no problems with that.
Made 'ext2' partition with 'gdisk' (one large 150GB partition).
Slackware installer was able to detect that partition and I made installation there and had no problems, even thought I wasn't prompted with LILO/GRUB installer or bootdisk maker (happened when installed to 'normal' disk with MBR etc) after installation.

So, since there was nothing to booting up Slackware I downloaded 'usbboot.img' and copied it to USB stick and booted it.
Then typed command:
'hugesmp.s root=/dev/sda4'

Well, that worked but I was logged in 'darkstar' and nothing worked (standard commands like cd, mv, shutdown etc).
Also tried to copy 'vmlinuz' and boot with this command: 'vmlinuz root=/dev/sda4/' -- got kernel panic.

Cliff notes:
- OP is beginner
- PC using UEFI and GPT (no secure boot, have used Linux successfully from live USB's)
- Tried to install Slackware 14.0 from USB stick (successfully, or at least think so )
- Tried to boot Slackware at /dev/sda4 (ext2) with USB stick -- downloaded 'usbboot.img' from AlienBob's site
- After booting up from USB stick I'm logged as single user, darkstar.

whizje 01-05-2013 06:59 AM

Maybe this helps or as a alternative[]=grub

slaka 01-05-2013 08:12 AM

Thanks, seems like everything I need is there.
Don't know why I was unable to find these pages when googled myself.

whizje 01-05-2013 08:16 AM

The Slackware Documentation project is fairly new so it will not be on the top of google searches yet ;-).

All times are GMT -5. The time now is 04:49 PM.