-   Slackware (
-   -   slackware 14.0 suddenly freezes (64 bit) (

0zMe 10-27-2012 11:28 AM

slackware 14.0 suddenly freezes (64 bit)
hi guys,

my hardware:

intel core i7 3520m
8gb ram
intel hd 4000 graphics

i am using slackware 14.0, 64bit version.

sometimes my system suddenly freezes. i don't know why. I don't know if my notebook is overheating but just booted it 20 minutes ago, after a couple of minutes it freezed. so i don't think it has anything to do with overheating.



system boot: 20:00
system freeze: 20:02 - 20:03

from the logs I couldn't find anything, maybe you can help me out with it.

688a 10-27-2012 11:49 AM

Check this out:

GasPipe 10-27-2012 12:26 PM

I also have Ivy Bridge processor and had this problem. I compiled 3.6.1 kernel (because of ext4 bug in newer versions) this morning and no freezes so far.

0zMe 10-27-2012 06:15 PM

thanks guys

could manage to upgrade to kernel 3.6 rc4 with config-huge for x64.

everything went successfull until i rebooted the system.
when booting the fonts got bigger and after startx i could not move my mouse or use my keyboard.

on next reboot i wanted to check for slackpkg updates but there was no eth0 interface and so no ethernet connection. very strange.

688a 10-27-2012 07:46 PM

Try to run "xorgsetup" before you run "startx".

0zMe 10-27-2012 09:49 PM

still not working :/

Mark Pettit 10-28-2012 02:27 AM

Adding a touch of humour (often needed when time are tough), don't you find it interesting that a machine that overheats ends up freezing ?

business_kid 10-28-2012 04:12 AM

You have a definite lead in the 3.6 kernel. I woulkd try for or make a 3.6 generic kernel, and initrd. Grab source, the generic config file from make and run 'make oldconfig'. It's pretty safe to say no to every peripheral that new.

Also worth checking to eliminate them are memory (can test with memtest86) and disk behaviour. Best to check from a CD rather than booted on the disk.

0zMe 10-28-2012 08:21 AM

did the whole thing again with generic config.
after install i got kernel panic. (kernel panic - not syncing vfs: unable to mount root fs on unknown-block(8,6)

booted from slackware 14 cd with the command huge.s root=/dev/sda5 rdinit=ro
it booted with kernel 3.2.29, i was able to login to my account and startx but mouse and keyboard still not working.
i also dont have ethernet connection when i boot from cd.

so i guess there is no other option than format and re-install

business_kid 10-28-2012 03:46 PM


so i guess there is no other option than format and re-install
Yes there is, you just need to fix it. Delete & reinstall rarely solves much in linux, because it is repeatable. It solves stuff in windows world. By booting on the cd, you can alter /etc/inittab to boot to console, if it isn't doing so already. About line 25, set it


and you boot to console. Download the 3.6 kernel source, and put it in /usr/src/linux-3.6.x. Run the following commands

cd /usr/src/linux-3.6*
make mrproper
cp /boot/config-generic-3.2.29 ./.config
make oldconfig #Answer the questions
make # you now have a 3.6 generic kernel
from here, best to follow install instructions here, and alter names for your version

Pick up the line after the make. Ignore the docs unless you're a programmer.

0zMe 11-13-2012 02:22 PM

thanks for help everyone.
managed to install kernel 3.6.5 and using it since 2 days. everything fine till now.

All times are GMT -5. The time now is 10:50 PM.