-   Slackware (
-   -   Slackware 14.0 -problem with mouse scrolling under KDE. (

Esthar 03-01-2013 09:56 PM

Slackware 14.0 -problem with mouse scrolling under KDE.

I've been reading up a lot on this forum lately, which is awesome since there's a lot of answers out there.

Writting this post since I've been looking a lot for a way to get mouse scrolling under KDE. (running slackware 14 on a virtualbox)

Tho a lot of posts sent me straight to editing the /etc/X11/xorg.conf file, but I guess Slack14 gets config files for input devices elsewhere. (also cant seem to run X - configure to generate a new one).

I've tried editing files in /usr/share/X11/xorg.conf.d/ and placing a copy in /usr/share/X11/xorg.conf.d/ as well, but no luck.
I've tried many configs for thoses files, none of 'em enables my precious scrolling.

This is what the .conf file looks like:

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "imps2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"

Tried theses values after searing the Xorg.0.log file, and ps -aux | grep mouse returns :
/usr/sbin/gpm -m /dev/mouse -t imps2

Would appriciate some help, this thing as small as it is drives me crazy.

Thanks in advance

allend 03-01-2013 11:42 PM

Welcome to LQ!

Have you installed the Guest Additions for Linux?

BTW - It is not considered correct to edit files in /usr/share/X11/xorg.conf.d/
Rather, copy any file that you wish to edit to /etc/X11/xorg.conf.d/ and edit the copy.

Esthar 03-02-2013 01:39 AM

Thanks a lot, I guess it was that simple...
Had no idea about guests additions!

Fixed it after a quick reboot, thanks for the tip !

All times are GMT -5. The time now is 07:14 AM.