-   Slackware (
-   -   Slackware 14.0 Linux user cross-contamination (

girvinh 09-14-2013 02:54 PM

Slackware 14.0 Linux user cross-contamination
Ever since I installed Slackware 14.0 Linux (K3.5.10), I have noticed a disturbing effect with it in that one user affects another user!

I am using the SMP Huge kernel and ever since I installed S14.0, I have noticed KDE apps in my user account being killed when I am working in another login console, especially a root console. This should not happen in Linux!

The scene is that I log in to the main console (F1), bring up KDE4 and start a few apps such as Xine playing a web radio stream and a Klondike card game, use Ctrl-Alt-F4 for example to open a new login console, log in as root and do some work in the root console. After that work is done, I switch back to the user KDE4 session with F7 and discover Xine and/or Klondike is no longer running. It or they got killed somehow. This only seems to affect actively running apps on the desktop, since the inactive apps in the task bar do not seem to be affected. Another symptom is the KDE program run command popup may be visible when I never invoked it. These symptoms imply that there is a multi-user cross-contamination bug somewhere. This should not happen in a true multi-user system such as Linux. I must note that this effect is not consistent nor repeatable. It appears random.

At first, I thought this may be a hardware problem with my 10+ year old computer, but it still happens with my new computer, an AMD Athlon II 3.4GHz 8GB system.

Anyone else experience this and/or is it a known bug in this new 3.x Linux?

Thanks in advance.
Girvin Herr

wildwizard 09-14-2013 05:58 PM

With the apps closing are you sure you've got your finger down on the CTRL key properly as ALT+F4 is close and ALT+F2 drops the run dialog box down.

Also is the keyboard the same, perhaps it's on the way out.

kingbeowulf 09-14-2013 06:54 PM

Nope, console switching while X apps are running works fine here (Slack64 14 multilib Xfce 4.10 dual monitor). This does sound like a possible keyboard issue as wildwizard mentioned. You can try running "xev" in a terminal window and see if any kb buttons don't respond reliably.

On the other hand, I don't bother with this anymore. I just pop open a terminal window (Terminal, Konsole, xterm etc) and just "su -" since that way I can do root stuff and still what vids.irc, etc. etc on the 2nd monitor.

girvinh 09-16-2013 03:44 PM

Thanks for the prompt replies.
Now that you both mention the possible keyboard effects, I thought it was a separate issue so I didn't mention it, but I now see the connection. Yes, ever since I installed S14.0, my left shift and left ctrl keys have been messing up occasionally. The right shift and ctrl keys seem to be fine. I thought it was the keyboard, but I have tried two other keyboards, one a less-used version of the one that was giving me the problems, and a completely different type. Both had exhibited the same problems, so I ruled out the keyboard as the root cause of the problem. I then suspected my old motherboard and/or the PS/2 interface on it, and after I switched to the new Mobo and did a fresh install of S14.0, the keyboard seemed to be working. Now, almost a month later, the problem has been getting worse again. I can hold the left shift key down and partway through a capitalized word, the shift will stop and I will get lower case until I release the left shift and then re-press it. Then it may work again until the next time. It certainly sounds like a bad keyboard, but I cannot isolate the problem. I tried moving the shift key around horizontally while typing upper case in case the key contacts where at fault, but that would not cause the problem. I am at a loss for a solution to this problem, since I cannot determine a root cause. It looks like software, but...

Since the left Ctrl key is also affected, the suggestion that it is the culprit for the closed apps etc. is a good one. I do believe now that is what is happening, but why would a miss-key in one user's (i.e. root) space affect the KDE domain (F7) in another user's space (F1)? That still does not seem correct for a multi-user environment.

I just tried xev as suggested and I seem to be getting somewhat periodic spurious "KeyRelease" and "KeyPress" events while holding the shift key down or even not touching the keyboard at all! Ahh! Another clue - it seems to be connected to xine. I get the spurious events if xine is playing my web stream. As soon as I stop the stream, the spurious events stop. I discovered that when xine is reduced to the task bar, I no longer get the spurious events either. I started looking at the xine Setup GUI options and discovered a "Screensaver reset interval (s)" option, which has a help of: "Time in seconds between two faked events to keep a screensaver quiet, 0 to disable". I set this to 0 and the spurious events stopped. That looks like it may be the culprit.

Yes, I could use multiple terminals in KDE. I tried that for a while after installing S14.0 with KDE4. However, I tend to open several Midnight Commander (mc) sessions for the work I do. KDE3 had a terminal feature which did allow multiple mc sessions open at once with tabs to select which session I wanted to use. It even had a root mc session tab. However, KDE4 seems to have dropped that feature (among many others I liked). So, I open up additional login consoles and bring up mc in each one to get similar processes. Also, I found that KDE4's terminals do not render mc as well in them, and then there is the mc key binding issue, which I have not spent the time on to make changes in the terminal session to enable the mc key bindings. Maybe sometime later...

Thanks again for the help.

elyk 09-18-2013 12:02 AM

Thanks for that! I knew xine was doing something evil with my keyboard too. I just took a look in the code and it's alternately pressing left ctrl and left shift. I've configured X to swap left ctrl and caps lock, so it ends up toggling caps lock for me about every 20 seconds.

girvinh 09-18-2013 06:18 PM

I am not sure I want caps lock to be toggling while I am working on a document. Well, yes, I am sure: I wouldn't. So far, changing that xine option to 0 (zero) seems to be working. I have not had the problem since. However, I want to have more test time before I mark this thread as solved. Maybe a week should do. I understand what the xine programmers were trying to do to disable the screen saver while watching a video stream or DVD, that could be annoying. However, I think they chose a bad way to do it by messing with the keyboard events. Maybe they will fix that in a later version. In the meantime, since screen saving is a deprecated feature that LCD displays do not need, I plan to disable it elsewhere on my computer.
Girvin Herr

All times are GMT -5. The time now is 05:06 AM.