-   Slackware (
-   -   Slackware 14.0 KDE keyboard layouts bug (

ve2tmq 12-03-2012 03:15 PM

Slackware 14.0 KDE keyboard layouts bug
Hi. I just reinstall my Slackware 13.37 to 14.0 (Format and reinstall, not just an upgrade). On 13.37 KDE Keyboard layout working good, I see flags on tray bar and can change layouts by clicking on it (layout US and CA). On 14.0 I try to config on KDE control pannel but flag doesn't appear on tray. I try to activate plugin (Keyboard layout), so I see flag, but could change by clicking on it.

When I right click and select configuration, I've got error : "Cannot load library /usr/lib/kde4/ (/usr/lib/qt/lib/ undifined symbol: get_x_overlay_set_window_handle)".

I find work around : on command line, I type : "setxkbmap -layout ca or setxkbmap -layout us". It's working good, and the flag on tray change to represent the current keyboard layout.

So, does any body have same issue as me? Did you find to correct it?

Thanks a lot.

kabamaru 12-03-2012 03:20 PM

I experienced the same issue, i.e. layout switcher not showing up (although I didn't have an error message). Logging out and back in, fixed it.

ve2tmq 12-03-2012 08:41 PM

Well, I tryed to logoff, logon, reboot... not success :(.

kabamaru 12-04-2012 02:34 AM

You could try deselecting "Configure Layouts" from KDE's settings (but leave "Show layout indicator" selected), and create a /etc/X11/xorg.conf.d/90-keyboard.conf file:


Section "InputClass"
  Identifier "Keyboard0"
  MatchIsKeyboard "on"
  MatchDevicePath "/dev/input/event*"
  Driver "evdev"
  Option "XkbLayout" "us,ca"
  Option "XkbOptions" "grp:alt_shift_toggle"

as a workaround. If you already have an /etc/X11/xorg.conf file you can put the code there instead.

The error message you get sounds like a library incompatibility. Is this a vanilla full install of Slackware? I run Slackware 14.0 64bit on my machine and a 32bit virtual machine and cannot reproduce your error.

ve2tmq 12-04-2012 06:41 PM

Hi. I just found the solution. On my installation I keep /usr/local with old apps, libs and others. So they were conflict with new install. So I decide to clean /usr/local and reinstall apps and libs from sources, only for apps and libs neded.

All times are GMT -5. The time now is 06:52 AM.