-   Slackware (
-   -   slackware 13 xorg server multihead doesnt work with any PCI card as secondary (

domen80 09-09-2009 05:43 AM

slackware 13 xorg server multihead doesnt work with any PCI card as secondary
I know that this worked on slackware 12.2.
But on slackware 13 multihead fails because PCI resources are disabled so x server cant do detection and it fails.

It works if i set secondary card to primary then everything works ok.

Here are two examples how cards are disabled even when i start it.

01:06.0 VGA compatible controller: Device 00a1:0300 (rev a1) (prog-if 00 [VGA controller])
Flags: 66MHz, medium devsel, IRQ 8
Memory at <unassigned> (32-bit, prefetchable) [disabled]
Capabilities: [60] Power Management version 2


01:06.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27) (prog-if 00 [VGA controller])
Subsystem: ATI Technologies Inc Rage XL
Flags: stepping, medium devsel, IRQ 10
Memory at fd000000 (32-bit, non-prefetchable) [disabled] [size=16M]
I/O ports at e000 [disabled] [size=256]
Memory at febff000 (32-bit, non-prefetchable) [disabled] [size=4K]
Expansion ROM at 80000000 [disabled] [size=128K]
Capabilities: [5c] Power Management version 2
Kernel modules: atyfb

Does anyone know what might be the problem ?


static void
pciIo_MemAccessEnable(void* arg)
#if 0
#ifdef DEBUG
ErrorF("pciIo_MemAccessEnable: 0x%05lx\n", *(PCITAG *)arg);
pci_device_cfg_write_u32(pArg->dev, pArg->ctrl, PCI_CMD_STAT_REG);

So secondary cards stays disabled.:tisk:

archtoad6 11-12-2010 11:09 AM

Your profile shows: "Last Activity: 03-13-10", so I don't know if you will see this. Maybe it will help someone else. ...

Thanks for indicating that there is a the solution. That's the LQ spirit.

Now please post the solution for everyone to benefit from. Even though this is an old thread, you never know whom it might help. TIA.

A suggestion for the future: If you answer your own question, put the solution in a separate post; this does 2 good things:
  • It generates e-mail to anyone who subscribed to either the thread or the forum.
  • It avoids the creation of oxymoronic 0-reply solved threads.

All times are GMT -5. The time now is 02:11 PM.