LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2010, 04:15 PM   #1
nenpa8lo
Member
 
Registered: Oct 2008
Location: Ireland
Distribution: Slackware 13.0, Slackware 13.37
Posts: 68
Blog Entries: 2

Rep: Reputation: 18
Slackware 13 wifi config, and now both eth and wifi are down


Greetings,

After some time (I was using my eth0 wired connection) I've decided to get my BCM4312 up and running on my vostro1310. I've found that I need wl driver from Broadcom website. Done that, so far so good. I followed alien slackbook about networking. All good. Now after I rebooted my system eth0 and wireless are down. So this is what I have:
Code:
bash-3.1# uname -r
2.6.29.6-smp

bash-3.1# ifconfig
eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX  
          inet addr:192.168.1.9  Bcast:255.255.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1030 errors:0 dropped:0 overruns:0 frame:631
          TX packets:51 errors:1001 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:75671 (73.8 KiB)  TX bytes:5602 (5.4 KiB)
          Interrupt:19 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1200 (1.1 KiB)  TX bytes:1200 (1.1 KiB)

bash-3.1# iwconfig
lo        no wireless extensions.

eth0      IEEE 802.11bg  ESSID:"Kosmodrom"  Nickname:""
          Mode:Managed  Frequency:2.417 GHz  Access Point: XX:XX:XX:XX:XX:XX   
          Bit Rate=54 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=-47 dBm  Noise level=-92 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.


bash-3.1# cat /etc/udev/rules.d/70-persistent-net.rules 
# This file was automatically generated by the //lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x14e4:0x4315 (wl)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="XX:XX:XX:XX:XX:XX", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="XX:XX:XX:XX:XX:XX", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"


bash-3.1# lsmod | grep wl
wl                   1962468  0 
lib80211                5216  2 lib80211_crypt_tkip,wl

bash-3.1# lspci | grep BCM
06:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
And this is my rc.inet1.conf:
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"


# Configuration for Broadcom4312
IFNAME[1]="wlan1"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="V13"
GETAWAY="192.168.1.254"
WLAN_MODE[1]=Managed
WLAN_ESSID[1]="Kosmodrom"
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
WLAN_WPAWAIT[1]=30
Also configured my /etc/wpa_supplicant.conf just like alien.slackbook said. Why there is no wlan1 visible but eth0, eht1?
Thank you for any help.
 
Old 04-18-2010, 05:03 PM   #2
fancylad
Member
 
Registered: Mar 2008
Distribution: slackware
Posts: 175

Rep: Reputation: 19
are you substituting x's for your mac addresses? if so what is the point of that? the reason why you don't have a wlan0 interface is because of your udev rules. according to your udev rules it looks the wireless interface is eth0.
 
Old 04-18-2010, 06:18 PM   #3
nenpa8lo
Member
 
Registered: Oct 2008
Location: Ireland
Distribution: Slackware 13.0, Slackware 13.37
Posts: 68
Blog Entries: 2

Original Poster
Rep: Reputation: 18
Edited /etc/udev/rules.d/70-persistent-net.rules and changed names to wlan1 and eth0 respectively.
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual wifi and wired connection: how to make a specific website use only wifi? shinji2001xyz Linux - Networking 2 04-08-2010 10:13 AM
wifi works:how to connect to hotspot,with console?alternative to wifi-wiz assistant? frenchn00b Debian 7 10-30-2009 12:31 PM
Ubuntu 9.04 can't connect to wifi with Intel Wireless WiFi Link 5100 Shinbatsu Linux - Networking 3 08-30-2009 12:55 AM
setting wifi and eth in slackware indriaj Linux - Newbie 3 08-05-2008 02:38 PM
Help IP Masquerading (wifi to eth) OEP Linux - Wireless Networking 17 08-10-2004 11:01 PM


All times are GMT -5. The time now is 03:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration