-   Slackware (
-   -   Slackware 13 on slackbuilds (

hua 01-24-2010 11:08 AM

Slackware 13 on slackbuilds
I tried to build several packages designed for slackware 13 at slackbuilds. Those was a simple apps like ardour, audacity ... for example.

ardour error:

./ardour.SlackBuild: line 91: scons: command not found
from line 91 the slackbuild looks like this:
scons \
PREFIX=/usr \
ARCH="$(echo $SLKCFLAGS)" \
$wiiopt \
scons \
--implicit-deps-unchanged \
PREFIX=/usr \
ARCH="$(echo $SLKCFLAGS)" \
$wiiopt \
$lv2opt \
$vstopt \
audacity error:

checking for C compiler default output file name...
configure: error: in `/tmp/SBo/audacity-src-1.3.7':
configure: error: C compiler cannot create executables
See `config.log' for more details.

in config.log:
configure:2368: gcc -O2 -march=i486 -mtune=i686 conftest.c >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set
My CPU is AMD Phenom 9550 Quad core. It supports 64 bit. My os is slackware 13_64.
What do I need to change in slackbuild to create a txz package for those apps?

phunkymunky 01-24-2010 11:46 AM

For the first error you need to install scons (

No advice for the second error since I use a 32bit system but somebody here will probably be able to help.

sojasau 01-24-2010 11:52 AM

In every Slackbuild is a Section ARCH=${ARCH:-i486}, this you must change to x86_64.

gauchao 01-24-2010 12:31 PM

You must specify the 64 bit architeture:

$ ARCH={x86_64} ./yourpackage.SlackBuild

(I suppose you have typed chmod +x yourpackage.SlackBuild before, to make it executable)

zordrak 01-24-2010 12:49 PM

The curly brackets are superfluous.

In any case, use sbopkg (

hua 01-26-2010 10:55 AM

Thanks sojasau, the 64 bit arch error solved

In every Slackbuild is a Section ARCH=${ARCH:-i486}, this you must change to x86_64
The missing package of scons worked too, but I found out that it needs more packages to be installed.
All of them finally ended with the same error: (ardour, audcity)

The ardour after scons installation, required a next library > liblrdf, which ends with the following error:

checking build system type... configure: error: /bin/sh ./config.sub -slackware-linux failed
The audacity requires libsndfile package, which ends with the same error too:

checking build system type... configure: error: /bin/sh ./config.sub -slackware-linux failed
To zordrak >

The curly brackets are superfluous.
What does this mean? There is a problem with this line (for example)? >

How it should look like?

XGizzmo 01-26-2010 11:11 AM

The SlackBuild does not need to edited in any way. You simply need to follow
the directions listed here

brianL 01-26-2010 11:12 AM

Get sbopkg, it makes things easy when you have a number of SlackBuilds to run. When you want to install something with several dependencies (the Slackbuild readme files tell you what's needed), then you can queue them up in sbopkg to build and install in the right order. it automatically detects the right architecture, too.

ponce 01-26-2010 11:21 AM

+1 for sbopkg.
look for needed packages on after you found all dependencies you can build easily with sbopkg creating a queuefile named /var/lib/sbopkg/queues/audacity.sqf with this content

audacity | SOUNDTOUCH=yes TWOLAME=yes

then issue a

sbopkg -i audacity
and answer to the questions (keep queuefile options ;) ).

if audacity gives you problems building with soundtouch and twolame support, you can use the official queuefile written by slackbuilds' audacity mantainer.

same thing for ardour: read slackbuild's page for hints on dependencies (to write a queuefile).

hua 01-26-2010 11:48 AM

sbopkg is great, thanks for the hint.
I built a queue for ardour, put there these packages >

liblo, liblrdf, scons, fftw, libsamplerate, libgnomecanvas,
jack-audio-connection-kit, aubio
But I get stucked with liblrdf, with the error:

make[2]: Entering directory `/tmp/SBo/liblrdf-0.4.0/examples'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -O2 -fPIC -O2 -fPIC -MT showdefaults.o -MD -MP -MF ".deps/showdefaults.Tpo" -c -o showdefaults.o showdefaults.c; \
then mv -f ".deps/showdefaults.Tpo" ".deps/showdefaults.Po"; else rm -f ".deps/showdefaults.Tpo"; exit 1; fi
showdefaults.c:3:20: error: ladspa.h: No such file or directory
make[2]: *** [showdefaults.o] Error1
make[2]: Leaving directory `/tmp/SBo/liblrdf-0.4.0/examples'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/liblrdf-0.4.0'
make: *** [all] Error 2
ladspa.h? Maybe another library is required?

brianL 01-26-2010 11:57 AM

It could be part of this, but it's not mentioned as a dependency for ardour:

ponce 01-26-2010 12:27 PM

but it's a dependency of liblrdf.
first thing you have to learn working with is that dependencies often need their own dependencies ;)

brianL 01-26-2010 12:49 PM

Yeah, of course. I didn't bother looking any further back than ardour and ladspa. :)

hua 01-26-2010 01:04 PM

I like dependencies. It tests my will to achieve the goal. And since it is important to me it finally works with your help.
Thanks for all of you.
The finally order of packages is:

liblo, ladspa_sdk, liblrdf, scons, fftw, libsamplerate, libgnomecanvas,
jack-audio-connection-kit, libsndfile, aubio
So the packages ladspa_sdk and libsndfile are required for ardour too.

brianL 01-26-2010 01:13 PM

That's one of the things that make Slackware more interesting than some other distros. Finding out what depends on what and getting it yourself, rather than letting a package manager do it.

All times are GMT -5. The time now is 03:52 PM.