-   Slackware (
-   -   Slackware 13 Network Settings (

ibwew 09-06-2009 04:06 AM

Slackware 13 Network Settings
I just installed Slackware 13 and I cannot see my network settings with KDE
I get an error "could not parse XML file()" My networks connect fine and I can see them with iwlist or ifconfig from the command line....just cant see the setting with KDE. I have the same problem on both my Laptop and Desktop computers. Any ideas??


shelleywang 09-06-2009 04:32 AM

so do I

markush 09-06-2009 05:07 AM

Hello ibwew,

welcome to LQ,
If everything works fine in your network, why do you want to see the settings in KDE? I don't know what to do to make KDE show the networksettings. But it is not the prefered method in Slackware, to configure the system via a gui-tool.


ibwew 09-06-2009 05:15 AM

It's easier to switch networks.....especially on my Laptop. I used the GUI
with Slackware 12.2 and it was easier to change the wireless settings...just "point and click". Now I have to edit my /etc/rc.d/rc.wireless.conf file to switch wireless networks...PITA!!


Nylex 09-06-2009 05:21 AM

You could try using wicd. Slackware has a package for it.

ibwew 09-06-2009 05:32 AM

Already installed and tried joy!!

onebuck 09-06-2009 10:01 AM



Originally Posted by ibwew (Post 3671678)
Already installed and tried joy!!

What errors or information when you attempt 'wicd'?

ibwew 09-09-2009 02:24 PM

OK........I got wicd working!! Had to add myself to the netdev group.
Thanks everyone for your help!!

ibwew 09-09-2009 02:27 PM

I still would like to be able to see my network setting with KDE though...if anyone has a solution I would love to hear it.


Alien Bob 09-09-2009 02:51 PM

Contact the KDE people who added "Slackware network configuration support" but didn't check with the Slackware developers to make it actually work...


eraosso 10-13-2009 09:27 PM

Forever newbie...
1 Attachment(s)
Ok, I had just installed Slackware 13.0 and got no network working.
I also got the same error in KDE (prnt screen attached). How to get out of here and have eth0 up and running?

markush 10-14-2009 01:19 AM

Hello eraosso,

please let us know which network card you're using. Wired or wireless? what is the output of ifconfig? please post the related part of your /etc/rc.d/rc.inet1.conf.


eraosso 10-14-2009 07:10 AM

3 Attachment(s)

Originally Posted by markush (Post 3718497)
Hello eraosso,

please let us know which network card you're using. Wired or wireless? what is the output of ifconfig? please post the related part of your /etc/rc.d/rc.inet1.conf.


Hello Markus,
I was trying the wired card. Wireless will come next. :D

Attached are dmesg, ifconfig and rc.inet1.conf.

Since I did not know what is the important part of rc.inet1.conf, I attached the whole file.

On dmesg I found the following about eth0:
  • eth0 (3c59x): not using net_device_ops yet
  • ADDRCONF(NETDEV_UP): eth0: link is not ready

Thanks again for the help!

markush 10-14-2009 07:50 AM

Hello eraosso,

your networkinterface is set up correct with the appropriate drivers. But it did not get an IP-configuration via DHCP. If you use DHCP you shoud try:

dhcpcd eth0
(as root) if you don't have DHCP it is necessary to edit rc.inet1.conf and create the necessary entries manually.
The IP-adress which ifconfig shows for eth0 is a so called APIPA-adress (automatic private ip adressing) which the computer generates if there is noch configuration available via DHCP.
Have you used Slackware before installing Slack13? Have you made any changes? As far as I know the network-configuration while the installation has not changed since earlier versions of Slackware.


eraosso 10-14-2009 08:10 AM

Hi Markus,
this is a plain vanilla installation I did yesterday.
I have played with Slackware since version 8, then installed Slack 11 and even played with wireless. But I never had such problems... Usually network was up and running without issues.
I will give it another try and will revert back in case I do not succeed.

Thanks again!

All times are GMT -5. The time now is 10:43 AM.