-   Slackware (
-   -   Slackware 13+Current Huawei E1552 HSDPA USB Wireless Broadband (

dc_eros 02-25-2010 12:52 AM

Slackware 13+Current Huawei E1552 HSDPA USB Wireless Broadband
Hi there slackers,

I have Slackware 13+current as of Jan 31, 2010. Except that kernel is I brought yesterday a new Globe Tattoo prepaid kit (a wireless broadband kit -- mobile broadband service here in the Philippines) which uses Huawei E1552 HSDPA USB stick (usb modem).

I understand that they don't natively support linux but from what I've learned, they are the most linux friendly wireless broadband provider. There are few success stories about installing them on Ubuntu, Xandros, Linux Mint and OpenSuSE.

I do searched the net and found:

Which says I need to compile to create a huaweiAktBbo but when run, it says 'dev' failed. (Compile succeed though).

I tried kppp but my Huawei USB stick is detected as USB storage and not as a modem, so i need to use usb_modeswitch.

I grab it from and tried to download the source but it seems that SlackBuilds has not updated yet its link (and the slackbuild package). I tried to make and make install the latest source from but I think I forget that switch-data and conf, anyway I have to re-download again.

Do I need libusb? Or slackware 13 already have it? (I just learn while typing this that I forgot to download the switch-data and the conf file)

Another thing, I found this:

But it says I need the qt compat lib from /extra? Is it this: ?

I think kppp will do the job, but I must gather more information first before going home.

Any other things to consider?


masonm 02-26-2010 10:22 AM

usb_modeswitch is what you need for that dongle. Yes, it does appear you also need the data and conf files as well so you'll want to download those.

Try compiling it with the data package installed first, following the instructions listed on the page you linked.

ponce 02-26-2010 10:55 AM

I use an huawei e220 hsdpa usb with wvdial: I packaged wvstreams and wvdial, version 1.61 of wvdial because 1.60 doesn't build on current.
after installing these two, I use this /etc/wvdial.conf (I got a 3 rechargeable key) and I launch the connection in a root shell with

wvdial hsdpa
maybe using a slightly different wvdial.conf for you should be enough.
no need for usb_mode_switch for me.

dc_eros 02-26-2010 11:06 PM

Hey there,

I have used modprobe option instead and it appears that the modem is at /dev/ttyUSB2. I tried kppp and tried to connect but it gives me the NO CARRIER error. Anyway, I will try your suggestions first. Got to restart to boot slack.

dc_eros 02-27-2010 12:50 AM

I tried it but wvdial requires Trying to look at slackbulds.

By the way, I just installed the latest version by installing from source.

Do I need to use the slackbuild and change the source code instead?

EDIT: uniconf is included in wvstreams, do I have to symlink something or a simple restart?

dc_eros 02-27-2010 01:48 AM

Thanks for your replies! I'm now posting this on my Slackware 13+Current. I just forgot I scheduled ldconfig daily that the new lib was not registered.

A simple ldconfig solves it.

All times are GMT -5. The time now is 06:03 AM.