LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-04-2009, 09:15 PM   #1
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Rep: Reputation: 37
slackware 13 and compiz-fusion


Hi!
In the previous version of slack(12.2) im using the compiz packages from slackbuilds, and it seems that in slack13 is unmainteined now, im thinking in make the slackbuilds for 0.8.2 version of compiz........or anyone have it, or you guys install it from source

thanx a lot
 
Old 09-04-2009, 09:38 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
NOTE: I've made slackbuilds for the newest release (0.8.4) here http://webpages.charter.net/daedra1/...-fusion.tar.gz

You don't need the source for fusion-icon, all the other sources cam be found here http://releases.compiz-fusion.org/0.8.4/


Im running it right now, the easiest way IMO right now is the use the slacky.eu 12.2 slackbuilds (they are newer than the slackbuilds.org). I can confirm they work. Here is the address
http://repository.slacky.eu/slackwar...ion/0.8.2/src/

However the first thing you need to do is install the requiredbuiler package supplied by slacky @ http://stabellini.net/requiredbuilder.html

Once that is installed then you need to install CF is THIS ORDER.

1) compiz (slackware ships with 0.7.8. you need 0.8.2, just upgrade)
2) compiz-bcop
3) libcompizconfig
4) compizconfig-python
5) compiz-plugins-main
6) compiz-plugins-extra
7) compiz-plugins-unsupported
8) ccsm
9) Emerald (optional)
10) fusion-icon (optional, but highly recommended) URL http://repository.slacky.eu/slackwar.../20090211/src/

You can also use src2pkg, I actually built my 13.0 packages that way, but the builds work too.


Also if your using KDE4 you need to disable "desktop effects" in the system settings. You wont need it since CF will be taking over the compositing duties

Last edited by Daedra; 01-07-2010 at 06:15 PM.
 
1 members found this post helpful.
Old 09-05-2009, 11:20 AM   #3
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
GREAT MAN!!

with src2pkg works fine, with the slackbuild from slacky dont

but.......emerald hangs up when i try to load themes....as user, weird ah?

than a lot dude, xfce without compiz.......is unthinkable
 
Old 09-05-2009, 03:56 PM   #4
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Did you enable "Window Decorations" under "Settings Manager"? I had the same problem. It was because a lot of basic features were disabled after install. You also need to enable "Move" "Resize" window to be able to manipulate windows. Sorry about the slacky builds. I remember now that i only used them for certain portions and used src2pkg for everything else.
 
Old 09-05-2009, 09:36 PM   #5
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
mmm i activate several things........but still hangs up....
i cant load themes for emerald
there is a way to change the window decoration from console?
tell me the things that you have activated

Last edited by specialized; 09-05-2009 at 09:37 PM.
 
Old 09-05-2009, 09:42 PM   #6
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
what happens exactly? Does it crash the system or does it just not show up? Cause I also have xfce running and emerald crashes when I try to change a theme too. to get around it I just changed my window manager back to xfce then I could change the emerald theme, then I reactivate compiz and emerald will then run my new theme. I use the fusion-icon for this. However "Window Decorations" has to be enabled in settings for emerald to work, otherwise you will see nothing. I'll post a screen shot of my setting in a few minutes

Last edited by Daedra; 09-05-2009 at 09:47 PM.
 
Old 09-05-2009, 09:55 PM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Here is a screenshot of my settings in ccsm.
http://webpages.charter.net/daedra/settings.png

and a configuration file. I disable a lot of stuff by default since I only need a few things, but your welcome to look at it
http://webpages.charter.net/daedra/settings
 
Old 09-06-2009, 07:47 AM   #8
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
i have window decorations enable and my setting are.... like yours.
compiz and the efects works fine but when a try to load q new theme for emerald, the emerald-theme-manager hangs up, freezes(se cuelga)and dont load anything and i must close the window because is not responding, if i start a session as root in xfce, wirks great....i dont know.

And if a exec the theme-manager from console everything seems to be ok
 
Old 09-06-2009, 07:49 AM   #9
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
screenshot
Attached Thumbnails
Click image for larger version

Name:	Screenshot.jpg
Views:	233
Size:	121.4 KB
ID:	1407  
 
Old 09-06-2009, 08:06 AM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I'm using compiz-fusion 0.8.2 here (built by hand, without slackbuild) and notice something similar. I can actually switch emerald themes *once* and then emerald hangs for anywhere from 10 seconds to a full minute. Then it seems to come back to life. In that time, it does dim and I get that popup window. I haven't tried to investigate to see what's going on, but running emerald-theme-manager via strace (or with gdb) might give some clue as to why it's hanging.

Adam
 
Old 09-06-2009, 08:27 AM   #11
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
with strace


gettimeofday({1252243694, 587935}, NULL) = 0
gettimeofday({1252243694, 587971}, NULL) = 0
gettimeofday({1252243694, 591120}, NULL) = 0
gettimeofday({1252243694, 591162}, NULL) = 0
gettimeofday({1252243694, 591198}, NULL) = 0
gettimeofday({1252243694, 594332}, NULL) = 0
gettimeofday({1252243694, 594373}, NULL) = 0
gettimeofday({1252243694, 594408}, NULL) = 0
gettimeofday( <unfinished ...>

and so on................. until i kill the theme manager
 
Old 09-06-2009, 03:30 PM   #12
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Yeah this is a weird problem. Like I said I'm having the same problem but for me as long as compiz is disabled when I choose my theme I'm ok, if not then it locks up. In fact it hard locked my system.
 
Old 09-06-2009, 10:12 PM   #13
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
you disable compiz from fusion-icon ?? that doesn't works for me
the weird thing is...... as root works fine, i don't thing in a group problem o users or whatever
 
Old 09-07-2009, 12:48 AM   #14
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,625

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
Quote:
Originally Posted by specialized View Post
you disable compiz from fusion-icon ?? that doesn't works for me
the weird thing is...... as root works fine, i don't thing in a group problem o users or whatever
No I use fusion-icon to turn off compiz then once compiz is off I launch emerald theme manager. Then I am able to change the theme. Then once I reenable compiz the new theme will appear.
 
Old 09-07-2009, 11:06 AM   #15
specialized
Member
 
Registered: Sep 2005
Location: Mar del Plata, Arg
Distribution: Always Slackware
Posts: 228

Original Poster
Rep: Reputation: 37
i don't understand why im the only one with this problem....
also i try to remove nvidia and use nv........but its the same
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing compiz-fusion on slackware-current Vic1ous Slackware 4 06-18-2009 02:09 AM
compiz-fusion and fusion-icon problems psilo357 Linux - Software 2 12-22-2008 04:41 PM
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 01:08 PM
compiz-fusion problems with slackware ati x1600pro konqi Linux - Software 3 06-27-2008 02:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration