-   Slackware (
-   -   Slackware 13.37 and SpamAssassin (

Lucifer4o 05-16-2011 09:43 AM

Slackware 13.37 and SpamAssassin
Hello guys,

This is my little bit of headache - I have an Slackware 13.37 mail + web server with SpamAssassin installed with all deps from (using sbopkg offcourse).

Until going to 13.37 all seemed fine and worked. Today I saw 3-4 spam messages and tried sa-update to update the spam rules, but I got the following message:


root@gate:/root# sa-update
defined(%hash) is deprecated at /usr/lib/perl5/vendor_perl/5.12.3/Mail/SpamAssas                                                                                                  sin/ line 757.
        (Maybe you should just omit the defined()?)

Tried recompilling all deps and the SpamAssassin it self, but to no avail.

And the worst part is that spam is coming trough ...

vulcan59 05-16-2011 01:29 PM

It's a problem with SpamAssassin and versions of Perl since 5.12.1. I believe that the messages are only warnings so it should still function correctly. I installed SpamAssassin 3.3.2-RC1 from SVN and the messages have gone away. If you're not comfortable doing that then I suggest waiting for an official release of 3.3.2 which will hopefully not be too far away.

Lucifer4o 05-16-2011 11:37 PM

I'll keep waiting.
Thank you ... probably it is just a warning (without SpamAssasin I receive 100+ spam messages a day)

All times are GMT -5. The time now is 10:48 AM.