-   Slackware (
-   -   Slackware 13.37 64bit Not booting properly (

seangregory 05-13-2011 04:55 AM

Slackware 13.37 64bit Not booting properly
Hi Guys

I bought a new laptop HP Pavillion dv3-4170ee that has Core i5 2.53ghz dual core with hyper threading, intel hd graphics and Ati Radeon HD 5470 512 mb dedicated. It came with windows 7 64bit. It also has 6 gb ram(2gb in first slot + 4 gb in the second one).

I installed slackware 13.37 64 bit. It installed just fine. installed lilo onto mbr. When it boots up it shows the slackware screen. I am able to boot into windows just fine. When I select Linux it boots into linux bios data check successful. lots of stuff goes on the screen the normal linux boot stuff. and then it goes to the next screen and stays blank

Nothing happens and even the hard disk light is not blinking.
By the way the HDD is Western Digital.

Please help me find a way around this

Best Regards

zordrak 05-13-2011 11:32 AM

I would guess this is related to KMS on the radeon. I don't know how to make that work properly not having Radeons, however I might be able to help you get a normal framebuffer going.

Follow this guide for re-installing lilo from the boot CD/DVD:
Re-installing lilo from a Slackware boot CD

At the point of editing lilo, add the line:

And ensure you have a normal vga= line such as:
vga=791 (1024x768x32)
vga=ask (to prompt with available modes).

then continue to run lilo and reboot. Hopefully you'll get all the way through the boot process then.

seangregory 05-13-2011 01:26 PM

Thank you Zordrak a million times

I was able boot into the system and performed my initial configuration . But still x is not working By the way my resolution in windows is 1366 x 768

How can I work a way around this


zordrak 05-13-2011 01:43 PM

Well.. I know the Intel graphics drivers usually don't work if you disable KMS. It may be the same with the Radeons meaning that you have to get KMS to work properly to get the X drivers working properly. At this point you need help from someone who uses ATI cards.

Sorry I can't be of more help here.

adamk75 05-13-2011 09:40 PM

Instead of passing nomodeset to the kernel, try 'video=640x480'. That should force KMS to a 640x480 resolution on the console.


seangregory 01-31-2012 01:56 PM

Hi all

After a year .. I am coming back to this thread again. is there any solution to the problem any new developements in linux that can be used to find a way around this problem..

Please help

colorpurple21859 01-31-2012 06:36 PM

either you will have to compile and install a more recent kernel with the correct video modules included, or install the correct closed source drivers from radeon's website.

seangregory 02-01-2012 11:43 AM

Since I am not able to boot into the system to perform all these .. how will i do it???

colorpurple21859 02-01-2012 12:12 PM

you can use the installation dvd/cd to boot the slackware installation. Once you get booted into the installation add

append = "nomodset"
to /etc/lilo.conf slackware entry just above the

read only line
, run lilo at the prompt.

seangregory 02-02-2012 12:39 AM

But still how will i be able to boot to gui.. that wont work. i have tried this before...

colorpurple21859 02-05-2012 02:23 PM

What have you tried. you don't need gui to compile newer kernel or install ati-radeon drivers from their website. can you get to gui with startx at the console prompt

seangregory 02-06-2012 01:11 PM

I have tried start x from cli.. but its blinks and goes blank... i will have to give it a try again.. i am not remembering exactly how this happened. could u please tell me how to install the ati drivers from cli

colorpurple21859 02-06-2012 01:53 PM

once you get the driver from radeon's web site cd to the location it is in, probably in the Download folder, then at the prompt ./<name of driver>

seangregory 02-07-2012 02:35 PM

OK. i installed slackware 13.37. installed fine. then something wierd happened.
booted into the system and wola it booted just fine. i added a user. alsa conf updatedb done. logged in as user. startx worked. then i restarted it doesnt work. i am able to reach the command prompt by passing nomodeset to kernel. i tried installing ati driver from site. but i tried sh ./a*.run but its says permission denied. i tried to install it in root privilages only. any suggestion guys. i would really appreciate it. Thanks in advance

colorpurple21859 02-07-2012 03:28 PM

Run eiher


as root, don't use sh./

All times are GMT -5. The time now is 04:47 PM.