-   Slackware (
-   -   Slackware 13.37 64 boot hang in new asus laptop (

hottdogg 01-06-2012 09:24 PM

Slackware 13.37 64 boot hang in new asus laptop
I have problem with slackware 13.37 64bit on my new asus n43s laptop (no-preinstalled OS).
After installation,when booting where the dmesg is scrolling suddenly the screen is dark
and my laptop just hang.
I suspect the problem is with hdd advanced format . I can be wrong,though.
I have brought the laptop to asus service center, they said the hdd is fine.

So here's data that I took using live cd from the laptop.


[  12.712899] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 1
[  12.823928] Adding 6291452k swap on /dev/sda3.  Priority:-1 extents:1 across:6291452k
[  12.910559] fuse init (API version 7.15)
[  13.386053] EXT4-fs (sda1): re-mounted. Opts: (null)
[  13.490101] EXT4-fs (sda1): re-mounted. Opts: (null)
[  13.984391] ppdev: user-space parallel port driver
[  13.997228] lp: driver loaded but no devices found
[  17.698621] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)

that last line is the last data from dmesg log

fdisk -l

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x96ab74d5

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1            2048  419432448  209715200+  83  Linux
/dev/sda2      419434496  1048580096  314572800+  83  Linux
/dev/sda3      1048582144  1061165056    6291456+  82  Linux swap

that's the way I partition the hdd. After researching hours in internet,
seems that for advanced format hdd, the partition needs to start
from multiple of 8 or something like that.
Before like this I had partitioned using partedmagic using gparted gui, starting from
63 IIRC, the end result is the same ,i.e. Slackware hang in the middle of dmesg

Anyone have solved this kind of problem?
I'm getting frustrated
If you guys need more data just let me know

allend 01-07-2012 01:45 AM

If you could run the Slackware installer successfully, then this suggests there is no problem with running Slackware on your machine.
It is more likely that you have had some problem in the install, either an incorrect setup or some corruption on your install media.
I suggest checking the validity of your install media and reinstalling.

Martinus2u 01-07-2012 06:26 AM

doesn't look like a hdd issue. have you tried this?

All times are GMT -5. The time now is 12:12 PM.