-   Slackware (
-   -   Slackware 13.37 64 bit, getting a Dell 1250c printer to work. (

lttldog 01-25-2012 04:45 PM

Slackware 13.37 64 bit, getting a Dell 1250c printer to work.
This is my first time ever asking a question on a linux forum so bear with me :)
I've been trying to get a Dell 1250c printer working. Now they say a xerox phaser 6000B will work but that's not in the list and i went to the xerox site and they have 2 linux packages a .deb and a .rpm neither of which is particularly useful for what i need especially for 64 bit. Does anyone have any ideas?

allend 01-25-2012 07:36 PM

Welcome to LQ!

I have no personal experience with your device, but my suggestion is to download the .rpm from the xerox site and then run 'rpm2tgz Xerox-Phaser_6000_6010-1.0-1.i686.rpm' to create a Slackware package. Then, as root, do 'installpkg Xerox-Phaser_6000_6010-1.0-1.i686.tgz'. Then, still as root, restart CUPS using '/etc/rc.d/rc.cups restart'.

I have looked at the .rpm package and it seems very straight forward.

After restarting CUPS, use a web browser to access the CUPS daemon at http://localhost:631. Hopefully you will be able to configure the printer.

Good luck with this.

lttldog 01-26-2012 10:24 AM

oh well.
First off thank you for replying. I did everything and it worked as far as it went. I did get the driver installed and the driver set up. The printer was giving me a yellow light before, which seems to mean the printer is not recognized. When I installed the new driver the printer had a green light, until I tried to print this page. It stayed green for about a minute and then went back to yellow. It seems to half recognize that drive and in all my searching of the web (I'm fairly good at that) I only came up with that driver as working with the Dell 1250c. Seems like I was led astray. :) i have been using Linux for years but I am no more than a mid level Linux user. I have no idea how to use cups since I have never had a printer set up under Linux before. So I don't know where to go from here but if you have any ideas I would appreciate the direction. I have a dual boot system with windows 7 but I'm not really a windows fan so I don't use it much, but I can work the printer under windows if worse comes to worst, but I really would like to set it up under Linux. Thank You for your time

lttldog 01-26-2012 10:32 AM

One more thing..
When I try to print a page under status it says: missing %%EndSetup!

allend 01-26-2012 04:57 PM

Try installing the 32 bit version of CUPs from Alien_Bob's multilib.

lttldog 01-26-2012 07:59 PM

No such luck
I did install it and it didn't work so I also installed the multilib support too. It did get rid of that error message and it seems to be getting closer to working with each step. When I try to print a page it processes for about 3 minutes then the light on the printer goes back to yellow. It's driving me nuts! lol. Any other ideas? Doing the multilib install was the last thing in my bag of tricks. Thanks again!

lttldog 01-26-2012 08:32 PM

i also tried..
I was looking through the cups driver list and I saw they didn't have any Xerox listed but they did have tkph6001.ppd, Tektronix Phaser 600 and 600 extended. I tried both of them and no luck there either.

michaelk 01-26-2012 08:58 PM

Your printer falls under the GDI class. linux support is not so good.

lttldog 01-26-2012 09:16 PM

Thanks for the link
Yeah it's beginning to look like that but there are people who say the Phaser driver worked for them on Linux.

allend 01-26-2012 10:51 PM

Perhaps you could try the foo2qpdl printer driver.

The Changelog here has an entry:

Tue Jun 07 2011 ... - New program: hbpldecode for decoding Fuji-Zerox cp105b and Dell 1250c
This link says:

A HBPL stream is the printer language used by the Fuji-Xerox cp105b and the Dell 1250c printers.

lttldog 01-27-2012 05:37 PM

That seemed very promising
I did install those drivers and i tried that specific one and the lava driver but still no luck.That did seem very promising. Thanks for all the help.

allend 01-28-2012 07:20 PM

I assume you have seen this thread. There are some tips on getting this to work with the Xerox Phaser 6000B driver in post#5, including having the latest firmware update and matching the default settings between operating systems.

lttldog 01-29-2012 01:58 PM

Yes I saw
I did see that thread. It's part of why I was trying the Phaser 6000B. The firmware is the latest but I am not sure what the person means by matching default setting since Windows doesn't use cups. The basic settings are the same but since it's a USB printer you can only attach one machine at a time to it. I can't even get it to print a test page. Thanks for replying.

AlmasiKalman 12-09-2012 11:49 AM

Did you finally manage to print?
Hi, lttldog!

I also have a Xerox Phaser 6000B, and I was always satisfied with it under openSuSE 12.1 (32-bit). But last week I bought a new desktop machine, and I installed openSuSE 12.2 (64-bit) on it. From that moment my printer hasn't been working.
If you have the solution, please let me know it.


All times are GMT -5. The time now is 04:34 PM.