LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-26-2010, 10:56 PM   #1
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 312

Rep: Reputation: 59
Slackware 13.1 Netconfig problem


I'm having a problem with DHCP internet connection on Slackware 13.1, everything seems to be set up correctly, yet there is no internet.
At first I thought it's just my second NIC, so I've changed eth1 to eth0 in 70-persistent-net.rules, and restarted rc.inet1
/etc/rc.d/rc.inet1 restart
Code:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: broadcasting for a lease
dhcpcd: eth0: offered 67.xxx.xxx.xxx from 68.xxx.xxx.xxx
dhcpcd: eth0: acknowledge 67.xxx.xxx.xxx from 68.xxx.xxx.xxx
dhcpcd: eth0: checking for 67.xxx.xxx.xxx
dhcpcd: eth0: leased 67.xxx.xxx.xxx for 2843 sec
dhcpcd: eth0: MTU set to 576
forking to background
route
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
loopback        *               255.0.0.0       U     0      0        0 lo
/var/log/syslog
Code:
martian source 255.255.255.255 from 96.xxx.xxx.xxx on dev eth0
ll header: ff:ff:ff:ff:ff:ff:01:xx:xx:xx:xx:xx:xx:xx
etc, etc...
/var/log/messages
Code:
May 26 21:18:58 otis dhcpcd: eth0: carrier acquired
May 26 21:18:58 otis kernel: e1000: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX
May 26 21:18:58 otis dhcpcd: eth0: rebinding lease of 67.xxx.xxx.xxx
May 26 21:18:59 otis dhcpcd: eth0: acknowledged 67.xxx.xxx.xxx from 68.87.72.16
May 26 21:18:59 otis dhcpcd: eth0: checking for 67.xxx.xxx.xxx
May 26 21:19:04 otis dhcpcd: eth0: leased 67.xxx.xxx.xxx for 4768 seconds
May 26 21:19:05 otis kernel: e1000: eth0 changing MTU from 1500 to 576
May 26 21:19:05 otis dhcpcd: eth0: MTU set to 576
May 26 21:19:05 otis dhcpcd: eth0: carrier lost
May 26 21:19:05 otis dhcpcd: eth0: MTU restored to 1500
May 26 21:19:05 otis kernel: e1000: eth0 changing MTU from 576 to 1500
Any idea what might cause it?.
 
Old 05-27-2010, 12:41 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,566

Rep: Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794
Hi,

It looks like the dhcpd server does not setup a default gateway.
How do you connect to the net?
 
Old 05-27-2010, 01:37 AM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,997

Rep: Reputation: Disabled
found this irc log in which I think (i don't know french ) they suggest commenting this option in /etc/dhcpcd.conf
Code:
# Respect the network MTU.
option interface_mtu
this to avoid getting the mtu from your router that is probably sending the wrong value of 576, for ethernet the default of 1500 should work.

Last edited by ponce; 05-27-2010 at 01:39 AM.
 
Old 05-27-2010, 01:43 AM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,069

Rep: Reputation: 160Reputation: 160
Quote:
Originally Posted by ponce View Post
found this irc log in which I think (i don't know french ) they suggest commenting this option in /etc/dhcpd.conf
Code:
# Respect the network MTU.
option interface_mtu
this to avoid getting the mtu from your router that is probably sending the wrong value of 576, for ethernet the default of 1500 should work.
But the OP was using 1500. A larger value may cause problems. A smaller value can slow down the network. So maybe you pointed out the key point.

Nevertheless, it'll be better if the OP can define "no internet" more clearly -- e.g. "I cannot ping XXX.XXX.XXX.XXX" or "I cannot view http://somewhere.com".
 
Old 05-27-2010, 04:19 AM   #5
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 868

Rep: Reputation: 265Reputation: 265Reputation: 265
Quote:
Originally Posted by guanx View Post
But the OP was using 1500. A larger value may cause problems.
Not according to the logs posted.

The logs quite clearly show the MTU is getting set by dhcpcd to 576 when the IP lease is gained and then reset again when the link fails completely.
 
Old 05-27-2010, 05:24 AM   #6
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: LinuxMint 17
Posts: 104

Rep: Reputation: 23
It would help if you could tell us more about your modem/router setup and make and model. Some older European routers only had a MTU of 576. Static or dynamic IP.

Last edited by jtarin; 05-27-2010 at 05:26 AM.
 
Old 05-27-2010, 05:37 AM   #7
Intel_
Member
 
Registered: Mar 2009
Location: Bulgaria
Distribution: Slackware
Posts: 103
Blog Entries: 5

Rep: Reputation: 20
I had the same problem, but after entered static addresses now work fine.
 
Old 05-27-2010, 06:18 AM   #8
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,069

Rep: Reputation: 160Reputation: 160
Quote:
Originally Posted by wildwizard View Post
Not according to the logs posted.

The logs quite clearly show the MTU is getting set by dhcpcd to 576 when the IP lease is gained and then reset again when the link fails completely.
Yes. You are right. A search showed first 3 results from Arch, Gentoo, and NetBSD. (The 4th is this thread.) The solution is to disable the offered MTU.
 
Old 05-27-2010, 09:41 AM   #9
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 312

Original Poster
Rep: Reputation: 59
Yep, you were right, it was a problem. So is it some sort of a bug, or is it a modem, in fact it's kind of old.
Anyway, thanks all of you for your help.
 
Old 06-03-2010, 06:12 AM   #10
snr
LQ Newbie
 
Registered: May 2010
Posts: 1

Rep: Reputation: 0
in /etc/dhcpcd.conf

find "nohook lookup-hostname"

modified to "nohook hostname"

problem solved.
 
Old 07-21-2010, 12:44 AM   #11
dgauze
LQ Newbie
 
Registered: Jul 2010
Posts: 3

Rep: Reputation: 0
Quote:
in /etc/dhcpcd.conf

find "nohook lookup-hostname"

modified to "nohook hostname"
Quote:
they suggest commenting this option in /etc/dhcpcd.conf
# Respect the network MTU.
option interface_mtu
Can anyone tell me which of these two methods is preferable? I never had a problem with SW 13.0, but when I upgraded to 13.1, I could not connect to the internet.
 
Old 07-21-2010, 01:13 PM   #12
dgauze
LQ Newbie
 
Registered: Jul 2010
Posts: 3

Rep: Reputation: 0
anyone?
 
Old 07-24-2010, 05:42 PM   #13
tuubaaku
Member
 
Registered: Oct 2004
Distribution: Slackware, Mint
Posts: 122

Rep: Reputation: 16
I'm having a similar issue on an eee pc. I'm connecting over a wireless connection to a netgear wireless switch, which is connected over a wired connection to a dhcp-server slackware box that connects to the internet. I'm using wicd to configure the wireless connection and connect to the wireless switch. It thinks it gets an ip address fine, but then doesn't connect to the external internet or to other machines on my network.

I've tried disabling both suggested options in /etc/dhcpcd.conf. I thought there might be a firewall issue, so I turned that off. Every once in a while, I'll be able to connect to a website right after I connect, but otherwise I can't connect to anything.

Everything is fine with my wired connection, and other computers can connect over wireless. And, this setup worked fine with Slackware 13.0 on the eeepc.

Any thoughts? Anything else I could check, or insights into the problem? Or do I need to just go back to 13.0?
 
Old 08-03-2010, 06:52 PM   #14
tuubaaku
Member
 
Registered: Oct 2004
Distribution: Slackware, Mint
Posts: 122

Rep: Reputation: 16
If anyone sees this post and wants to know the solution for me, there's a problem with the modules that are loaded for wireless on the EeePC. I had to add "blacklist rt2800pci" to /etc/modprobe.d/blacklist.conf, and now it's fine. Search for RT2860 in Slackware 13.1 for more details.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
'netconfig' in Slackware 9.0 rockpc Linux - Newbie 2 11-30-2004 04:00 PM
netconfig problems in Slackware destroygbiv Linux - Newbie 5 02-16-2004 05:28 AM
Slackware netconfig.... augamecock Linux - Networking 3 03-20-2002 06:45 AM
Slackware 8 - no ifconfig or netconfig indy_bob Linux - Software 8 02-20-2002 02:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration