-   Slackware (
-   -   Slackware 13.1 HandbrakeCLI build error (

the_zone 12-27-2012 02:51 PM

[Solved] Slackware 13.1 HandbrakeCLI build error
I have downloaded Hanndbrake and its deps from slackbuids.

During the build process i get :

/tmp/SBo/HandBrake-0.9.4/build/contrib/ffmpeg/ffmpeg-r19067/libavcodec/vaapi.c:106: undefined reference to `vaCreateBuffer'
collect2: ld returned 1 exit status
make: *** [HandBrakeCLI] Error 1

I have no clue what this could be.



glorsplitz 12-27-2012 09:11 PM

Hi, I have HandbrakeCLI working ok, not sure when I got libavcodec but looks like it was part of alienbob vlc package.

Maybe get vlc installed and try ALL the HandbrakeCLI slackbuild again?

kite 12-27-2012 09:23 PM

As handbrake is normally built with static libraries self-contained, you may just try to download any built handbrake binary for your arch (x86 or x86_64). Last time I downloaded one handbrake rpm for fedora and did the rpm2tgz, which works fine under slackware. It is faster than digging what is wrong.

the_zone 01-06-2013 05:05 AM

Hopefully I have solved it.
Altough I have tried a different route.

1st I installed VLC with all its dependencies. No luck.
Next i tried by using alienbob's 13.37 slackbuild package on my 13.1 install.
The package installed OK.

Next thing is to resolve the HandbrakeCLI warnings/errors but that is a whole diffrent thread ;)



All times are GMT -5. The time now is 03:44 AM.