-   Slackware (
-   -   Slackware 13.1 first batch of updates - print crash on firefox and thunderbird (

sljunkie 06-28-2010 02:35 PM

Slackware 13.1 first batch of updates - print crash on firefox and thunderbird
Well, that's about it - the firefox and thunderbird packages included on the first batch of official 13.1 updates keep crashing when I try to print a web page or an e-mail. Seamonkey, updated as well, can print as usual.

Any thoughts?

rweaver 06-28-2010 02:38 PM

start a session from the console and then see if any errors get displayed, check your logs and see if they're providing additional details.

sljunkie 06-28-2010 03:03 PM

No error output on console.

Here's the crash report, I tried to print the default start page:

Add-ons: {972ce4c6-7e08-4474-a285-3208198ce6fd}:3.6.6
BuildID: 20100625222733
CrashTime: 1277755222
EMCheckCompatibility: true
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1277752415
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 1022
StartupTime: 1277755215
Theme: classic/1.0
Throttleable: 1
Vendor: Mozilla
Version: 3.6.6

rpedrica 06-28-2010 03:11 PM

Same here except it seems it's any mozilla apps including Seamonkey ...

Started from the console I get the following error when printing:

bash-4.1$ seamonkey
/usr/lib64/seamonkey-2.0.5/ line 131: 4782 Segmentation fault "$prog" ${1+"$@"}

Have removed all plugins and disabled most of my extensions but no go ...

sljunkie 06-29-2010 10:30 AM

And for the worst part, when I tried to downgrade firefox, thunderbird, and seamonkey (ie, reinstalling the packages on the DVD) the problem persists! How come...?


mlangdn 06-29-2010 10:41 AM

I just printed a web page and an email without incident. Did you upgrade both cups and ghostscript as well?

sljunkie 06-29-2010 10:53 AM


Yes, I did upgrade cups and ghostscript, and I can print from within seamonkey. Ah, I'm on a 32-bit machine.

gapan 06-29-2010 11:07 AM

Same problem here on a 64-bit system.

edit: Tried the latest nightly binary distributed from, that one crashes on printing too.

samac 06-29-2010 01:06 PM

Prints OK from both on Slackware64-13.1 (multi-lib).


sljunkie 06-29-2010 03:39 PM

I think I found the problem - I had gnome-vfs 2.24.3 installed, removed it and the printing issues were over.

Does anybody else who's had this problem has a gnome-vfs installed too?

gapan 06-29-2010 03:50 PM

You're right, I had gnome-vfs 2.24.2 installed and after removing it, it works.

rpedrica 06-29-2010 04:41 PM

Wow sljunkie, worked for me too - how'd you find that out?

sljunkie 06-29-2010 08:46 PM

Hey rpedrica,

I created a new account to test how firefox would behave, and the console complained something about ~/.gnome and gnome-vfs... that was the clue I needed ;)

I believe that the real problem is that firefox and thunderbird are distributed as static binaries.

lynnwood 06-29-2010 09:17 PM

This problem does not exist on my Slackware 13.0 box with FF 3.6.6 and gnome-vfs-2.24.1.

/hoping to get a patch to apply to my slack 13.1 system soon

gapan 06-30-2010 02:24 AM

No problem in my 13.0 installation with gnome-vfs 2.24.1 either. It's only a problem with 13.1 for some reason.

All times are GMT -5. The time now is 03:30 AM.