LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-23-2010, 06:15 PM   #1
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Rep: Reputation: 228Reputation: 228Reputation: 228
Slackware 13.1 Ė Bluetooth problem


I canít configure Bluetooth in Slackware 13.1. It basically works. I can scan my mobile phone:

Code:
$ hcitool scan
Scanning ...
        BA:BE:DE:AD:AB:ED       Nokia 6300
But when I try other commands, mobile phone asks me about passcode. Because I donít know it pairing fails:

Code:
$ gammu 6300 --identify
Error opening device. Unknown, busy or no permissions.
On the other hand when I try to pair computer using mobile phone it doesnít find any device.

Code:
Pair new device
Searching for devices
No devices found
In Slackware 13.0 to configure Bluetooth it was enough to edit /etc/bluetooth/hcid.conf file. In Slackware 13.1 there is no such file. I tried to use blueman but it offers first and foremost a lot of error messages. In despair I even started KDE and tried Bluetooth Manager. It attempts to run for a dozen or so of second and finally fails.

I searched Internet for the solution of my problem. Because I didnít find any question concerning Slackware 13.1 and Bluetooth I assume nobody has problems with it. Iím pretty sure the solution is simple and Iím the only one who canít figure it out.

I did full installation of Slackware 13.1 and I use generic SMP kernel.

Any help will be greatly appreciated.
 
Old 06-23-2010, 08:52 PM   #2
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 111Reputation: 111
Check out the blueman tools installed. Particularly, bluman-applet will sit in your system tray and allow you to do various things as pairing. The default passcode on all bluetooth devices is 0000. Additionally, I think phones can set the passcode somewhere in its settings.

Unfortunately, that's the extent of my bluetooth experience. I've only attempted and successfully connected a mouse.
 
Old 06-24-2010, 09:31 AM   #3
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Original Poster
Rep: Reputation: 228Reputation: 228Reputation: 228
I tried blueman tools from within KDE – without success. When I click Bluetooth icon it trays to start Blueman Manager but fails. Such options as: Setup new device, Send files to device, Browse files on device and Devices display bouncing icons and stop. Recent Connections displays empty narrow square submenu. Adapters displays window with Close button only. Local Services, Plugins and About display appropriate windows.

Blueman run from within KDE works in my case similarly to blueman run from command line.

Passcode 0000 doesn’t work in my case as well as passcodes: 1234, 4321 and 9999.

So my problem persists.
 
Old 06-24-2010, 01:36 PM   #4
jannekrille
Member
 
Registered: Jul 2005
Location: Dalsland, Sweden
Distribution: Slackware 13.0 and 13.1
Posts: 75

Rep: Reputation: 22
Is /etc/rc.d/rc.bluetooth set as executable? That's all I had to do to get it working.

Jan C.
 
Old 06-24-2010, 02:06 PM   #5
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Original Poster
Rep: Reputation: 228Reputation: 228Reputation: 228
The script /etc/rc.d/rc.bluetooth has of course set executable mode bit. As I wrote above hcitool recognizes my mobile phone and gammu identifies it. Unfortunately I can't replay with valid passcode nor pair computer with the phone: my mobile doesn't see the computer and I can't guess the passcode.

I even copied /etc/bluetooth/hcid.conf from Slackware 13.0 to 13.1 and restarted /etc/rc.d/rc.bluetooth but the results were exactly the same as before.
 
Old 06-24-2010, 03:14 PM   #6
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 111Reputation: 111
OK I played with connecting to a Nokia 6255i Alltel Device.

First I ensured bluetooth was toggled on from the device.
Menu > Connectivity > Bluetooth > Bluetooth ON

Then I ran blueman-manager (which is what's auto run by clicking the system tray icon for blueman-applet)
Clicked on SEARCH
Right clicked the device and selected ADD DEVICE
THEN I clicked PAIR at the top or from the right click menu

At this point a dialog will prompt you for a pass code on both the device and on the computer. Any passcode works as long as they are the same on both. In my case, when I attempted to click Pair before clicking Add Device the connection would fail. I also never received a prompt on the phone to enter a pass code.

At this point I could browse the device and send files but the serial ports "COM1" and "Nokia PC Suite" did not function. I didn't attempt dialup networking as the phone has no service.

How you do this from command line I don't know. But when I was using the command line, most of the connection tools required root privileges. That's why I use blueman. The connections should persist if you close the blueman applications. There may be a command line tool that you use to first "add" the device and then pair with it.


Every action with the phone required me to click the "Accept" soft key on the phone it self. There may be more settings to set your computer as trusted.

... If you do a huge file transfer, don't do anything else like browse the directory structure. For me, all other actions froze until the file transfer was complete.

Last edited by lumak; 06-24-2010 at 03:26 PM.
 
Old 06-24-2010, 07:00 PM   #7
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Original Poster
Rep: Reputation: 228Reputation: 228Reputation: 228
Finally I found the cause of my Bluetooth problems. As I supposed a solution was simple. It was enough to run blueman-manager as root. Before I started it as a regular user. During configuration of the system one of my scripts should register my user in the plugdev group. For some reason it failed. In result my user hadn’t enough rights to run blueman-manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 13 bluetooth PAN 0rphu Slackware 1 10-03-2009 10:08 AM
Using USB bluetooth with slackware 12.0 vitalstrike82 Slackware 8 06-18-2009 11:27 AM
Slackware 12.0 and Bluetooth perry Slackware 2 08-07-2007 04:21 PM
Bluetooth in Slackware HOWTO drkstr Slackware 6 06-15-2006 04:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration