LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-25-2010, 10:10 PM   #1
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Rep: Reputation: 15
slackware 13.0 + sata disk installation problem


good day to all slackers!

i have a problem installing slackware 13.0 using my new sata hardisk...
the DVD installer cant boot using hugesmp.s, i tried also booting
hugesmp.s root=/dev/sda1 rdinit=ro but no luck.


i know that the cause of this problem was my new hardisk because when i use an IDE hardisk i can install slack with no problem.


I need help regarding this slack problem.. thanks...

Last edited by belkens; 06-25-2010 at 10:15 PM.
 
Old 06-25-2010, 10:16 PM   #2
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
Edit the boot option. Put in:
Quote:
pci=nomsi
and try that. I have the same issue with my board, otherwise it won't recognize the drive.
 
Old 06-25-2010, 10:25 PM   #3
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
how can i use the pci=nomsi?

is this right? hugesmp.s pci=nomsi
 
Old 06-25-2010, 10:27 PM   #4
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
When the boot loader comes up, it should give you an option to edit the bootline. I think in 13.x you have to hit tab to see it, I could be wrong. But yes essentially you want to pass "pci=nomsi" to the kernel before booting.
 
Old 06-25-2010, 10:34 PM   #5
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
boot:
only that prompt will appear when i press tab nothing happens...
 
Old 06-25-2010, 10:36 PM   #6
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
Ok in that case it is asking for the kernel name. You'll need to either do
Quote:
hugesmp.s pci=nomsi
or
Quote:
Linux pci=nomsi
My guess is the first.
 
Old 06-25-2010, 10:40 PM   #7
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
i tried hugesmp.s pci=nomsi but still no luck..
 
Old 06-25-2010, 10:48 PM   #8
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
Ok well when I had the problem I used "hugesmp.s pci=nomsi pci=nopcmcia"

However, I'm not entirely sure if you're having the same issue as I did. Do you see any errors or anything? Does it come up saying something about not finding a harddisk?
 
Old 06-25-2010, 10:54 PM   #9
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
here's my problem..
when i use hugesmp.s root=/dev/sda1 rdinit=ro it will continue to boot but
at the end it will say:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)

Last edited by belkens; 06-25-2010 at 10:57 PM.
 
Old 06-25-2010, 11:13 PM   #10
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
Hmm ok. Take out the root=/dev/sda1 and rdinit=ro for now and try the other two I mentioned. When you're pointing out root if its not on your CD drive, you're telling it to boot a different system with the kernel on the CD. So, try to just do: hugesmp.s pci=nopcmcia pci=nomsi
 
Old 06-25-2010, 11:22 PM   #11
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
thanks for the reply
but still no luck..
 
Old 06-25-2010, 11:44 PM   #12
Onoir
LQ Newbie
 
Registered: May 2010
Posts: 24

Rep: Reputation: 15
Is your harddisk new? And did you check the md5 for the iso you burned?
 
Old 06-26-2010, 12:04 AM   #13
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
I would check the bios settings. I have to set my bios for AHCI or there's no joy in Slacktown.
 
Old 06-28-2010, 03:13 AM   #14
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,273
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by belkens View Post
here's my problem..
when i use hugesmp.s root=/dev/sda1 rdinit=ro it will continue to boot but
at the end it will say:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
It seems like your root partition is not /dev/sda1. Try to run CD-ROM
Check hard disk

Code:
fdisk /dev/sda
next - after fdisk will start

Code:
Command (m for help): p
this should show all your partitions on /dev/sda

If you'll find the output as it should be, quit from fdisk with 'q' command and try manually
mount /dev/sda1 eg. on /mnt directory

Code:
mount -t auto /dev/sda1 /mnt
If this command won't work probably it means that the file system on
/dev/sda1 may be corrupted. This sometimes may be fixed with fsck command(s).

If you are able to mount /dev/sda1 and it the root partition look at fstab
file

cat /etc/fstab

you should find '/dev/sda1 /'

Finally, look at lilo.conf (if you are using LILO as a bootloader, I don't)

Last edited by igadoter; 06-28-2010 at 03:50 AM. Reason: I forget to add
 
Old 06-28-2010, 11:20 PM   #15
belkens
Member
 
Registered: Dec 2003
Location: Philippines
Distribution: Slackware 10.0
Posts: 46

Original Poster
Rep: Reputation: 15
thanks for the reply..

but my problem is that i cannot proceed to the # prompt to issue fdisk
i am stuck with the boot: prompt..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Installation on SATA Hard Disk atulrn Linux - Hardware 23 10-04-2007 05:59 AM
Sata hard disk installation problem tkmsr Linux - Hardware 2 03-16-2007 04:34 PM
New Hard Disk (SATA) Installation shaileshjain Linux - Hardware 1 01-29-2007 08:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration