-   Slackware (
-   -   Slackware 13.0 and kmail annoyances (

dimm0k 10-26-2009 04:48 PM

Slackware 13.0 and kmail annoyances
Is anyone having issues with setting fonts in kmail that comes with Slackware 13.0? No matter what I set in kmail for the message list or anything for that matter, it never changes! Even keeping the same font but changing the size does nothing!

The other issue is that now it no longer shows you how many total messages there are in a folder in kmail... am I missing something?

I've upgraded to Slackware 13 and have moved .kde and .kderc out of the way...

cwizardone 10-27-2009 10:37 AM

1 Attachment(s)
Just above the message list box, on the right side, are 4 or 5 small icons. Please see attachment. You can use those to change the way KMail displays the mail list.
KMail in KDE 4.xx is yet another example of a KDE 4.xx application that is not as functional as its KDE 3.5.x predecessor. From what I've read on the KDE Forum it might be KDE 4.4 or later before the problems with KMail are straightened out.
IMHO, KMail is, i.e., was, the best e-mail client available, but for now I'm using Opera Mail until KMail gets "repaired."

dimm0k 10-28-2009 12:30 AM

Yes, I feel the same way in regards to KDE 4.xx and 3.5.x when it comes to a lot of the settings... unfortunately what you have described to alter the display of the mail list does not do what I'm looking for. I'm referring more to the folder list on the left said showing some sort of notification on the total number of messages in each folder, something I remember KMail in 3.5.x doing...

cwizardone 10-28-2009 12:52 PM

On the left size at the top of column labelled "Folder" (not "Favorite Folders") right click on the "bar" contains the word "Folder" and a menu should drop down. Under "View Columns," place a check mark next to each item you want to appear, e.g., "unread."
This was discovered by looking at the options available after clicking on the last of the previously mentioned icons on the right.
So, there you go...

dimm0k 10-29-2009 01:22 AM

Sweet! Thanks cwizardone, I don't know why I never bothered to even try right clicking on that "bar"! Now if we could do something about font size in KMail...

cwizardone 10-29-2009 01:54 AM

Settings, Configure KMail, Appearance, and then put a check in 'Custom fonts,' pick "composer," "folder size," etc., then change the size, and click on "Apply," then "OK."
I just did it and it worked.

dimm0k 10-30-2009 12:39 AM

cwizardone, thanks again! I don't know what was going on, but when I did those same exact steps they didn't work... now they do, however for the Message List the font selections do not work... The message body and folder list worked nicely however. Does Message List work for you?

cwizardone 10-30-2009 01:49 AM


Originally Posted by dimm0k (Post 3737509)
...Does Message List work for you?

No it does not, so you're not alone. :)
I tried changing the font and the size of the font for the message list and neither worked. I know it worked in the earlier KDE 3.5.x versions, but not, so far, in KDE 4.xx.
Each passing day seems to confirm changing to Xfce was the right move. :)

dimm0k 10-31-2009 12:11 AM

*sigh* I was hoping you had good news, but I guess KMail's fscked in that regard. Thanks again though!

cwizardone 11-01-2009 11:32 AM


Originally Posted by dimm0k (Post 3738757)
*sigh* I was hoping you had good news, but I guess KMail's fscked in that regard. Thanks again though!

I've found changing the font or font size for the message list does work.
The trick is to completely close KMail after you have made and saved your change, and then restart it.

All times are GMT -5. The time now is 10:37 PM.