-   Slackware (
-   -   Slackware 12 in VMware Workstation 6 Issues (

ChaoticEuphoria 09-20-2007 09:59 AM

Slackware 12 in VMware Workstation 6 Issues

I have been a long time reader of the forum but this is my first posting.

I have been quad booting for quite some time and after a while it gets annoying. So I was trying to install Slackware 12 in VMware Workstation 6. The install was successful as was the installation of VMware Tools.

I ran in to problems, however, when I tried to compile my own custom kernel. I have done this many, many time in the past with success. The only difference was this is a VM and before it was my actual laptop.

I looked over all the loaded modules, which ones were being used, as well as what pci hardware was detected. Based off that I went through and gave my best shot for the kernel.

So the first error upon rebooting was


"The CPU has been disabled by the guest operating system. You will need to power off or reset the virtual machine at this point."
Through searching I found that this was caused by SpeedStepping in my guest OS. Disabling that fixed the issue.

Now the other issue that I keep receiving, which I can't fix through about 8 different tries with the kernel is:


... Please append a correct "root=" boot option
> Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (8,2)
I found a good deal of threads on this as well, although they are all related to reiserfs support not being in the kernel or compiled as a module. I use ext3 across the boards and have that and ext2 support built into the kernel.

I also made sure scsi/sata support was included as well. I verified my /etc/fstab and lilo conf lists my devices as "sd*" rather than "hd*" since I am using scsi/sata. I'm lost.

Has anyone successfully installed Slack in VMware and upgraded their kernel as well? Perhaps I am missing some hardware drivers in the kernel that are important ...

My host OS is Windows XP and my kernel version is 2.6.22

Any help is appreciated.


ghostdancer 09-20-2007 10:28 AM

What type of Linux you choose? For me I always choose "Other Linux" (Since no option for "Slackware"). I make sure the disk controller is BusLogic BT-946C (a scsi controller).


$> lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 01)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 01)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 08)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0f.0 VGA compatible controller: VMware Inc [VMware SVGA II] PCI Display Adapter
00:10.0 SCSI storage controller: BusLogic BT-946C (BA80C30) [MultiMaster 10] (rev 01)
00:11.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 10)

Did you keep your previous kernel? If you had, you should boot it back and the devices again.

ChaoticEuphoria 09-20-2007 10:33 AM

I did choose other, and then the kernel 2.6 option. And yes I did keep my old kernel which is how I keep booting to retry the kernel complilation.

I used LSI Logic for the scsi controller. Is there a difference between the two. I did include both Bus and LSI logic support in the kernel under the scsi options.

Your output is exactly what my lspci shows except I am using the Intel 100/1000 NIC (e1000)

ghostdancer 09-20-2007 10:46 AM

If that is the case, then you should not be using LSI Logic for SCSI controller. Since we are using the same PCI list, you can take my .config file a try: -> FYI, this is for kernel

ChaoticEuphoria 09-21-2007 09:40 AM


I'm going to recreate my VM using Bus Logic or just normal IDE and see if that fixes it.

All times are GMT -5. The time now is 04:34 PM.