LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-20-2009, 06:55 PM   #16
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23

Look at the following file which you should have on your Slackware installation:

/usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt

Go to the section for snd-hda-intel. There will be a list of all the model options you can try. Notice that "model=auto" is an option and who knows, it might work.
 
Old 01-20-2009, 06:56 PM   #17
replay019
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Wait I found an error

Code:
$ dmesg | grep model
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
according to "alsamixer"

Chip: Realtek ALC268

maybe thats the problem, but I don't know what it means by auto-probe?
 
Old 01-20-2009, 07:06 PM   #18
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Quote:
Originally Posted by replay019 View Post
according to "alsamixer"

Chip: Realtek ALC268
I don't know if that message means the driver was expecting an ALC268 and didn't find one, or that it positively identified your codec as ALC268.

In any case, ALC268 is listed in the ALSA_Configuration file. These are the model options:

Code:
	ALC267/268
	  quanta-il1	Quanta IL1 mini-notebook
	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
			$CONFIG_SND_DEBUG=y
	  auto		auto-config reading BIOS (default)
 
Old 01-20-2009, 08:07 PM   #19
replay019
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
I rebooted several times times experimenting with,

options snd-hda-intel index=0 model=auto
options snd-hda-intel index=1 model=auto
options snd-hda-intel index=2 model=auto

an index # above 0 Linux doesn't see my card. Although when I tried to play something on 'xmms' with 'index=0 model=auto' and I get this error
at the end..

Code:
$ dmesg
hda-intel: Invalid position buffer, using LPIB read method instead.
No idea wat LPIB means..
 
Old 01-20-2009, 08:20 PM   #20
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Quote:
Originally Posted by replay019 View Post
I rebooted several times times experimenting with,

options snd-hda-intel index=0 model=auto
options snd-hda-intel index=1 model=auto
options snd-hda-intel index=2 model=auto
Leave out the index option (since you have only one audio device). Try the other ALC268 related models

model=toshiba
model=dell
model=3stack

etc

What model computer/motherboard are you running with?
 
Old 01-20-2009, 08:40 PM   #21
replay019
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
I'm running HP Pavilion tx2510us Entertainment Notebook PC

I'll try out the other models.
 
Old 01-20-2009, 08:49 PM   #22
replay019
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
HA!! =D It worked
I tried out model=zepto and the sound works

THANKS ALOT!! even the headphones works! xD
 
Old 01-20-2009, 09:05 PM   #23
DavidHindman
Member
 
Registered: Dec 2008
Distribution: Slack 13 + JWM
Posts: 101

Rep: Reputation: 23
Quote:
Originally Posted by replay019 View Post
HA!! =D It worked
I tried out model=zepto and the sound works

THANKS ALOT!! even the headphones works! xD
Ah yes, the old zepto fix, how could we have possibly missed that.

One more thing. Add "position_fix=1" after the "model=zepto" option to eliminate the LPIB warning message. The LPIB thing is just a notification, not an error, apparently it means a change in buffering method was required somewhere within the audio driver.

Last edited by DavidHindman; 01-20-2009 at 09:06 PM.
 
Old 01-20-2009, 09:11 PM   #24
replay019
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Done thanks for all your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problem with Slackware 11.0 theweehours Slackware 3 10-11-2006 11:00 PM
Slackware sound problem, HELP! fiddle Slackware 4 08-08-2005 03:06 PM
Slackware 10 Sound Problem Jeffmrg Slackware 12 08-09-2004 06:07 AM
Sound problem Slackware 10 arubin Slackware 3 07-01-2004 08:54 AM
Slackware 9 sound problem wildtiger23 Linux - Hardware 2 03-27-2003 12:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration