-   Slackware (
-   -   Slackware 12.2 + RAID-5 + LVM => Read-write issues during boot (

v3gard 07-24-2009 03:50 AM

[SOLVED] Slackware 12.2 + RAID-5 + LVM => Read-write issues during boot
I have 5 1.5TB SATA drives, and out of those I'm going to use 4 for a RAID-5 array (with LVM2) and keep 1 for backup in case any of the other disks should get f*cked up in any way.

Currently, I have installed three of the four disks I will be using. The reason for this, is because I want to learn how to expand a RAID5-array and LVM-volume.

Using the guides located at and, I was able to create 3 RAID-pools (in software) and installing LVM on top of the pool that was configured with RAID-5.

/dev/md0 -> LVM2 (raid-5)
/dev/md1 -> swap (raid-1)
/dev/md2 -> /boot (raid-1)

/dev/lvm-raid/lvm0 -> /
/dev/lvm-raid/lvm1 -> /home
/dev/lvm-raid/lvm2 -> /mnt/shared

I have now gotten to the point where I'm able to initialize the raid-array and locating the volume groups during boot time.. The problem that has been pestering me for the last three hours, is being able to mount with read-write privileges.

When Slackware (12.2) is booting, I keep getting the error message from /etc/rc.d/rc.S (on line 186 and forward) stating the following: "attempt to remount root device as read-write failed! This is going to cause serious problems". According to this error-message, there should be nothing wrong with the /boot partition, since the initrd loads without problems, and the LVM volume group is mounted (however in read-only mode).

I really don't understand this part, because I am able to boot from the Slackware CD and mount my volumes manually (using mdadm first, followed by vgscan and vgchange, and then mount) without any hassle. Creating and deleting files on the LVM volume groups works like a charm.

If it is of any help, I'm using the ext3 file system on all the volume groups including /dev/md2 where /boot is located. I've also included my lilo.conf and mkinitrd.conf below.

from lilo.conf

append = "vt.default_utf8=1"
boot = /dev/md2
raid-extra-boot = "/dev/sda /dev/sdb /dev/sdc"

image = /boot/vmlinuz-generic-smp-
initrd = /boot/initrd.gz
root = /dev/lvm-raid/lvm0
label = Slackware

from mkinitrd.conf


I appreciate all the input you can give me :)

v3gard 07-26-2009 02:39 PM

Okey, I've now made some minor changes to mkinitrd.conf to see if that would fix the errors, but it seems like I'm out of luck.



Is there some module that's required during the boot sequence that I have forgotten to load? I just don't understand why I am able to mount the partitions manually with the Slackware CD, and not automatically when Slackware has been installed.

Since I am able to boot the kernel, which resides on /dev/md2, can I safely eliminate LILO from the list of possible problems?

By the way, here are the messages I keep getting when I'm booting the system:


Initializing LVM (Logical Volume Manager):
  Reading all physical volumes: This may take a while...
  Found volume group "lvm-raid" using metadata type lvm2
  3 logical volume(s) in volume group "lvm-raid" now active
Adding 979832k swap on /dev/md1. Priority:-1 extents:1 across:979832k
Loading fuse modulesfuse init (API version 7.9)
Mounting fuse control filesystem
Setting system time from the hardware clock (localtime).
Testing root filesystem status:  read-only filesystem
Checking root filesystem:
fsck 1.41.3 (12-Oct-2008)
fsck: fsck.defaults: not found
/sbin/fsck: Error 2 while executing fsck.defaults for /dev/lvm-raid/lvm0
Remounting root device with read-write enabled.
EXT3-fs: Unrecognized mount option "1" or missing value
mount: / not mounted already, or bad option

Attempt to remount root device as read-write failed! This is going to
cause serious problems. [....]

v3gard 07-26-2009 03:27 PM

Well, this is quite embarrassing..

I had forgotten to specify which filesystem the volumes were using in /etc/fstab. Adding ext3 to each of the volumes fixed the problem during boot :)

GazL 07-26-2009 03:41 PM

edit: deleted.
Never mind, I see you've already spotted it.

Glad you got it sorted. :)

All times are GMT -5. The time now is 12:19 AM.