-   Slackware (
-   -   Slackware 12.2 ATI 4850 and Catalyst (

loboo 04-16-2009 01:54 AM

Slackware 12.2 ATI 4850 and Catalyst
Slackers do you read me?
Hi there i just want a little help installing drivers for my ATI Sapphire 4850.I tried to download and install the latest Catalyst but the only thing i managed was to make it impossible to startx :P

So i would like someone more experienced than me to help me install the drivers from scratch.If the latest catalyst does not support SlackWare let me know which one i need and how to install it.

Thank you

amiga32 04-16-2009 02:33 AM

lol we are all having problems with ATi drivers Dx

First make sure you rebuild your kernel with MSI support under bus options if you are using 9.x cats. Secondly many people are having problems with 9.3 cats so try 9.2 if they do not work for you or wait for 9.4. Alternately try installing the 8.12 drivers if you do not wish to rebuild your kernel.

Z038 04-29-2009 08:48 PM

I have an ASUS EAH 4850 TOP card. It has the 4850 chip. I tried Catalyst 9.4 and at first could only manage to get the "white screen of death". When you enter startx, the screen clears, goes totally white except for the last couple of lines, and hangs your system. The reset button is the only way out.

Then I recompiled my kernel with the PCI MSI support, and I no longer get the white screen of death. But no matter what I set my horisync and vertisync values to, I get "out of range" error from my monitor when I startx.

Anyone have any ideas? I'm considering buying an old cheap card just so I can get some kind of graphics working again on this system I'm upgrading.

OK2BCK 05-16-2009 08:09 AM

This won't work?

is this slackware no-go?

I am running linux 3rd day in my life and totally love it. Is there tutorial how to rebuild slack to take ati drivers? I'm learning fast.
I MUST get rid of this 1027x768 resolution, it drives me mad!
running radeon HD3850 512MB AGP and 3GB RAM, this is not as good as it gets, right? :)

forum1793 05-16-2009 10:03 AM

Cat 9.4 doesn't autoinstall with 2.6.29 kernel without patching which I haven't tried. If you're running -current and upgraded to the 2.6.29 kernel, download a 2.6.28 or .27 and configure with the msi stuff discussed before. I'm using but was also having no real problems (video card related) with the 2.6.25 kernels. This was for integrated hd3200. Your situation may be different.

If you have to use 2.6.29 kernels (for hardware reasons), try rebuilding kernel as discussed (don't overwrite /usr/scr or /usr/include distribution kernel headers etc). Try patching or try the radeonhd git or I think they are starting to get some 3d acceleration with the ati git and read the experimental part. This is not overly easy for the inexperienced (which mostly includes me). I've got it working, to the extent it works, but there is no 3d acceleration yet for the hd3200. Not sure with your chips.

By the way, I've hobbled together some slackbuild scripts for these (ati, drm, mesa...) and could provide these if desired. They seemed to work for me but I make no promises as I really am not very smart on this stuff.

hemp4fuel 05-16-2009 10:18 AM

You can run 8-12 on the 2.6.28 kernels without recompiling, it seems to be a superior driver as well.

OK2BCK 05-16-2009 11:18 PM


Originally Posted by hemp4fuel (Post 3542834)
You can run 8-12 on the 2.6.28 kernels without recompiling, it seems to be a superior driver as well.

I have tried it and it works just perfect. The only problem seem to be when dragging windows around my desktop - sometime it takes a while for background windows to re-render. But, geeez, this thing doesn't have IE!
I love it!

Z038 05-17-2009 12:00 AM

I'm running, and Catalyst 8.12 doesn't work. And yes, I recompiled the kernel to include the PCI MSI support. I tried Catalyst 8.11 through 9.4, and none of them work for me. I gave up for now. I'm running radeonhd with my 4850 card, and it works fine for everything I need to do.

forum1793 05-17-2009 10:35 AM

What error messages are you seeing in /var/log/Xorg.0.log? cat /var/log/Xorg.0.log | grep EE

When you ran the ATI installer, did you get any error messages? Look at last ten or so lines in /usr/share/ati/fglrx-install.log. If it worked there should be "build succeeded with return value 0". If it doesn't succeed there should be error message of some sort.

Did it produce a fglrx.ko file in /lib/modules/<your>/kernel/drivers/char/drm? Note that every time you produce a kernel you have to either rerun the ati installer or go to /lib/modules/fglrx and sh ./ Sometimes you first have to drop one more directory "build_mod" and sh ./

Is fglrx loaded? lsmod | grep fg

If it loaded OK:
1. Ensure other modules aren't loaded. I think these include drm.
lsmod | grep drm
lsmod | grep agp
lsmod | grep radeon
same with dmesg, dmesg | grep drm (in case you compiled these i the kernel)

I seem to remember that fglrx does not work if drm is loaded. You probably shouldn't have any radeon.ko, radeonhd.ko, or framebuffers either. If in the /lib area, back them up and then delete and try it. I've verified in the past that agpgart can either be loaded or not. It doesn't matter and fglrx has its own.

2. Review your /etc/X11/xorg.conf. Here is the relevant parts of mine ( I don't claim it's perfect, ideal, or eve optimized). You can see I don't have anything for horizontal or vertical hz. fglrx (edid) or something finds this itself. Also note I don't have any modelines in the "Screen" section, same reason. You might try this and then read up on your potential options for your hardware (like textured video). You should also web-search your hardware at phoronix to see if the drivers simply aren't ready yet for your hardware. Good luck.


Section "ServerLayout"
        Identifier    "Simple Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"

Section "Files"
#    ModulePath "/usr/lib/xorg/modules"
        RgbPath      "/usr/share/X11/rgb"
<fonts stuff removed to reduce this postings size>

Section "Module"
# Note: dbe, type1, freetype, glx, and dri are loaded per default
        SubSection "extmod"
                Option            "omit xfree86-dga" 

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option            "Protocol" "Auto"
        Option      "ZAxisMapping" "4 5"
        Option            "Device" "/dev/mouse"

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]"
        Option            "DPMS" "true"

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option "VideoOverlay" "off"
        Option "OpenGLOverlay" "off"
        Option "TexturedVideo" "on"

# next three from phoronix person not sure if they work
        Option            "XAANoOffscreenPixmaps" "on"

# xorg.log shows next two don't work
#        Option            "AccelMethod" "EXA"
#        Option            "ExaNoComposite" "false"

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device    "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24

forum1793 05-17-2009 11:30 AM

Note at least one bug for this board. Something about locking up on dual head. Some mention of turning "textured video" off in the xorg.conf, whereas I show it on in my xorg.conf example.

My hd3200 runs faster having textured video on but for the 4850 I don't know.

kpworrell 06-25-2009 07:04 PM

Hey guys ...

This link might help you out re: installing the proprietary ATI driver in Slackware

All times are GMT -5. The time now is 01:49 AM.