LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-14-2009, 04:55 PM   #1
dumdadum
Member
 
Registered: May 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 14.1 64 bits
Posts: 238

Rep: Reputation: 15
Exclamation Slackware 12.2 and audacity


Hello,

I'm trying to install Audacity on Slackware 12.2. Went to slacbuilds.org to find that. Thing is, when I run the SlackBuild file, I get an error. First error for something about wxwidgets. So went and found that. Now I get another error. This is the one :

configure: error: Audacity requires expat to be enabled

What is this? How do you fix this?

Thanks
 
Old 07-14-2009, 05:08 PM   #2
bugman5
LQ Newbie
 
Registered: Jul 2009
Location: nowhere
Distribution: debian
Posts: 10

Rep: Reputation: 0
i googled 'slackware expat' and it appears to be on the slack install disk, in the l [for 'library']folder, take a look...
 
Old 08-06-2009, 07:01 AM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Hi people,

Is there any more information on this error and how to correct it. FYI, I have expat installed, and the libs are in /usr/lib as would be expected, but the build still returns with the error shown above, so any additional help will be appreciated.

TIA
 
Old 08-06-2009, 08:19 AM   #4
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 698

Rep: Reputation: 110Reputation: 110
Googled a bit around:
Code:
+if test "$LIBEXPAT_USE_LOCAL" != "yes" && test "$LIBEXPAT_USE_SYSTEM" != "yes"
; then
+ AC_MSG_ERROR([Audacity requires expat to be enabled])
+else
+ if test "$LIBEXPAT_USE_SYSTEM" = "yes" ; then
+ AC_DEFINE(USE_SYSTEM_EXPAT, 1, [Use system Expat library])
+ fi
+fi
+
if test "$LIBRESAMPLE_USE_LOCAL" = "yes" || test "$LIBRESAMPLE_USE_SYSTEM" =
"yes" ; then
LIBSAMPLERATE_USE_LOCAL="no"
LIBSAMPLERATE_USE_SYSTEM="no"
It seems there are two choices, of which you must use one; --expat=local or --expat=system
Since you have expat installed, I'd go with --expat=system
 
Old 08-06-2009, 08:39 AM   #5
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Except, of course the test for expat is obviously failing as it doesn't find the locally installed expat libs. Even using ./configure --with-expat local.
Any more suggestions?
 
Old 08-06-2009, 08:43 AM   #6
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 698

Rep: Reputation: 110Reputation: 110
I don't have a try-out location here, but my guess is that --with-expat should come with an "=" between "local" or "system". The error is not that the configure script cannot find the library, but that it does not seem to be enabled as in --with-expat=[local|system]

try and see what the options exactly are with ./configure --help
 
Old 08-06-2009, 10:26 AM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
OK, done that. Used ./configure --with-expat=local/system/y/n/and any other combination it could possible be.
./configure --help specifies not to use the equals sign, so I have tried that as well. Googleing suggests that there should be an expat.pc file in /usr/lib/pkgconfig, but there isn't, so I have created one. Guess what, still the same. There are 2 versions available. One expects that you have all of the support libs installed (which I have), whilst the other has all the support libs included, so off I go to download the larger version, 17+Mbs as opposed to just over 10Mb. I will let you know what happens
 
Old 08-06-2009, 11:09 AM   #8
Mol_Bolom
Member
 
Registered: Nov 2008
Location: S.W. Kansas
Distribution: Slackware64 14.0 / 14.2
Posts: 245
Blog Entries: 2

Rep: Reputation: 41
I tried to find out what might be wrong myself, since I installed it twice on two separate machines with 12.2 and didn't have any problems.

I have a bit of time and still have the packages I used to install it from slackbuilds. So if you tell me which wxwidgets you installed I'll uninstall and attempt it myself and see if I can't find the problem.

However, just to make sure, these are the steps I took when installing Audacity. wxGTK then libsndfile then audacity. All from slackbuilds.org.
 
Old 08-07-2009, 10:43 AM   #9
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Okey dokey. Downloaded the 17+Mb version, which includes all of the libraries, and bingo, it all compiles and builds first time. So that's good enough for me, at least for now anyway.
It would be nice to know why the smaller download fails when trying to locate the Expat libs, and maybe when I have some extra time I might do more digging, but for now at least, all is again at peace.
 
1 members found this post helpful.
Old 02-07-2012, 04:08 AM   #10
Wario.
Member
 
Registered: Feb 2012
Location: Italy
Distribution: Slackware (newbie)
Posts: 45

Rep: Reputation: Disabled
Hi everybody,
I'm trying to install Audacity using slackbuild packages, but I have the same problem with expat
So I've searched on google for the 17Mb package that includes all the libraries needed, but I couldn't manage to find it.
Please, can someone write the link?

Thanks

Last edited by Wario.; 02-07-2012 at 04:10 AM.
 
Old 02-07-2012, 11:09 PM   #11
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 2,499

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
It's the last file on this list:

http://sourceforge.net/projects/auda...y-beta/1.3.14/

audacity-fullsrc-1.3.14-beta.tar.bz2

Last edited by rkelsen; 02-07-2012 at 11:11 PM.
 
Old 02-08-2012, 05:38 AM   #12
Wario.
Member
 
Registered: Feb 2012
Location: Italy
Distribution: Slackware (newbie)
Posts: 45

Rep: Reputation: Disabled
Thanks!
I'm sorry but I have another problem...

1) I've tried to compile "audacity-fullsrc-1.3.14-beta.tar.bz2" using Slackbuils, but it returned some errors during the execution of "./configure".
So I've chosen to compile it manually, but the error is the same:
" ./configure: line 366: test: required: integer expression expected...
./configure: line 263: return: required: numeric argument requested.. ecc..."


2) I've decided to try with an old version of Audacity, 1.3.10, but now the problem is:
" Your version of portaudio doesn't include required functions"

Please, can you suggest me what should I do?
Cheers
 
Old 07-03-2012, 04:32 PM   #13
darkcity
LQ Newbie
 
Registered: May 2010
Posts: 18

Rep: Reputation: 7
Audacity may give 'Audacity requires expat to be enabled' error when wxGTK (wxwidgets) isn't installed correctly, that's what my experience was.
 
Old 07-03-2012, 05:15 PM   #14
Alchemikos
Member
 
Registered: Jun 2012
Location: Porto Alegre-Brazil
Distribution: Slackware- 14, Debian Wheezy, Ubuntu Studio, Tails
Posts: 88

Rep: Reputation: 6
I installed my Audacity via gslapt/slapt-get then all worked fine.
I ever go there first, before SBO.

I'm a slack too heheheh

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot run Audacity : "Audacity is already running" tuanito Linux - Software 8 03-17-2016 02:05 PM
xmmintrin.h SSE not enabled slackware 12.0 and audacity xaos5 Slackware 3 01-17-2008 06:25 PM
slackware Eleven install Audacity sound editor? Ed_999 Slackware 4 01-15-2007 11:06 AM
Slackware 11 - Audacity 1.3.2 bgeddy Slackware 10 11-10-2006 05:45 AM
how to install audacity in slackware 10.0 alm3 Linux - Software 1 04-15-2006 07:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration