-   Slackware (
-   -   Slackware 12.1: Fixed IP Address Not Working (

tronayne 05-19-2008 06:07 PM

Slackware 12.1: Fixed IP Address Not Working
I installed Slackware 12.1 on a Dell Inspiron 6000 (laptop) -- a clean install, not an upgrade -- and I cannot communicate with any internal server or the network printer; I can ping the gateway ( and I can ping "myself" ( or by name, "snafu") with no problems. I cannot ping another server ( or printer ( although I can, strangely, ping (both with and without packet losses). I have the addresses and names of the servers and printer in /etc/hosts and I have the network configured exactly as it was with Slackware 12.0 -- I use fixed IP and have done so with this machine and this local network configuration for some years; same netmask, same gateway (a Linksys router), same everything (from, I think, Slackware 10.x through 11.x and 12.0).

The output of ifconfig -a, netstat -rn and everything else I can think of looks like I expect it to; all the pertinent stuff I can think of looks like below.

Is there some funky thing about Slackware 12.1 that I've missed? I do know that the wireless stuff came up without prompting but that doesn't seem to appear here.

Any help is deeply appreciated.

ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:12:f0:98:45:1e
        inet addr:  Bcast:  Mask:
        inet6 addr: fe80::212:f0ff:fe98:451e/64 Scope:Link
        RX packets:2278 errors:0 dropped:0 overruns:0 frame:0
        TX packets:884 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:1991692 (1.8 MiB)  TX bytes:60047 (58.6 KiB)
        Interrupt:17 Base address:0x8000 Memory:dfdfd000-dfdfdfff

eth1      Link encap:Ethernet  HWaddr 00:12:3f:da:8d:74
        BROADCAST MULTICAST  MTU:1500  Metric:1
        RX packets:0 errors:0 dropped:0 overruns:0 frame:0
        TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
        inet addr:  Mask:
        inet6 addr: ::1/128 Scope:Host
        UP LOOPBACK RUNNING  MTU:16436  Metric:1
        RX packets:4 errors:0 dropped:0 overruns:0 frame:0
        TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:372 (372.0 B)  TX bytes:372 (372.0 B)
netstat -rn
Kernel IP routing table
Destination    Gateway        Genmask        Flags  MSS Window  irtt Iface  U        0 0          0 eth0      U        0 0          0 lo        UG        0 0          0 eth0

# Config information for eth0:

# Config information for eth1:

# Config information for eth2:

# Config information for eth3:

# Default gateway IP address:

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
(everything else is commented out)

# For loopbacking.              localhost   snafu   fubar            InkJet

# End of hosts.

search com

onebuck 05-19-2008 07:20 PM


How do you have your DNS setup?

search com <<<- what's this?

tronayne 05-19-2008 10:26 PM

Uh, the "com" is the local domain name (at least that's what I've had in resolv.conf for... well, quite a while -- like years -- with no problems). If I remember right the network wizard at work (who managed about fifty Sun servers) said to stick that in the search list and the manual page seems to bear that out. Could, of course, be dead wrong about that (and the machine I'm writing this on has exactly that in resolv.conf and has since 10.x (I think).

Took that out, doesn't work for squat. Odd thing -- I can ping the system by name or address and it's fine; I can ping the gateway, it's fine; I ping either of the other services ( or and "Destination Host Unreachable."

I dunno.

allend 05-20-2008 12:43 AM

Perhaps you could try blacklisting the ipv6 module. Appears to have helped some others.

tronayne 05-20-2008 06:28 AM

OK, tried blacklisting ipv6, rebooted, no joy in Mudville (thing won't even ping the gateway).

So, I'm wondering... I installed the default kernel. This thing is a laptop (and everybody knows that laptops are weird) and I'm pretty sure it's a Pentium (bearing in mind that Slackware 12.0 worked just fine with the SMP kernel) and maybe I should have used a different kernel? Right now I'm reinstalling (yeah, using the same default kernel) just in case I did something stupid without realizing it).

This one has me stumped.

[stinger] 05-20-2008 06:52 AM

Would I be correct to assume eth1 is the wireless card (that is not configured)?

If so, I don't see why this is coming up at all in the output of ifconfig (based on the snippit of rc.inet1.conf you showed). Again, if this is true, try disabling the radio with the function keys on the laptop keyboard and restart rc.inet1 (or reboot) and see if you get an ifconfig output without eth1 listed. Then see if you can reach these other addresses.

What wireless card are you (not) using?

randomsel 05-20-2008 07:14 AM


Originally Posted by tronayne (Post 3158465)
I can ping the gateway ( and I can ping "myself" ( or by name, "snafu") with no problems. I cannot ping another server ( or printer ( although I can, strangely, ping (both with and without packet losses).

If you can ping, then the network is working, so the problem lies somewhere else.
  • Do you have iptables enabled?
  • Can you ping "yourself" from the server
  • Can you open webpages (just to verify that the network's working)
  • Are the machines in the same switch/VLAN?
  • Is the correct module for the NIC loading? Does it need firmware?

You can also use nmap to scan for present hosts on the network.

tronayne 05-20-2008 07:45 AM

I did a complete reinstall (this time the Ethernet cables was not plugged in during installation, only difference, an I can not imagine why that would have mattered).

The machine can talk to the LAN, talk to the world, what the heck talk to the animals as far as I know. Why it works now and did not work previously, I do not know, alas.

Thank you to all for your time and effort (and I wrote down all those great hints for future reference, too).

All is well that ends.

All times are GMT -5. The time now is 01:06 AM.