Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 05-14-2008, 07:24 AM   #1
LQ Newbie
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Slackware 12.1 Dell D520 notebook detects HD as sda vs hda


Estou tentando instalar o slackware 12.1 em um notebook dell d520. Ele está detectando o HD como /dev/hda. Na versão anterior (12.0) ele detectava como /dev/sda.

Ao tentar formatar a partição a instalação trava e nao consigo ir adiante. Tem algum parametro que eu possa passar na hora do boot para fazer com que o proc4esso de instalação detecte meu HD como SATA??

Luiz Fernando
Old 05-14-2008, 07:41 AM   #2
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
Speak english.
Old 05-14-2008, 07:47 AM   #3
LQ Newbie
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
oopss.. really sorry about that. I've posted the same message in a Brazilian forum...


I'm trying to install slackware 12.1 in a D520 dell notebook. The installation process is detecting my HD as /dev/hda. In previous version (12.0) it detected as /dev/sda.

When I try to format the partition the installation process hangs up and I'm not able to even finish it. Is there any parameter that I can pass at boot time in order to make the installation process to detect by HD as SATA (/dev/sda) instead of IDE (/dev/hda)

Any help is welcomed!

Luiz Fernando
Old 05-14-2008, 09:22 AM   #4
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,692

Rep: Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017Reputation: 4017

When starting the installation, add the string "hda=noprobe" (minus the quotes) to the boot command. For instance, if you do not have to add further parameters, you would boot the Slackware installer with this commandline instead of just pressing <ENTER>:
hugesmp.s hda=noprobe
This will cause your disk to be recognized as sda again and enable DMA as well. Did you notice how slow disk access was when the disk was recognized as hda? That is because DMA is turned off and there is no way to turn it back on.
At the end of the installation when you get to the LILO configuration dialogs, you will see the prompt to add additional parameters:
Some systems might require extra parameters to be passed to the kernel.
If you needed to pass parameters to the kernel when you booted the
Slackware bootdisk, you'll probably want to enter the same ones here.
Most systems won't require any extra parameters.
If you don't need any, just hit ENTER to continue
Here, you have to enter again
so that your system will assign sda to your harddisk when it boots.

This issue is covered in the CHANGES_AND_HINTS.TXT file too, please read the documentation that comes with Slackware! We do not write these for fun.

Old 05-15-2008, 09:41 AM   #5
LQ Newbie
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
tks! it worked!
Old 07-24-2008, 11:10 AM   #6
LQ Newbie
Registered: Jul 2008
Distribution: Slackware64 14.2
Posts: 20

Rep: Reputation: 0
I'm not finding why but since I changed from Slackware 12 to 12.1 my notebook hp 6715s is reallly sloooow during boot at the "Replaying journal.." for the non-root partitions.

Thought it was caused by the same problem that howlerbr was having but no effect at all. Some idea?

I'm using Reiserfs...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
sda-> hda linuxgentoo Linux - Kernel 2 04-22-2008 06:06 AM
Dell D520 Issues rahulthewall3000 Linux - Laptop and Netbook 1 02-28-2008 03:18 AM
Why sda* and not hda* ? hepburnenthorpe Arch 9 06-27-2007 05:18 PM
/hda to /sda - help! dodgydodgy Linux - General 9 10-20-2006 07:07 PM
hda? sda? what do i have? nr5 Linux - Newbie 12 02-24-2005 07:50 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration