-   Slackware (
-   -   slackware 11.0 and no keyboard response (

mscole 10-04-2006 10:22 AM

slackware 11.0 and no keyboard response
As a Slackware fan I hate to rain on the 11.0 parade, but I just installed 11.0 last night, and when I tried to log in as root for the first time, I got no response from the keyboard, and was unable to log in. Ctrl+Alt+Delete did not work either. I did a hard reboot, and found that the keyboard does work at the lilo prompt. I installed the default choice for the kernel from the cdrom installation (I think it is called sata.i). The keyboard is ps2, the cpu is an old celeron. Everything worked under 10.2. Any suggestions?

slackware_newbie 10-04-2006 10:47 AM

Do you use gpm?

mscole 10-04-2006 11:09 AM

Yes, but I used it in 10.2 with no problem.

mscole 10-04-2006 10:18 PM

Ok, slackware_newbie, just for laughs I re-installed without enableing gpm, and for even more yucks, I chose the huge 2.6 kernel, and what do you know, it worked (don't forget to install the 2.6 kernel modules from cd 2 under /extra). And even with the huge kernel, it's a lot faster than 10.2, kernel 2.4, on my old celeron. Thanks for the lead.

delryn 10-08-2006 09:44 AM

I had a similar problem, no mouse(usb) or kbd(ps2) at login

Also tried the huge image - without gpm, but still had the same problem

I have seen this same problem on 3-4 different forums,
Anyone know what is wrong?
Or have a suggestion for a possible work around?

dcdbutler 10-08-2006 11:17 AM

I had the same problem using the bare kernel from the cd. I was able to ssh in though and configure everything that way. Only problem, I put in some firewall rules and managed to lock myself out of ssh :mad:

So, I reinstalled and noticed the kbd program from slackware/a which I hadn't installed the first time round. So I installed it this time and then my keyboard worked when I rebooted. That's about the only thing I did different and it shouldn't have made a difference (my keyboard is US), but maybe it did for some reason.:scratch:


mscole 10-08-2006 08:13 PM

I think the problem I had was gpm, because I installed first with huge26.s and gpm, no keyboard response. I then re-installed with sata.i and gpm, no keyboard response. Then I re-installed with huge26.s, no gpm, and it worked.

tomrobla 10-29-2006 01:01 AM

I had the same problem. bare.i with gpm locks up keyboard. bare.i without gpm, keyboard works and you can login. If you issue command #gpm -m /dev/psaux -t ps2 ... the keyboard locks up
worked in 10.1

rtra 10-29-2006 08:36 AM

I've this problem when I run gpm or xorg, but only whem I'm using the IMPS/2 or PS/2 drivers without the a mouse connected on the computer. If I choose the "microsoft" serial driver, or plug a mouse, everything works ok.

Anyway, when it looks up I just ssh from another machine to kill gpm or the X, and the keyboards starts working again.

linuxgeek01 10-30-2006 04:35 AM

I am having the same problem and everything was fine with Slackware 10.2. Once I installed Slackware 11 and booted the default sata.i kernel, GPM would load and suddenly I get scrambled text "^[ ^[ ^[ ^[" all the way down to the Login: This also disables my keyboard from working. If I boot into single mode by typing 'linux single' without the quotes, it works fine. I have tried disabling GPM and that seems to fix it but I need GPM working so I can use the mouse/keyboard in X. Is there a workaround for this? Something new that I need to install? Thanks

All times are GMT -5. The time now is 10:04 AM.