-   Slackware (
-   -   Slackware 10 error compiling kernel 2.6.7 (

nirvanix 06-28-2004 02:48 PM

Slackware 10 error compiling kernel 2.6.7
Hi Slackers,

I've installed Slackware 10 without problems, then installed the generic kernel 2.6.7 also without problems. It all works fine. But I'm trying to compile my own custom version of 2.6.7 (with preemptive Athlon config) and follow the correct procedures as far as I know. Everything goes fine (make xconfig, make bzImage, make modules, make modules_install) until I run the
mkinitrd -c -k 2.6.7 -m reiserfs as described in the documentation. That's when I get the error 'this kernel doesn't know about loop devices (try modprobe loop)'. I try the modprobe loop and it fails. If I try to boot with my new kernel I get a kernel panic telling me it can't load the fs which is reiserfs) because the version magic control is wrong. I can't see anything wrong with my procedure so I'm wondering if anyone else is experiencing this?


nirvanix 06-28-2004 03:31 PM

Hi again,

Solved my own problem, but maybe someone can benefit from the answer: The generic kernel has the loop device configured as a MODULE, therefore before you start customizing the kernel do a 'modprobe loop' to load this module, otherwise you won't be able to do a mkinitrd later on after you've done the compile steps.

edyoung 05-30-2006 12:50 AM

Use a newer version
1.9 is pretty old now. I'd recommend trying 2.14 instead.

edyoung 05-30-2006 12:52 AM

Apologies, disregard previous post - it went to the wrong thread.

All times are GMT -5. The time now is 05:17 AM.